Bug Hunting Session
Bug 124414 - Image is partly displayed when printing (to PDF) two pages per sheet (Linux-only)
Summary: Image is partly displayed when printing (to PDF) two pages per sheet (Linux-o...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: notBibisectable, regression
Depends on:
Blocks:
 
Reported: 2019-03-29 05:17 UTC by Fred Lemire
Modified: 2019-10-26 18:31 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
I isolated the page with the image that doesn't print. (25.63 KB, application/vnd.oasis.opendocument.text)
2019-04-01 05:52 UTC, Fred Lemire
Details
output (126.56 KB, application/pdf)
2019-04-09 12:47 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fred Lemire 2019-03-29 05:17:13 UTC
Description:
I have a 295 pages document with about 10 images appearing here and there in it. There is one, though, that doesn't print. It appears fine in the LibreOffice document, but the PDF doesn't contain the image, just its frame.

Actual Results:
I open my document, I select Print in the menu, I chose to print in a file, I ask that there are to pages printed side to side (1 2) : Tadam ! One image is missing.

Expected Results:
Image not present in the PDF.


Reproducible: Always


User Profile Reset: No



Additional Info:
Put the image in it, like all the others.
Comment 1 Timur 2019-03-29 13:26:18 UTC
Please attach the document OR better try to make a minimal anonymized sample document that reproduces the bug and preferably attach that one.
Would be nice if you could also test with master https://dev-builds.libreoffice.org/daily/master/.
Comment 2 Fred Lemire 2019-04-01 05:52:50 UTC
Created attachment 150436 [details]
I isolated the page with the image that doesn't print.

I would like to attach the PDF with the missing image too, but apparently, I can attach only ONE document here. Anyway, the bug doesn't occur when I print only one page per sheet, but it comes back when I print TWO pages per sheet of paper.
Comment 3 Fred Lemire 2019-04-05 21:30:18 UTC
Comment on attachment 150436 [details]
I isolated the page with the image that doesn't print.

Are you working on this case ?
Comment 4 Xisco Faulí 2019-04-09 12:45:04 UTC
Reproduced in

Version: 6.3.0.0.alpha0+
Build ID: 040a54d89e8ca33171e86647ced8dc58efd85fbe
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Xisco Faulí 2019-04-09 12:47:34 UTC
Created attachment 150622 [details]
output
Comment 6 Xisco Faulí 2019-04-09 12:53:48 UTC
Also reproduced in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.15; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)
Comment 7 Buovjaga 2019-04-09 13:50:28 UTC
Print to file as PDF with two pages per sheet works with the last commit of Linux 50max bibisect repo
Comment 8 Fred Lemire 2019-04-09 14:43:52 UTC Comment hidden (obsolete)
Comment 9 Buovjaga 2019-04-09 16:04:31 UTC
(In reply to Fred Lemire from comment #8)
> And where can I find that commit ? Is that an earlier version of LibreOffice
> ? Or has the bug been fixed in the 6.2.2.2 version ?

https://wiki.documentfoundation.org/QA/Bibisect/Linux

Xisco confirmed it in comment 4 with 6.3, so it has not been fixed.

I just tested on Windows and could not reproduce.
Comment 10 BogdanB 2019-04-10 15:11:56 UTC
Working in my case.

Version: 6.3.0.0.alpha0+
Build ID: 84d4125b28c384f9ac6285737a5bb9093978798e
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-04-06_20:07:58
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 11 Fred Lemire 2019-04-12 05:40:22 UTC
(In reply to Xisco Faulí from comment #5)
> Created attachment 150622 [details]
> output

That's not the output that I obtained. In my case, there was just the image's frame (that was well centered and sized, contrarily to this output) that appeared.

Also, if possible, I would like not to return to a much older version, for, with version 5.1.6.2, I had other bugs at print time (garbage appearing here and there on the printed pages, seemingly randomly). Those problems disappeared when I switched to version 6.2.2.2 — except for the one this whole thread is about.

Finally, when you suggest to download a specific version, could you provide as well the link where it dwells ? I would fear, by just looking up a given version number, to find something irrelevant, or faulty.

Remember that I run under Ubuntu 16.04 LTS.

Thanks, you all !

Fred Lemire
Comment 12 Buovjaga 2019-04-12 07:54:18 UTC
An easy way to try old ones is using appimages: https://libreoffice.soluzioniopen.com/index.php/old-versions/
You just have to make them executable files and run them.
Comment 13 raal 2019-04-20 07:36:11 UTC Comment hidden (obsolete)
Comment 14 Buovjaga 2019-04-20 09:44:31 UTC Comment hidden (obsolete)
Comment 15 raal 2019-04-20 18:41:46 UTC
(In reply to Buovjaga from comment #14)
> 
> Are you sure you selected "pages per sheet: 2"? I still repro.
> 
my fault, sorry. Reproduced.
Comment 16 Timur 2019-10-25 14:58:45 UTC Comment hidden (obsolete)
Comment 17 Buovjaga 2019-10-25 15:06:49 UTC
(In reply to Timur from comment #16)
> I tried to bibisect in5.2 but after first bad, I just get "Application
> Error".
> What I am supposed, to say skip dozen times or more? 
> I cannot believe that 5.2 is in such a lousy condition. 

If the bisect issue happens so early on, we can just call this notBibisectable.
Comment 18 Timur 2019-10-26 18:31:46 UTC
Application Error is not related to this file, I can't start LO at all. I tried dozen times and quit.