Download it now!
Bug 124430 - Child Textbox separates from shape when align action is used
Summary: Child Textbox separates from shape when align action is used
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All All
: medium minor
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard: target:7.1.0 target:7.0.3
Keywords: implementationError
: 127628 (view as bug list)
Depends on:
Blocks: Object-Selection-Alignment Shape-Textbox
  Show dependency treegraph
 
Reported: 2019-03-29 15:18 UTC by Bastián Díaz
Modified: 2020-10-16 21:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (2.56 KB, image/png)
2019-03-29 15:22 UTC, Bastián Díaz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bastián Díaz 2019-03-29 15:18:53 UTC
Description:
Textbox and shape are separated when using align (anchored to page, paragraph, etc.). Textbox is reattached to the shape when using DND.

Steps to Reproduce:
1.Insert a shape
2.Select shape, open context menu and go to "Add textbox"
3.Write or insert an object (ex. Table)
4.Select shape, open context menu and go to "Align|right or left, etc"

Actual Results:
Textbox is kept in the original place while the shape is located on the right, left, center, etc.

Expected Results:
Textbox stays into the shape, in the same way when using DND


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Bastián Díaz 2019-03-29 15:22:00 UTC
Created attachment 150398 [details]
screenshot
Comment 2 mulla.tasanim 2019-03-29 22:22:59 UTC
Thank you for reporting the bug.

I can confirm that the bug is present in

Version: 6.2.1.2 (x64)
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL


Version: 6.3.0.0.alpha0+ (x64)
Build ID: 91cdf22b88a4f7bec243c8fb187627e766d3294c
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-08_00:38:10
Locale: en-US (en_US); UI-Language: en-US
Calc: CL
Comment 3 Buovjaga 2019-04-22 15:40:55 UTC
Prior to 6.2, the Align context menu contained "No selection possible" and in the menu Format - Align, the items are disabled. In 5.4, the context menu had the entries, but nothing happens when using them. 5.3.0 had "No selection possible".

In even older versions, there is no context menu entry to add text box.
Comment 4 Commit Notification 2020-07-27 09:57:17 UTC
Bakos Attila committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/06fd06597796d9e92117602245f3968c93707708

tdf#124430 Writer Editing: Fix textbox aligning

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 NISZ LibreOffice Team 2020-09-11 10:43:08 UTC
*** Bug 127628 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2020-10-16 09:08:56 UTC
Bakos Attila committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/d7b67e6fe3e449c8c5b95a57d8cc7b9ca70c7a99

tdf#124430 Writer Editing: Fix textbox aligning

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2020-10-16 19:37:28 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 06fd06597796d9e92117602245f3968c93707708
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Attila Bakos, thanks for fixing this issue!!