Bug 124432 - Impress SlideShow fails on dual screen use
Summary: Impress SlideShow fails on dual screen use
Status: RESOLVED DUPLICATE of bug 119719
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Slide-Show
  Show dependency treegraph
 
Reported: 2019-03-29 15:51 UTC by AtesComp
Modified: 2019-08-30 06:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen shown when starting slide show. (20.51 KB, image/png)
2019-03-29 15:53 UTC, AtesComp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description AtesComp 2019-03-29 15:51:42 UTC
Description:
On a dual monitor setup (or more), using "Start from First Slide - F5" (or F5) initially an "soffice.bin" application appears on the same monitor with a black screen and scrollbars.  Picking anywhere in the "soffice.bin" application presents the presenter's view screen.  The full screen slide show screen is NOT displayed on any screen.  The "Slide Show Settings -> Multiple Display -> Presentation Display" is set to "Auto External (Display 2)".  Using an application flipper shows that the full screen slide show screen is behind the presenter's view screen.  Additionally, the mouse or other pointer device may not operate the slide show depending on which screen is shown.

Issue where found when connecting to a Crestron controlled display.  Reproduced on a local triple screen display.  Both where using a Kubuntu based laptop.


Steps to Reproduce:
1. Start LibreOffice Impress
2. Open a presentation
3. Start a slideshow on a dual monitor system

Actual Results:
Black application/dialog screen filling initial screen with scrollbars.  Picking anywhere on the screen displays the presenter's view.  An "alt-tab" shows the slide show screen is behind the presenter's view.

Expected Results:
Starting the presentation should have placed the slide show screen on a second display and the presenter's view on the initial screen as in version 6.1.5.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version 6.1.5 works correctly.  Versions 6.2.1 and 6.2.2 fail.
Changing the "Tools -> Options -> View -> Graphics Output -> Use OpenGL for all rendering" (on or off) does not help.
Changing the "Tools -> Options -> View -> User Interface -> Icon Style" does not help.
Changing the "Tools -> Options -> OpenCL -> Allow use of OpenCL" (on or off) does not help.
No combinations of changes for the above help.
Using "Restart in safe mode..." does not help.
----------
Version: 6.2.2.2
Build ID: 1:6.2.2-0ubuntu0.18.04.1~lo1
CPU threads: 8; OS: Linux 4.15; UI render: GL; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 AtesComp 2019-03-29 15:53:36 UTC
Created attachment 150399 [details]
Screen shown when starting slide show.
Comment 2 AtesComp 2019-03-29 16:14:49 UTC
Changing "Slide Show - > Slide show Settings -> Multiple Displays -> Presentation display"  does not help.  Seting to specific monitors results in the same above on F5.

Changing "Slide Show - > Slide show Settings -> Multiple Displays -> Presentation display" to "All displays" crashes LibreOffice on F5.
Comment 3 AtesComp 2019-03-29 19:23:30 UTC
This bug may be related to bug 124044.

Changing the VCL via tests using "SAL_USE_VCLPLUGIN=xxx libreoffice" does not help.  Used "qt5", "kde5", "kde4", "gtk", "gtk2", "gtk3", "gtk3_kde5", "kde", and "gen".  "gen" failed to start libreoffice.
Comment 4 AtesComp 2019-03-29 20:07:13 UTC
Tested using Libreoffice 6.2.3:

Version: 6.2.3.0.0+
Build ID: e019441cb0507fd533fe7114c6a1ea17e2c10aa6
CPU threads: 8; OS: Linux 4.15; UI render: GL; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time: 2019-03-29_08:58:31
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

This version slightly improves the problem.  The initial black screen when starting the slide show is no longer present and immediately shows the presenter's view.  The slide show is still in another window below the presenter's view window and does not use the dual (or more) screen.

Occasionally, after ending the presentation, the the application shows one or more unresponsive (cannot close) "soffice.bin" window displaying the presenter's view.  This is most noticeable if the "Exchange" button in the presenter's view is used one or more times.  Closing the main application window closes the other "soffice.bin" windows.

Tested the following with no improvement:
opt/libreofficedev6.2/program/soffice
SAL_USE_VCLPLUGIN=kde4     opt/libreofficedev6.2/program/soffice
SAL_USE_VCLPLUGIN=kde5     opt/libreofficedev6.2/program/soffice
SAL_USE_VCLPLUGIN=qt5      opt/libreofficedev6.2/program/soffice
SAL_USE_VCLPLUGIN=gtk3     opt/libreofficedev6.2/program/soffice
SAL_USE_VCLPLUGIN=kde5_qt5 opt/libreofficedev6.2/program/soffice
Comment 5 AtesComp 2019-03-29 20:33:56 UTC
Tested using Libreoffice 6.3.0:

Version: 6.3.0.0.alpha0+
Build ID: 1e2868296730d3548574f61a3c6e323aa5c0598a
CPU threads: 8; OS: Linux 4.15; UI render: GL; VCL: qt5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-03-28_20:38:05
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Slight improvement over version 6.2.3.0.0+ -- the unresponsive (cannot close) "soffice.bin" windows did not show up.

Changing "Slide Show - > Slide show Settings -> Multiple Displays -> Presentation display"  does not help.  Setting to specific monitors results in the same above on F5. 

Changing "Slide Show - > Slide show Settings -> Multiple Displays -> Presentation display" to "All displays" STILL crashes LibreOffice on F5.
Comment 6 AtesComp 2019-03-29 22:13:45 UTC
FYI TESTING
-----------
Tested using Libreoffice 6.1.5:

Version: 6.1.5.2
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: en-US (en_US.UTF-8); Calc: group threaded

Works as expected...mostly.  The "Presenter" view is always set to Display 1 (or first enabled display).  Generally not a problem, but would be nice to be able to set for Multiple Displays which display is "Presentation" and which is "Presenter".  I would expect the "Presenter" to default to the display with the active application window unless set in the options, but that's me.

Tested the following with same results:
opt/libreoffice6.1/program/soffice
SAL_USE_VCLPLUGIN=gen opt/libreoffice6.1/program/soffice
SAL_USE_VCLPLUGIN=gtk opt/libreoffice6.1/program/soffice
SAL_USE_VCLPLUGIN=kde4 opt/libreoffice6.1/program/soffice

The "gen" and "kde4" differed from "gtk" for deciding which "Presentation" display was 2 and 3.
For all, the "Presenter" display was always 1 unless the "Presentation" was set to 1.
Comment 7 Michael Weghorn 2019-03-30 08:45:41 UTC
With regard to qt5 and kde5, this sounds like bug 119719, which has been fixed.
However, there was also some issue in the Qt library; at least Qt 5.10 is required for this to work if you're on KDE Plasma.

What Qt version are you using?

Is this on X11 or Wayland?

I'm surprised to hear that gtk3 is affected as well. Can you please copy the "Help" -> "About" info you get with "SAL_USE_VCLPLUGIN=gtk3" set?

(In reply to AtesComp from comment #4)
> Tested using Libreoffice 6.2.3:
> [...]
> This version slightly improves the problem.  The initial black screen when
> starting the slide show is no longer present and immediately shows the
> presenter's view.  [...]

Yes, that's been fixed in the meanwhile.


(In reply to AtesComp from comment #5)
> Changing "Slide Show - > Slide show Settings -> Multiple Displays ->
> Presentation display" to "All displays" STILL crashes LibreOffice on F5.

I can reproduce this with kde5 (works OK with gtk3). Can you please open a separate bug report for this?
Comment 8 AtesComp 2019-04-01 17:40:39 UTC
System:
* KDE Plasma
* X11
* Qt version: 5.9.5 (current for Kubuntu 18.04)

I expect, as you say, this is the issue and needs Qt 5.10+.

NOTE: I'm reluctant to upgrade at the moment due to possible package dependencies and breakage issues.

ALSO: The Libreoffice GTK packages were not installed.  My prior tests were apparently defaulting back to KDE5.  Maybe there should be a warning message when VCL is set to one option (or the "SAL_USE_VCLPLUGIN" environment variable is set) and Libreoffice decides to use some other VCL?

Sorry, I was just too quick to get the testing done without checking all the other elements.  As such, I retested with the proper Libreoffice packages installed: libreoffice-gtk2, libreoffice-gtk3.

--------------------
Test 1:
--------------------
SAL_USE_VCLPLUGIN=gen soffice

Version: 6.2.2.2
Build ID: 1:6.2.2-0ubuntu0.18.04.1~lo1
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

This seems to work!  Apparently, one or both of the GTK packages installed fixes the "gen" failure in comment 3.

--------------------
Test 2:
--------------------
SAL_USE_VCLPLUGIN=gtk soffice

Version: 6.2.2.2
Build ID: 1:6.2.2-0ubuntu0.18.04.1~lo1
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

This seems to work!

--------------------
Test 3:
--------------------
SAL_USE_VCLPLUGIN=gtk3 soffice

Version: 6.2.2.2
Build ID: 1:6.2.2-0ubuntu0.18.04.1~lo1
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

This seems to work!

--------------------
Test 4:
--------------------
SAL_USE_VCLPLUGIN=kde5 soffice

Version: 6.2.2.2
Build ID: 1:6.2.2-0ubuntu0.18.04.1~lo1
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

This fails, of course, as expected!

--------------------

@Michael Weghorn: Thanks for the reality check!!!

However, I'm not sure why the local installs of:
* Libreoffice 6.2.3
* Libreoffice 6.3.0
failed when using the "SAL_USE_VCLPLUGIN=gtk3" setting.  I would expect the package installs for these.

Rerunning...

--------------------
Test 5:
--------------------
SAL_USE_VCLPLUGIN=gtk3 opt/libreofficedev6.2/program/soffice

Version: 6.2.3.0.0+
Build ID: e019441cb0507fd533fe7114c6a1ea17e2c10aa6
CPU threads: 8; OS: Linux 4.15; UI render: GL; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time: 2019-03-29_08:58:31
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

This seems to work!

--------------------
Test 6:
--------------------
SAL_USE_VCLPLUGIN=gtk opt/libreofficedev6.2/program/soffice

Version: 6.2.3.0.0+
Build ID: e019441cb0507fd533fe7114c6a1ea17e2c10aa6
CPU threads: 8; OS: Linux 4.15; UI render: GL; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-2, Time: 2019-03-29_08:58:31
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

This had a weird dark color or theme problem that made it impossible to see menus and buttons.  I just got the version above.

--------------------
Test 7:
--------------------
SAL_USE_VCLPLUGIN=gen opt/libreofficedev6.2/program/soffice

This would not run.  It looked like Libreoffice was starting, but then kicked back to the prompt without any error message.
Comment 9 Michael Weghorn 2019-04-03 16:49:03 UTC
Thanks for retesting and the additional information! And for creating bug 124484 for the crash case.

(In reply to AtesComp from comment #8)
> System:
> * KDE Plasma
> * X11
> * Qt version: 5.9.5 (current for Kubuntu 18.04)
> 
> I expect, as you say, this is the issue and needs Qt 5.10+.

Let's mark this bug as a duplicate of bug 119719 then.

> 
> NOTE: I'm reluctant to upgrade at the moment due to possible package
> dependencies and breakage issues.
> 
> ALSO: The Libreoffice GTK packages were not installed.  My prior tests were
> apparently defaulting back to KDE5.  Maybe there should be a warning message
> when VCL is set to one option (or the "SAL_USE_VCLPLUGIN" environment
> variable is set) and Libreoffice decides to use some other VCL?

I already do get such a warning when I start from command line, e.g.

  $ SAL_USE_VCLPLUGIN=asdfasdfasdf ./instdir/program/soffice --writer
  warn:vcl.plugadapt:31111:31111:vcl/source/app/salplug.cxx:115: could not load shared object libvclplug_asdfasdfasdflo.so


> However, I'm not sure why the local installs of:
> * Libreoffice 6.2.3
> * Libreoffice 6.3.0
> failed when using the "SAL_USE_VCLPLUGIN=gtk3" setting.  I would expect the package installs for these.

As far as I know, they're in some libobasis<VERSION>-gnome-integration package, so you have to install that one (and it seems you did so in the meantime).

*** This bug has been marked as a duplicate of bug 119719 ***
Comment 10 AtesComp 2019-08-29 22:01:57 UTC
Due to postings on the duplicate bug, I will rerun tests in this bug post in the near future, if that will help?
Comment 11 AtesComp 2019-08-30 00:07:04 UTC
This is using Kubuntu 19.04.1 as shown below, so not LTS.  I'll do the same tests on 18.04 LTS later.

===Tests===

Baseline:
  Version: 6.3.0.4
  Build ID: 1:6.3.0-0ubuntu0.19.04.1~lo1
  CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: kde5; 
  Locale: en-US (en_US.UTF-8); UI-Language: en-US
  Calc: threaded

 1. libreoffice --impress xxx.odp
    Reports "VCL: kde5"
    No dual screen issue.

 2. SAL_USE_VCLPLUGIN=qt5 libreoffice --impress xxx.odp
    Reports "VCL: qt5"
    No dual screen issue.

 3. SAL_USE_VCLPLUGIN=kde libreoffice --impress xxx.odp
    Reports "VCL: kde5"
    No dual screen issue.

 4. SAL_USE_VCLPLUGIN=kde4 libreoffice --impress xxx.odp
    Reports "VCL: kde5" (Yes, KDE5)
    No dual screen issue.

 5. SAL_USE_VCLPLUGIN=kde5 libreoffice --impress xxx.odp
    Reports "VCL: kde5"
    No dual screen issue.

 6. SAL_USE_VCLPLUGIN=gtk libreoffice --impress xxx.odp
    Reports "VCL: gtk2" on unreadable black screen
    For dual screen, the "Next Slide" display element was black.
    Reports various "Gdk-WARNING"s

 7. SAL_USE_VCLPLUGIN=gtk2 libreoffice --impress xxx.odp
    Reports "VCL: kde5" (Yes, KDE5)
    No dual screen issue.

 8. SAL_USE_VCLPLUGIN=gtk3 libreoffice --impress xxx.odp
    Reports "VCL: gtk3"
    No dual screen issue.
> (soffice:7109): dbind-WARNING **: 18:32:52.617: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
> (soffice:7109): Gdk-WARNING **: 18:32:52.738: XSetErrorHandler() called with a GDK error trap pushed. Don't do that.

 9. SAL_USE_VCLPLUGIN=gtk3_kde5 libreoffice --impress xxx.odp
    Reports "VCL: kde5" (Yes, KDE5)
    No dual screen issue.

10. SAL_USE_VCLPLUGIN=gen libreoffice --impress xxx.odp
    Reports "VCL: x11"
    For dual screen, the "Next Slide" display element was black.

===Oddities===
"kde4" reports kde5, obviously kde4 is not installed
"gtk" reports gtk2
"gtk2" reports kde5 (?), so no issues
"gtk3_kde5" reports kde5, not sure if gtk3 is used
Black about screens and "Next Slide" on "gtk" and "gen"
Comment 12 Michael Weghorn 2019-08-30 06:00:09 UTC
Thanks for retesting.

(In reply to AtesComp from comment #11)
> ===Oddities===
> "kde4" reports kde5, obviously kde4 is not installed

kde4 VCL plugin has been removed in favor of kde5/kf5, since qt4 and kde4 are dead upstream.

> "gtk" reports gtk2

That's expected. And gtk2 is about to be removed soon as well, so I don't think it's worth spending much effort there.

> "gtk2" reports kde5 (?), so no issues

"SAL_USE_VCLPLUGIN=gtk2" does not map to any VCL plugin, so the default is used (which is "kde5" if you're running Plasma). (I guess the gtk/gtk2 naming is like this for some "historical" reason, but don't know.)

> "gtk3_kde5" reports kde5, not sure if gtk3 is used

If it's actually gtk3_kde5, it dos report so. Maybe it's not installed?

> Black about screens and "Next Slide" on "gtk" and "gen"

It properly shows the next slide for me on Debian testing with a current development build of LibreOffice's master git branch...