Bug Hunting Session
Bug 124484 - Impress crashes on slide show using "All displays"
Summary: Impress crashes on slide show using "All displays"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Katarina Behrens (CIB)
URL:
Whiteboard: target:6.3.0 target:6.2.5
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-04-01 18:59 UTC by AtesComp
Modified: 2019-05-31 21:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Dialog after starting slideshow (32.85 KB, image/png)
2019-04-01 19:01 UTC, AtesComp
Details
GDB backtrace with master as of commit bac831c8f5fb5c50ddddfb2458498fb9564c127a (13.60 KB, text/plain)
2019-04-02 11:52 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description AtesComp 2019-04-01 18:59:59 UTC
Description:
When the VCL is set to KDE5, Libreoffice crashes on a slideshow (F5) when the Slide Show Settings -> Multiple Displays -> Presentation display is set to "All displays".

Steps to Reproduce:
1. Open Impress with any presentation
2. If not already set, set Slide Show Settings -> Multiple Displays -> Presentation display to "All displays"
3. Start slide show.

Actual Results:
Libreoffice crashes with recovery dialog.

Expected Results:
Displayed slideshow on all screens depending on screen configuration.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 6.2.2.2
Build ID: 1:6.2.2-0ubuntu0.18.04.1~lo1
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 AtesComp 2019-04-01 19:01:31 UTC
Created attachment 150468 [details]
Dialog after starting slideshow
Comment 2 Xisco Faulí 2019-04-01 21:27:06 UTC
Hello AresComp,
Does it happen if you launch LibreOffice with SAL_USE_VCLPLUGIN=gtk3 ?
Comment 3 Michael Weghorn 2019-04-02 06:14:29 UTC
Confirmed, s. bug 124432 comment 7. Thanks for opening this new bug report for this.

This is specific to the kde5 VCL plugin, doesn't happen with gtk3.
Comment 4 Katarina Behrens (CIB) 2019-04-02 11:38:03 UTC
Anybody has a backtrace?
Comment 5 Michael Weghorn 2019-04-02 11:52:14 UTC
Created attachment 150481 [details]
GDB backtrace with master as of commit bac831c8f5fb5c50ddddfb2458498fb9564c127a

(In reply to Katarina Behrens (CIB) from comment #4)
> Anybody has a backtrace?

Backtrace attached.
Comment 6 AtesComp 2019-04-02 15:52:19 UTC
FYI: Using "All displays" with other modes (gtk, gtk3, gen) displays as one big display instead of several independent displays with duplicate slide shows.  I expect kde5 will do the same.

1. This may be due to the DE's display control.  The displays are not "unified", so I would expect them to be seen as independent.  Using "unified" should duplicate the screens as expected (untested).

2. This may be due to the graphics driver.  Nvidia has a "X screen 0" consisting of all the display as well as individual displays within it.  The slide show is probably detecting the "one display to rule them all"(tm).

NOTE: This probable needs to be reported as another bug.
Comment 7 Katarina Behrens (CIB) 2019-04-03 09:34:49 UTC
TIL this Multiple Displays setting exists at all
Comment 8 Commit Notification 2019-05-10 15:26:06 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/758c44f69f0a0ed4a501695de4f065824325e750%5E%21

tdf#124484: avoid crash in fullscreen slideshow spanning all displays

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Katarina Behrens (CIB) 2019-05-10 15:29:56 UTC
Peeps this bug is not fixed yet. The above just makes the crash go away. Needs more work to figure out how to make window w/ slideshow span multiple displays
Comment 10 Commit Notification 2019-05-31 11:22:37 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/6f613f973dcb86dbebc212bc466fbaa2b002655b%5E%21

tdf#124484: resize slideshow window so it spans all displays

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-05-31 21:29:57 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/c9e0fb864850fa434c4aa5c58960fac1fb382108%5E%21

tdf#124484: avoid crash in fullscreen slideshow spanning all displays

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2019-05-31 21:30:03 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/ae5b453eb63d08f8aba471d8263bff84be80c8aa%5E%21

tdf#124484: resize slideshow window so it spans all displays

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.