Bug Hunting Session
Bug 124440 - IDE & Calc crash opening Breakpoint Management (gen)
Summary: IDE & Calc crash opening Breakpoint Management (gen)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All All
: highest critical
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.1.6 target:6.2....
Keywords: bibisected, bisected, needUITest, regression
: 124487 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-03-30 03:58 UTC by John Donohue
Modified: 2019-04-04 15:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["SalInstanceSpinButton::SalInstanceSpinButton(FormattedField *,SalInstanceBuilder *,bool)"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Donohue 2019-03-30 03:58:01 UTC
This bug was filed from the crash reporting server and is br-993c03a2-36c9-4892-82a9-9f312d70bd6c.
=========================================
I have a total of 5 crash dumps available dated 5/15 thru 5/29 related to this problem.

Calc and IDE crashed when clicking on IDE breakpoint management icon.  It has occurred at least three different sessions when I tried to bring up the breakpoint management form to delete a breakpoint. It started when the 6.2.1.2 version was installed on 3/13.  The toggle breakpont icon works OK, but no longer allows adding additional breakpoints during a run when paused at a preexisting breakpoint.

Installed latest version of LO on 3/13
Running: LibreOffice Version: 6.2.1.2 (x64)
Build ID: 7bcb35dc3024a62dea0caee87020152d1ee96e71
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: CL 

OS: wIN 10 Home, v. 1803, build 17134.648
Comment 1 raal 2019-03-30 12:48:38 UTC
I can not confirm with Version: 6.3.0.0.alpha0+
Build ID: 82463bdde75447d45e0cd6ed9ab579e0e51ea912
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 

I can run Manage breakpoint dialog without crash. I can add breakpoint during program run (with icon or double-click).
Comment 2 Xisco Faulí 2019-03-30 16:30:16 UTC
Steps to reproduce:
1. Open writer/calc ( gen )
2. Go to tools - Macros - Edit Macros
3. Run - Manage Breakpoints
-> Crash

Regression introduced by:

author	Caolán McNamara <caolanm@redhat.com>	2019-01-09 13:05:16 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2019-01-10 12:54:38 +0100
commit	3f1e853b7b6d63f4e6fea70a5ef0aa94668ab16e (patch)
tree	b58e38cb4d54719ea01137a7a120150e0b5cf6ca
parent	42b3f8f57ad7cdb26fb8acb139c71ae1470a0b94 (diff)
Resolves: tdf#122348 make return in spinbutton signal value change
before going on to close the dialog afterwards

Bisected with: bibisect-linux64-6.2

Adding Cc: to Caolán McNamara

Setting severity to critical as it's reproducible in LibreOffice 6.1.5
Comment 3 Commit Notification 2019-04-01 13:59:57 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/07da6d9ed7ed15c661850eef275157648497181d%5E%21

Resolves: tdf#124440 nospin has no subedit

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Caolán McNamara 2019-04-01 14:32:22 UTC
fixed in master, backports in gerrit
Comment 5 Xisco Faulí 2019-04-01 21:23:56 UTC
*** Bug 124487 has been marked as a duplicate of this bug. ***
Comment 6 Xisco Faulí 2019-04-01 21:34:26 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: 5f04be8d385f100d0775549cbdd7295cec1d1423
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!!
Comment 7 Commit Notification 2019-04-01 21:37:06 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/b3b23df6ffdfefab7b2369c8330ed7fd8ac85424%5E%21

Resolves: tdf#124440 nospin has no subedit

It will be available in 6.1.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-04-02 08:59:41 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/2c150f952fb75da271648bf76c3a1bbf32bd25da%5E%21

Resolves: tdf#124440 nospin has no subedit

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-04-04 15:11:27 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-3":

https://git.libreoffice.org/core/+/0b3ceaaf9bddd74aa61e8ab934caa68a7238e405%5E%21

Resolves: tdf#124440 nospin has no subedit

It will be available in 6.2.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.