Bug Hunting Session
Bug 124476 - Calc occasionally crashes on File --> Open
Summary: Calc occasionally crashes on File --> Open
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE Java-Runtime-JRE
  Show dependency treegraph
 
Reported: 2019-04-01 15:58 UTC by Owen Savill
Modified: 2019-05-22 14:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Crash GDB log (59.12 KB, text/plain)
2019-04-01 15:58 UTC, Owen Savill
Details
Crash log when using Java 8 (51.25 KB, text/x-log)
2019-04-01 16:03 UTC, Owen Savill
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Savill 2019-04-01 15:58:48 UTC
Created attachment 150462 [details]
Crash GDB log

Log attached, appears to be throwing an exception in Java code. The JRE that ships with Ubuntu 18.04 is OpenJDK 11. I'll try the same with Oracle's Java 8.
Comment 1 Owen Savill 2019-04-01 16:03:05 UTC
Scrap that, I think it was just a thread report not an assert. Anyway, attached in the log using Java 8.
Comment 2 Owen Savill 2019-04-01 16:03:43 UTC
Created attachment 150463 [details]
Crash log when using Java 8
Comment 3 Xisco Faulí 2019-04-02 09:34:50 UTC
Could you please paste the info from Help - about LibreOffice ?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' once the information has been provided
Comment 4 Owen Savill 2019-04-02 10:40:10 UTC
Version: 6.2.2.2
Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
CPU threads: 8; OS: Linux 4.20; UI render: GL; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: CL
Comment 5 Roman Kuznetsov 2019-04-03 11:53:25 UTC
(In reply to Owen Savill from comment #4)
> Version: 6.2.2.2
> Build ID: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
> CPU threads: 8; OS: Linux 4.20; UI render: GL; VCL: kde5; 
> Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
> Calc: CL

Can you disable option "Use a Java runtime environmant" in dialog Tools->Options->LibreOffice->Advanced and try repeat your crash?
Comment 6 Michael Weghorn 2019-04-03 15:06:45 UTC
(In reply to Roman Kuznetsov from comment #5)
> Can you disable option "Use a Java runtime environmant" in dialog
> Tools->Options->LibreOffice->Advanced and try repeat your crash?

Yes, that would be really helpful, since the SIGSEGV from the JVM in the backtrace may be totally unrelated since the JVM uses SIGSEGV as a "normal way of communication".

The backtrace suggests that you're using a build of LibreOffice master. To get a more helpful backtrace, it would be great if you could use a daily master build with debug symbols, available at [1].
You can also install that in parallel to your existing version, s. [2].

Also, does this happen only happen when selecting specific files in "File" -> "Open"?

[1] https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@86-TDF-dbg/
[2] https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 7 Owen Savill 2019-04-04 12:22:22 UTC
Disabling Java seems to stop the crashing.
Comment 8 Roman Kuznetsov 2019-04-04 12:46:06 UTC
(In reply to Owen Savill from comment #7)
> Disabling Java seems to stop the crashing.

Do you use any extensions in your LibreOffice?
Comment 9 Roman Kuznetsov 2019-04-04 12:50:48 UTC
try add to kernel parameter "stack_guard_gap=1" before start OS and try retest your bug with enabled JRE in LibreOffice
Comment 10 Xisco Faulí 2019-04-04 13:00:44 UTC
bug 108619 is only happening in 32 bits...
Comment 11 Xisco Faulí 2019-04-16 08:12:22 UTC
Hi Michael Weghorn,
Is this the same issue as bug 124652 ?
Comment 12 Michael Weghorn 2019-04-16 10:41:13 UTC
(In reply to Xisco Faulí from comment #11)
> Hi Michael Weghorn,
> Is this the same issue as bug 124652 ?

No, bug 124652 only affected the gtk3_kde5 VCL plugin, while this one here mentions kde5 in comment 4.
Comment 13 Xisco Faulí 2019-05-21 11:05:59 UTC
Hello Owen Savill,
LibreOffice 6.2.4 is going to be released tomorrow. Could you please check it to this version? I'm wondering if it's related to bug 124503 which is fixed on that version...
Comment 14 Owen Savill 2019-05-22 14:31:48 UTC
I cannot reproduce this in 6.2.4
Comment 15 Xisco Faulí 2019-05-22 14:32:59 UTC
(In reply to Owen Savill from comment #14)
> I cannot reproduce this in 6.2.4

Thanks for retesting with the latest version.
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.