Bug 124565 - FILESAVE: Pasted row height is reset by after saving and reopen
Summary: FILESAVE: Pasted row height is reset by after saving and reopen
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Vasily Melenchuk (CIB)
URL:
Whiteboard: target:6.3.0 target:6.2.5
Keywords: bibisected, bisected, regression
: 125159 (view as bug list)
Depends on:
Blocks: Regressions-row-height
  Show dependency treegraph
 
Reported: 2019-04-05 12:35 UTC by Ilhan Yesil
Modified: 2019-05-07 19:59 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ilhan Yesil 2019-04-05 12:35:49 UTC
Steps to reproduce:

1. Create a new calc spreadsheet document.
2. Enlarge the first row by height
3. Type in a single character into first cell
4. Select first row and copy it
5. Paste copied row into second row
6. Notice the row heights of the first and second row by opening the "Row Height" dialog (For this go to menu "Format->Rows->Height...") and take attention to close this dialog with "Cancel"

   Result: first and second row have identical heights

7. Save the document, close and reopen it.
   
   Result: the first row has saved it's height, but the seconds height is resetted

8. Repeat steps 1 to 6, but instead closing the dialog with "Cancel" close it with "Ok"
9. Repeat step 7

   Result: now also seconds row height is saved


Expectation: I think that the document should save the row heights either if I change a row height manually or by pasting.
Comment 1 Oliver Brinzing 2019-04-05 15:56:33 UTC
> Result: the first row has saved it's height, but the seconds height is resetted

reproducible with:

Version: 6.3.0.0.alpha0+ (x64)
Build ID: df30a4515b1303b0891baa53754fa9b3e47e0c02
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

Version: 6.1.5.2 (x64)
Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: 

but *not* reproducible with:

Version: 6.0.7.3 (x64)
Build-ID: dc89aa7a9eabfd848af146d5086077aeed2ae4a5
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc:
Comment 2 Oliver Brinzing 2019-04-05 16:21:19 UTC
seems to have started with:

https://gerrit.libreoffice.org/plugins/gitiles/core/+/693953dd4699887bd3f5bca2c3582b5fae1d6992

commit 693953dd4699887bd3f5bca2c3582b5fae1d6992 [log]
author	Vasily Melenchuk <Vasily.Melenchuk@cib.de>Fri Apr 06 20:19:10 2018 +0300
committer Katarina Behrens <Katarina.Behrens@cib.de>Mon Oct 22 23:30:23 2018 +0200
tree 2091b2fe8d997ef84f149ace1e6a1f00fd8e08fe
parent fad764c02c7a9cd210bfa44ea0ce1ac5354d6427 [diff]

tdf#62268: allow row height recalculation on document load

During document load rows with style:use-optimal-row-height="true"
should recalculate it's height.

 * includes: Row height tolerance level increase for unittest
 * tdf#118086: calc: invalid row autoheight fixed

Change-Id: Ib38b5b753d9ff8352116d77851d228c5d77bd530
Reviewed-on: https://gerrit.libreoffice.org/52521
Reviewed-by: Katarina Behrens <Katarina.Behrens@cib.de>
Tested-by: Jenkins <ci@libreoffice.org>
Reviewed-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
(cherry picked from commit 1e55a47e89a9d9d6cf9cb3993484022aaf2c097b)
Reviewed-on: https://gerrit.libreoffice.org/61898
Tested-by: Jenkins

/cygdrive/d/sources/bibisect/bibisect-win32-6.1
$ git bisect log
# bad: [1d66cc00ca6fd2e562cbed88704051b2f5d989e3] source sha:8d2abb388b0a2423c9b7e1f52373e1b06dd9786f
# good: [29d08f54c2f71ffee4fe12dbb24c5f5cbedecfd2] source sha:6eeac3539ea4cac32d126c5e24141f262eb5a4d9
git bisect start 'master' 'oldest'
# good: [3ac46f6c41b5044f162a451b10af0dc5afdcc113] source sha:22c7c3f54dbb93f856190c561b2540064c5a767d
git bisect good 3ac46f6c41b5044f162a451b10af0dc5afdcc113
# good: [63fc3e0d41dd91f9fb3fe9891e009451285d9619] source sha:13a1bc409d9b2f0d14f4d316b7977b1fc2eb3c8a
git bisect good 63fc3e0d41dd91f9fb3fe9891e009451285d9619
# good: [6a75149c2bee2fa1c01b36aef4b734ceee7bc025] source sha:91d8af2c5cf4e8ec0f1ce0e532e0c896de77750b
git bisect good 6a75149c2bee2fa1c01b36aef4b734ceee7bc025
# good: [6440df548810a3adf5f7d125fe738467a5db7891] source sha:76c0b3c516f6b0d43136522b4d476eb60211cec1
git bisect good 6440df548810a3adf5f7d125fe738467a5db7891
# good: [809628c3decd16dacc705bda20efc603037667bf] source sha:3c20597ada7f74a4a96dec841264593fdbf0bcd5
git bisect good 809628c3decd16dacc705bda20efc603037667bf
# good: [0a5440cd08992f83f20aab2bcaa2b3e0be434d23] source sha:2c2ecb7eaa448f33162ce60154af207228ac05a8
git bisect good 0a5440cd08992f83f20aab2bcaa2b3e0be434d23
# good: [00b943e017c148697e3b4ab3c938edcb07e6a33a] source sha:e67ca59e293c4dd37795150cf871e36ca1affb76
git bisect good 00b943e017c148697e3b4ab3c938edcb07e6a33a
# bad: [521ff466935054556620576a8782a459686f955e] source sha:7a6e6d027ad41350ae1334d3e60dc1a6ce96c508
git bisect bad 521ff466935054556620576a8782a459686f955e
# bad: [07b7831aa81932b8a8cca5253d25a0d0157085b1] source sha:d860e6a138f08343b42f591462e85b85291b6fa8
git bisect bad 07b7831aa81932b8a8cca5253d25a0d0157085b1
# bad: [df5f87f82cc03697cc4d16b8700b35f667e6c948] source sha:5e582b7755c9d1e7e358cf5734c8b93d5219622d
git bisect bad df5f87f82cc03697cc4d16b8700b35f667e6c948
# bad: [15b060764ee7934c58786891fab4d0f38a09498e] source sha:5de85be43198804573787d4186b156b5931c4a9f
git bisect bad 15b060764ee7934c58786891fab4d0f38a09498e
# good: [180656b1b8aed5295a44cbacded98f37e45f5f1d] source sha:fad764c02c7a9cd210bfa44ea0ce1ac5354d6427
git bisect good 180656b1b8aed5295a44cbacded98f37e45f5f1d
# bad: [40ab4a5cf85d27950e409bd4af0086cd98213719] source sha:693953dd4699887bd3f5bca2c3582b5fae1d6992
git bisect bad 40ab4a5cf85d27950e409bd4af0086cd98213719
# first bad commit: [40ab4a5cf85d27950e409bd4af0086cd98213719] source sha:693953dd4699887bd3f5bca2c3582b5fae1d6992
Comment 3 Commit Notification 2019-05-03 20:44:57 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/7ca7d61dc25f409e209b3a432c7f07469b17e316%5E%21

tdf#124565: calc: copy/paste manual row height

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Xisco Faulí 2019-05-06 16:06:46 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: ddea172792d13516ff7e0dd43f1f78b74ade8914
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Vasily, thanks for fixing this issue!!

backported to 6-2 branch -> https://gerrit.libreoffice.org/#/c/71873/
Comment 5 Commit Notification 2019-05-07 10:12:02 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/9c9e8055987f9d707784a1d12eec6bba22c4b01e%5E%21

tdf#124565: calc: copy/paste manual row height

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2019-05-07 19:59:11 UTC
*** Bug 125159 has been marked as a duplicate of this bug. ***