Bug Hunting Session
Bug 124650 - Crash opening DOC file
Summary: Crash opening DOC file
Status: RESOLVED DUPLICATE of bug 124593
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: Java-Runtime-JRE
  Show dependency treegraph
 
Reported: 2019-04-10 10:47 UTC by Jonny Grant
Modified: 2019-04-12 14:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
gdb log (33.81 KB, text/x-log)
2019-04-10 10:47 UTC, Jonny Grant
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonny Grant 2019-04-10 10:47:41 UTC
Created attachment 150657 [details]
gdb log

Logging this. As no one is working on the other crash ticket logged against 6.2 fresh install. I won't re-install 6.2, you can investigate using the stacktrace  seems to be openjdk?

Just use latest Ubuntu LTS, default install.

Thread 1 "soffice.bin" received signal SIGSEGV, Segmentation fault.
0x00007f2f26bcf520 in ?? ()
#0  0x00007f2f26bcf520 in  ()
#1  0x0000000000000206 in  ()
#2  0x00007f2f26bcf280 in  ()
#3  0x00007f2f40b8cccc in  () at /usr/lib/jvm/java-11-openjdk-amd64/lib/server/libjvm.so
#4  0x00007fffffd88ca0 in  ()
#5  0x00007f2f4062f8a9 in  () at /usr/lib/jvm/java-11-openjdk-amd64/lib/server/libjvm.so



Version: 6.0.7.3
Build ID: 1:6.0.7-0ubuntu0.18.04.2
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); Calc: group

If no one wants to work on this crash. Just close the ticket.

DOC is confidential, but if you want it, drop me an email so you can reproduce.
Comment 1 Jonny Grant 2019-04-10 10:48:25 UTC
Would be nice if libreoffice gdb script could be updated 

/usr/lib/libreoffice/program/gdbtrace:9: Error in sourced command file:
No stack.
Comment 2 Xisco Faulí 2019-04-10 11:49:21 UTC
Hello Jonny Grant,
Could you please send the document to me ?
Does the crash only happen with that document ?
Comment 3 Jonny Grant 2019-04-10 12:03:14 UTC
Emailed you.

Steps to reproduce. I reproduced it twice to be sure it was repeatable.

1. $ soffice --backtrace
2. Open calc
3. Double click on three XLS files
4. Double click on DOC file

I removed the openjdk packages from ubuntu, it now does not crash.
Comment 4 Roman Kuznetsov 2019-04-11 20:41:23 UTC
Java problem is here by comment 3
Comment 5 Xisco Faulí 2019-04-12 09:55:52 UTC
Seems related to bug 124593

*** This bug has been marked as a duplicate of bug 124593 ***
Comment 6 Jonny Grant 2019-04-12 14:57:10 UTC
Except this isn't a duplicate of Bug 124593 - OutputDevice::LogicToPixel

What can I say - I don't work on this project. Only a developer should be closing tickets after reproducing the crash.