Bug 124697 - LOdev crashes after closing Tip of the Day dialog
Summary: LOdev crashes after closing Tip of the Day dialog
Status: RESOLVED DUPLICATE of bug 124238
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Assert Tip-Of-The-Day
  Show dependency treegraph
 
Reported: 2019-04-12 07:40 UTC by Stephan van den Akker
Modified: 2019-05-13 10:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace of debug build after crash (4.78 KB, text/plain)
2019-04-12 07:40 UTC, Stephan van den Akker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan van den Akker 2019-04-12 07:40:46 UTC
Created attachment 150707 [details]
Backtrace of debug build after crash

LOdev crashes after closing Tip of the Day.

After loading a document the Tip of the Day dialog appears. Closing it in any way (OK button, Close button on the title bar) crashes LOdev. Tested with Writer, Calc and Draw.

Using the "Next Tip" button works (no crash).

Happens in:

Version: 6.3.0.0.alpha0+
Build ID: e74bbefcd7048723b0cf2a3a775e2d84bf171591
CPU threads: 4; OS: Linux 4.12; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded
(Pull request Thusday 11 April 2019)

Does not happen in (Tip of the Day is not active):

Version: 6.3.0.0.alpha0+
Build ID: 9575aa3bba055258977d9a013889aa3acbaecb6a
CPU threads: 4; OS: Linux 4.12; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded
(Pull request Tuesday 9 April 2019)

It's a debug build, so I got back trace info on the command line (see attachment)
Comment 1 Xisco Faulí 2019-04-12 09:18:11 UTC
I can't reproduce it in

Version: 6.3.0.0.alpha0+
Build ID: 90b13c2c406ec2cdddfa6580edb401c0d07feae6
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Do you reproduce it if you launch LibreOffice with SAL_USE_VCLPLUGIN=gtk3 ?
Comment 2 Stephan van den Akker 2019-04-12 10:25:18 UTC
Crash also happens with the gtk3 backend.
Comment 3 Xisco Faulí 2019-04-12 10:45:57 UTC
that's weird.
To be certain the reported issue is not
related to corruption in the user profile, could you please reset your
Libreoffice profile ( https://wiki.documentfoundation.org/UserProfile ) and
re-test?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the issue is still present
Comment 4 Heiko Tietze 2019-04-12 11:00:54 UTC
Caolan submitted a patch this morning after it was reported yesterday evening.

*** This bug has been marked as a duplicate of bug 124238 ***