Bug 124721 - Crash in sw::UpdateFramesForRemoveDeleteRedline(SwDoc &,SwPaM const &)
Summary: Crash in sw::UpdateFramesForRemoveDeleteRedline(SwDoc &,SwPaM const &)
Status: VERIFIED DUPLICATE of bug 117185
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard:
Keywords:
: 124739 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-04-13 13:45 UTC by Xisco Faulí
Modified: 2019-07-29 12:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["sw::UpdateFramesForRemoveDeleteRedline(SwDoc &,SwPaM const &)"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-04-13 13:45:58 UTC
Steps to reproduce:
1. Open attachment 57526 [details] from bug 46441
2. Select all
3. Copy
4. Paste
5. Undo

Reproduced in

Version: 6.3.0.0.alpha0+
Build ID: 3b518953a8141b0d5043c2f3996a92956fdc3a47
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Xisco Faulí 2019-04-13 13:47:34 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d258fc29560baa5ecae03ebc2740e11420643e27

author	Michael Stahl <Michael.Stahl@cib.de>	2018-09-03 18:07:29 +0200
committer	Michael Stahl <Michael.Stahl@cib.de>	2018-09-19 10:18:29 +0200
commit	d258fc29560baa5ecae03ebc2740e11420643e27 (patch)
tree	b934fcbe96f5f433e05f365edc438499de63d671
parent	f32075fd7404dba62ae844cff84fdb43a91ac600 (diff)
sw_redlinehide_2: update frames on redline ops

Bisected with: bibisect-linux64-6.2

Adding Cc: to Michael Stahl
Comment 2 Oliver Brinzing 2019-04-13 16:02:53 UTC
reproducoble with:

Version: 6.2.3.1 (x64)
Build-ID: 9ba025bafb03b962c34687cf87806cc03a3a7436
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc:
Comment 3 Michael Stahl (CIB) 2019-04-16 09:49:54 UTC
doesn't look like a regression from sw_redlinehide; 6.1 and 6.0 have the same assert as master:

soffice.bin: libreoffice-6-1/sw/source/core/txtnode/thints.cxx:1265: bool SwTextNode::InsertHint(SwTextAttr*, SetAttrMode): Assertion `pAttr && pAttr->GetStart() <= Len()' failed.

the problem is that this frame (anchored at-char in the last node of the document) is duplicated on Undo:

[ 162]  0x8008160           StartNode , 
[ 163]   0x8013e20           TextNode "Ek wil net graag hiermee  baie dankie se aan die CPF -  Gerna, Robert en Eksteen.  Ek waardeer jul onbaatsugtige hulp.  Julle entoesiasme en ondersteuning  sal my bybly. Dit is nogal gerusstellend om te weet sulke mense is net 'n telefoon- of radio-oproep ver!  Ek kan julle verseker dat my man julle ook ewig dankbaar is!  Dit mag volgende keer dalk nie 'n onskadelike slang wees nie!", 
[ 164]   0x8015f70           TextNode "", 
[ 165]   0x80161a0           TextNode "Mercia Engelbrecht", 
[ 166]  0x80109e0             EndNode , 

subsequently the node indexes are offset and crash is inevitable; the assert is because the hint from Undo is inserted on the wrong node.

this reminds me of bug 107975 and 2903d85d6197829633d7f96c95cd55821c2c20ff
Comment 4 Xisco Faulí 2019-04-16 09:58:21 UTC
Hi Michael,
Yes, it seems related.
However, in a production version, it doesn't crash before d258fc29560baa5ecae03ebc2740e11420643e27
e.g.

Versió: 6.1.4.2
ID de la construcció: 1:6.1.4-0ubuntu0.16.04.1~lo2
Fils de CPU: 4; SO: Linux 4.15; Renderitzador de la IU: per defecte; VCL: gtk3; 
Configuració local: ca-ES (ca_ES.UTF-8); Calc: group threaded

while it crashes after it... Maybe it just revealed another way to reproduce bug 117215
Comment 5 Michael Stahl (CIB) 2019-04-16 10:29:59 UTC
*** Bug 124739 has been marked as a duplicate of this bug. ***
Comment 6 Michael Stahl (CIB) 2019-07-22 11:21:34 UTC
fixed on master

*** This bug has been marked as a duplicate of bug 117185 ***
Comment 7 Xisco Faulí 2019-07-29 12:28:13 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 0d36b32755ac662299e6a8165e9fa57311b74a2f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Michael Stahl, thanks for fixing this issue!