Download it now!
Bug 124738 - Writer: crash after pasting ToC to the whole selected document
Summary: Writer: crash after pasting ToC to the whole selected document
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0 all versions
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks: Paste Crash
  Show dependency treegraph
 
Reported: 2019-04-14 19:13 UTC by Xisco Faulí
Modified: 2020-07-01 11:30 UTC (History)
7 users (show)

See Also:
Crash report or crash signature: ["SwHistory::Add(SwTextAttr *,unsigned long,bool)"]


Attachments
bt with debug symbols (14.14 KB, text/plain)
2019-06-12 19:40 UTC, Julien Nabet
Details
simplified document to reproduce the crash (36.12 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-06-14 14:22 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-04-14 19:13:21 UTC
Steps to reproduce:
1. Open attachment 94362 [details] from bug 75208
2. Select all
3. Copy
4. Paste

-> Crash

Reproduced in

Version: 6.3.0.0.alpha0+
Build ID: 3b518953a8141b0d5043c2f3996a92956fdc3a47
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 2 Aron Budea 2019-04-15 04:05:57 UTC
Confirmed using LO 6.3.0.0.alpha0+ (3fe3bd8a90d6dc53b05b9236185af3916fc5375d) / Windows 7.

Bibisected to the following commit using repo bibisect-win32-4.3.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=9679e9c23216decb5f9f25f85b04cb3f25211111
author		Vinaya Mandke <vinaya.mandke@synerzip.com>	2013-12-30 16:22:30 +0530
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2014-01-03 09:37:58 +0100

fdo#69649 Fix for pre-rendered Table Of Contents
Comment 3 Xisco Faulí 2019-04-17 16:25:18 UTC
Hi Miklos,
I thought you might be interested in this crash... We have 1317 crashes in https://crashreport.libreoffice.org/stats/signature/SwHistory::Add(SwTextAttr%20*,unsigned%20long,bool) and Vinaya Mandke is no longer around...
Comment 4 Julien Nabet 2019-06-12 19:40:29 UTC
Created attachment 152144 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I got an assert.
Comment 5 Xisco Faulí 2019-06-14 14:22:16 UTC
Created attachment 152193 [details]
simplified document to reproduce the crash
Comment 6 Xisco Faulí 2019-06-14 14:23:54 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2019-06-14 15:27:04 UTC
(In reply to Xisco Faulí from comment #6)
> The crash can be reproduced like
> 1. Open the simplified document
> 2. Select all
> 3. delete

This is an older regression ( besides, the commit in comment 2 is about TOC ).
Regression introduced in range https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=1cdb792368ed26d58828eead2848422e7dec4c7d..77987eacff20dec40caf29aae61d262239d441e9
Comment 8 Xisco Faulí 2019-07-29 14:31:38 UTC
@Michael, I thought you might be interested in this issue...
Comment 9 Telesto 2020-01-03 19:52:58 UTC
No repro with
Version: 6.5.0.0.alpha0+ (x64)
Build ID: 42a1a1c6b91907f81e15066ffab219411f18c4db
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: GL; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 10 Aron Budea 2020-01-05 11:03:20 UTC
(In reply to Telesto from comment #9)
> No repro with
> Version: 6.5.0.0.alpha0+ (x64)
> Build ID: 42a1a1c6b91907f81e15066ffab219411f18c4db
I can confirm the case with the simplified document (comment 5 and comment 6) got fixed with the following commit:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=81112d875f1c29f1244e7f283f90d56cfbe5b5b4

I'm not sure what the situation is with this issue, there's the original description, and there's comment 5 and comment 6, bibisected to different changes. The steps in the description can't even be completed now, as there's a crash after step 3, bug 129805 has been opened on that.
Comment 11 Timur 2020-01-05 12:57:17 UTC
We had two bugs here, 2nd (that should've been separate) is fixed and 1st is not, so we are at the original bug that can now be tested like this:
1. Open attachment 94362 [details] from bug 75208
2. Select content of pages 7-8 with ToC and copy
3. Select all 178 pages in DOCX
4. Paste copied from step 2.

-> Crash
Comment 12 Xisco Faulí 2020-01-07 14:37:52 UTC
Steps from description are still standing

Version: 6.5.0.0.alpha0+
Build ID: bf540873f5e258452fed5006f65a403c95e7872a
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

The reason why I didn't create another report was that both crashes share the same crash signature < SwHistory::Add(SwTextAttr *,unsigned long,bool) >
Comment 13 Buovjaga 2020-05-10 15:05:47 UTC
No repro of desc / comment 11

Version: 7.0.0.0.alpha0+ (x64)
Build ID: 00db5933ded1884b2ac453552badae20fa943478
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded
Comment 14 Telesto 2020-05-10 16:56:58 UTC
No repro with comment 11. However.. 
> 1. Open attachment 94362 [details] from bug 75208
> 2. Select content of pages 7-8 with ToC and copy
3. CTRL+N
4. CTRL+V
5. CTRL+Z

https://crashreport.libreoffice.org/stats/crash_details/631c9a2c-4e52-4dfb-a9c7-af9495eb7e44

But not sure if another report is needed..
Comment 15 Telesto 2020-05-10 16:58:09 UTC
(In reply to Xisco Faulí from comment #12)
> Steps from description are still standing
> 
> Version: 6.5.0.0.alpha0+
> Build ID: bf540873f5e258452fed5006f65a403c95e7872a
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
> Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> The reason why I didn't create another report was that both crashes share
> the same crash signature < SwHistory::Add(SwTextAttr *,unsigned long,bool) >

No repro with
Version: 6.4.3.2 (x64)
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 16 Telesto 2020-05-10 17:02:30 UTC
(In reply to Telesto from comment #14)
> No repro with comment 11. However.. 
> > 1. Open attachment 94362 [details] from bug 75208
> > 2. Select content of pages 7-8 with ToC and copy
> 3. CTRL+N
> 4. CTRL+V
> 5. CTRL+Z
> 
> https://crashreport.libreoffice.org/stats/crash_details/631c9a2c-4e52-4dfb-
> a9c7-af9495eb7e44
> 
> But not sure if another report is needed..

Can be done for the whole document also
CTRL+A
CTRL+C
CTRL+N
CTRL+V
CTRL+Z

Same BigPtr...
Comment 17 Xisco Faulí 2020-07-01 11:19:15 UTC
(In reply to Xisco Faulí from comment #12)
> Steps from description are still standing
> 
> Version: 6.5.0.0.alpha0+
> Build ID: bf540873f5e258452fed5006f65a403c95e7872a
> CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
> Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
> Calc: threaded
> 
> The reason why I didn't create another report was that both crashes share
> the same crash signature < SwHistory::Add(SwTextAttr *,unsigned long,bool) >

Not reproducible since https://cgit.freedesktop.org/libreoffice/core/commit/?id=cf226535f9903a048b1c105b180ae3a50a776e68

Closing as VERIFIED FIXED. For similar issue. please, create a follow-up ticket
Comment 18 Xisco Faulí 2020-07-01 11:30:06 UTC
(In reply to Aron Budea from comment #10)
> (In reply to Telesto from comment #9)
> > No repro with
> > Version: 6.5.0.0.alpha0+ (x64)
> > Build ID: 42a1a1c6b91907f81e15066ffab219411f18c4db
> I can confirm the case with the simplified document (comment 5 and comment
> 6) got fixed with the following commit:
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=81112d875f1c29f1244e7f283f90d56cfbe5b5b4

which also fixed bug 124397 and it already has a unittest in https://git.libreoffice.org/core/commit/d49df68ec4807f31df4fb3cdaa0448405ef40a29