Bug 124800 - Phonetic guide is empty
Summary: Phonetic guide is empty
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CJK-Japanese
  Show dependency treegraph
 
Reported: 2019-04-17 15:55 UTC by Army_bloodcore
Modified: 2021-03-21 16:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Kanji reading map (453.29 KB, application/pdf)
2020-06-08 16:21 UTC, Army_bloodcore
Details
Kanji list (333.95 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-06-08 16:22 UTC, Army_bloodcore
Details
Wrong furigana borders (8.52 KB, image/png)
2020-07-25 02:35 UTC, Army_bloodcore
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Army_bloodcore 2019-04-17 15:55:23 UTC
Description:
When I typing a kanji in an openoffice writer document, furigana values stays empty.

Steps to Reproduce:
1. Write in openoffice simple japanese kanji word like 平仮名 or 音読み or 訓読み or 就職センター
2. Open the phonetic guide for this words.
3. Try to fill this

Actual Results:
Openoffice sais that readings are empty. 
平仮名: (nothing)
音読み: (nothing)
訓読み: (nothing)
就職センター: (nothing)

Expected Results:
Real readings, for example:
平仮名:ひらがな[hiragana]
音読み:おんよみ[on'yomi/onnyomi/onyomi]
訓読み:くんよみ[kun'yomi/kunnyomi/kunyomi]
就職センター:しゅうしょくせんたー[shuushokusenta:/shuushokusentaa/shuushokusenta-]




Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Add dictionary in future version
Comment 1 Xisco Faulí 2019-04-17 15:59:08 UTC
Could you please paste the info from Help - about LibreOffice ?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' once the information has been provided
Comment 2 Army_bloodcore 2019-04-22 15:33:30 UTC
(In reply to Xisco Faulí from comment #1)
> Could you please paste the info from Help - about LibreOffice ?
> 
> I have set the bug's status to 'NEEDINFO'. Please change it back to
> 'UNCONFIRMED' once the information has been provided
No, I cannot, in MS office this feature is enabled, why you cannot enable this also in LibreOffice?
Comment 3 QA Administrators 2019-05-08 21:50:09 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2019-05-08 21:59:20 UTC
(In reply to Army_bloodcore from comment #2)
> (In reply to Xisco Faulí from comment #1)
> > Could you please paste the info from Help - about LibreOffice ?
> > 
> > I have set the bug's status to 'NEEDINFO'. Please change it back to
> > 'UNCONFIRMED' once the information has been provided
> No, I cannot, in MS office this feature is enabled, why you cannot enable
> this also in LibreOffice?

Please, provide the Info requested, otherwise we can't triage this issue
Comment 5 Army_bloodcore 2019-07-22 18:36:23 UTC
(In reply to Xisco Faulí from comment #4)
> (In reply to Army_bloodcore from comment #2)
> > (In reply to Xisco Faulí from comment #1)
> > > Could you please paste the info from Help - about LibreOffice ?
> > > 
> > > I have set the bug's status to 'NEEDINFO'. Please change it back to
> > > 'UNCONFIRMED' once the information has been provided
> > No, I cannot, in MS office this feature is enabled, why you cannot enable
> > this also in LibreOffice?
> 
> Please, provide the Info requested, otherwise we can't triage this issue

Hello! I'm looking for this. If I understood right, this extension adds japanese dictionary which can show readings of kanji and words? If this right, you must notice that furigana will not work properly without following module:
https://extensions.libreoffice.org/extensions/japanese-integrated-learning-tool
Comment 6 Xisco Faulí 2020-01-20 16:03:58 UTC
Hello Army,
A new major release of LibreOffice is available since this bug was reported.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 7 Army_bloodcore 2020-05-15 21:42:57 UTC
Hello, Xisco Faulí!
Sorry for a late reply.
In version 6.4.3, this mistake is still not fixed.
I think, this will be help me to solve my problem, but I don't want to install java, I think it is bad language.
https://extensions.libreoffice.org/extensions/japanese-integrated-learning-tool
At the other side, I confirm it with 6.4.3.2, it still not fixed.
Comment 8 Ming Hua 2020-05-16 02:59:04 UTC
There is some language barrier here, but I think the reporter Army is asking for a feature that automatically recognize kanjis in the text and add furiganas for them.  This is a feature Microsoft Word has and is useful to many people.

I don't think LibreOffice currently has this feature.  Maybe the extension Army mentioned provides it, I haven't checked.
Comment 9 Army_bloodcore 2020-06-05 18:07:06 UTC
Ming Hua
Hello! I've been tested JILT addon, and it is NOT adding feature that I need.
https://extensions.libreoffice.org/en/extensions/show/japanese-integrated-learning-tool
This is too slow and too wrong for me. This is a just a dictionary and learning tool, but my target is a find reading of a kanji, not meaning.
The addon that I needed just inserts default reading of a furigana to a kanji and katakana japanese words, in MS Office it can be realized WITHOUT java.

This is TARGET addon:
https://extensions.libreoffice.org/en/extensions/show/kanji-to-phoentic-6f225b5730923075308a306a306b590963db
Can you include this addon in LibreOffice?
Comment 10 Army_bloodcore 2020-06-08 16:21:18 UTC
Created attachment 161769 [details]
Kanji reading map

ON reading
Comment 11 Army_bloodcore 2020-06-08 16:22:12 UTC
Created attachment 161770 [details]
Kanji list

Official kanji list recommended by Japanese government.
Comment 12 Army_bloodcore 2020-06-08 16:27:22 UTC
I will include 2 attachments, this is kanji map reading and kanji list recommended by japanese government.

There is 2 basic rules:
1) If you will meet 1 kanji in text, you must read it by KUN reading.
2) If you will meet 2 kanji in text or more, you must read it by ON reading.
This two basic rules covers most daily situations and useful japanese words.

And this two basic rules has a many exceptions that again strongly involving to a daily conversations (for example, gatsu/getsu, nichi/bi/hi, toshi/nen, hyou/omote and other).

I am not a programmist, but I can help to write a needed module to find a reading of a kanji. I will help and I will do all that you will request from me.
Comment 13 Ming Hua 2020-06-08 21:46:25 UTC
I know too little about Japanese to give any meaningful advice.  Pinging the Japanese meta bug to see if any native Japanese speaker can comment.
Comment 14 Army_bloodcore 2020-07-25 02:35:28 UTC
Created attachment 163497 [details]
Wrong furigana borders

Libreoffice marks wrong furigana borders.
Comment 15 Army_bloodcore 2020-07-25 02:39:41 UTC
Okay, lets go somewhere deeper than now.
I just tried to mark furigana the sample of text, and I get next.
Furigana borders is wrong.
Japanese texts contains 3 type of text:
1) Hiragana (furigana NOT required)
2) Katakana (furigana NOT required)
3) Kanji (furigana REQUIRED).
True borders is borders between kanji and hiragana and kanji and katakana, if you meet 2 or more kanji, this is one word and this is one furigana must be there.
繰り返します - here must be 2 furiganas.
水力工事 - there must be 1 furigana.
システム - there must be 0 furiganas.

Please, check it.
Comment 16 Army_bloodcore 2021-03-21 16:00:00 UTC
Not actual anymore, problem may solve by plugins and automated translators.