Bug Hunting Session
Bug 124828 - FILEOPEN XLS Crash with large spreadsheet
Summary: FILEOPEN XLS Crash with large spreadsheet
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All All
: highest critical
Assignee: Luboš Luňák
URL: https://docs.google.com/file/d/0B8qaX...
Whiteboard: target:6.3.0 target:6.2.4 target:6.1....
Keywords: bibisected, bisected, regression
: 120498 124901 (view as bug list)
Depends on:
Blocks: XLS
  Show dependency treegraph
 
Reported: 2019-04-18 18:47 UTC by Buovjaga
Modified: 2019-04-25 08:44 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2019-04-18 18:47:45 UTC
Try to open https://docs.google.com/file/d/0B8qaXt5L1EUXOFJmMXdoSS0xdWs/edit?usp=sharing

From bug 61837 we see that people could open it in the past.

Caution: trying to open the file causes slowness in the entire operating system. This even spread from my Win VM to my Linux host.

I was unable to get a backtrace. It just said it received SIGKILL (I didn't kill it).

This seems to have begun in 6.1. I got "bad allocation" from the last commit on win32-6.1. I am bibisecting it now, but it takes a long time.

Arch Linux 64-bit
Version: 6.2.2.2
Build ID: 6.2.2-3
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: kde5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 1fee3f1da6291bfbcd75455512726215d41b3e83
CPU threads: 8; OS: Linux 5.0; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 18 April 2019

Version: 6.3.0.0.alpha0+ (x64)
Build ID: 3083fe569f96bf0289da1e9d0ef7da15ab22e2f6
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-04-16_03:05:57
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded
Comment 1 Buovjaga 2019-04-18 19:13:51 UTC
Bibisected with win32-6.1 to https://gerrit.libreoffice.org/plugins/gitiles/core/+/b11188835d3b87cd9d2a8cdb3da204cfda5d3e6e%5E!/
DOC import: lazy-read images

Adding Cc: to Miklos Vajna
Comment 2 Xisco Faulí 2019-04-19 13:22:59 UTC
Reproduced in

Versión: 6.2.2.2
Id. de compilación: 2b840030fec2aae0fd2658d8d4f9548af4e3518d
Subprocs. CPU: 1; SO: Windows 6.1; Repres. IU: predet.; VCL: win; 
Configuración regional: es-ES (es_ES); Idioma de IU: es-ES
Calc: threaded
Comment 3 Miklos Vajna 2019-04-23 09:33:32 UTC
Lubos plans to look at this.
Comment 4 Commit Notification 2019-04-24 07:00:22 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/af84fc9d906626255aaf136eefc5e55236e0e8a6%5E%21

lazy image loading shouldn't read the entire .xls file (tdf#124828)

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2019-04-24 09:52:58 UTC
I do confirm the file opens in

Version: 6.3.0.0.alpha0+
Build ID: 90e3b47b52f26420425a7417d2f51b6a386282d9
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

after

real	0m13,552s
user	0m12,274s
sys	0m0,956s


previously, it just hangs forever...

@Luboš Luňák, thanks for fixing this issue!!
Comment 6 Xisco Faulí 2019-04-24 09:56:31 UTC
*** Bug 124901 has been marked as a duplicate of this bug. ***
Comment 7 Xisco Faulí 2019-04-24 09:57:00 UTC
*** Bug 120498 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2019-04-24 10:10:14 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/2dd410421331eb2a593a9e9ca2f73e2aa1c2a694%5E%21

lazy image loading shouldn't read the entire .xls file (tdf#124828)

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-04-24 14:14:03 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/cf01389718fb2ef84697542d69a7ee2c25e544fc%5E%21

lazy image loading shouldn't read the entire .xls file (tdf#124828)

It will be available in 6.1.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-04-25 08:44:29 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-6-1-6":

https://git.libreoffice.org/core/+/fb295e046297db896583f74ee78736d656d25f75%5E%21

lazy image loading shouldn't read the entire .xls file (tdf#124828)

It will be available in 6.1.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.