Bug 124901 - FILEOPEN: performance regression opening file with many images
Summary: FILEOPEN: performance regression opening file with many images
Status: RESOLVED DUPLICATE of bug 124828
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, perf, regression
Depends on:
Blocks:
 
Reported: 2019-04-23 11:14 UTC by Xisco Faulí
Modified: 2019-04-24 09:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-04-23 11:14:24 UTC
Steps to reproduce:
1. download http://rkb1c.ru/soft/35mb.xls
2. Open it with 'time OOO_EXIT_POST_STARTUP=1'

real	7m51,293s
user	0m11,948s
sys	1m3,162s

in

Version: 6.3.0.0.alpha0+
Build ID: b34786d2774b261be48de92f65a5d0aa3c32b289
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

before https://cgit.freedesktop.org/libreoffice/core/commit/?id=b11188835d3b87cd9d2a8cdb3da204cfda5d3e6e

it's

real	0m59,405s
user	0m55,466s
sys	0m1,863s
Comment 1 Xisco Faulí 2019-04-23 11:30:04 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b11188835d3b87cd9d2a8cdb3da204cfda5d3e6e

author	Miklos Vajna <vmiklos@collabora.co.uk>	2018-04-20 17:58:09 +0200
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2018-04-20 21:12:56 +0200
commit	b11188835d3b87cd9d2a8cdb3da204cfda5d3e6e (patch)
tree	d4c652363b1f20e7399be1fd01d74099e3aa8f3c
parent	40edbce3988946d0ffceb9554de42e1e469edd92 (diff)
DOC import: lazy-read images

Bisected with: bibisect-linux64-6.1

Adding Cc: to Miklos Vajna
Comment 2 Xisco Faulí 2019-04-24 09:56:31 UTC
after https://git.libreoffice.org/core/+/af84fc9d906626255aaf136eefc5e55236e0e8a6%5E%21 it's even better than before

real	0m24,458s
user	0m21,872s
sys	0m0,969s

Version: 6.3.0.0.alpha0+
Build ID: 90e3b47b52f26420425a7417d2f51b6a386282d9
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Closing as duplicate of bug 124828

*** This bug has been marked as a duplicate of bug 124828 ***