Bug 124852 - Heading characters much too big when copy-paste as GDI metafile
Summary: Heading characters much too big when copy-paste as GDI metafile
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) release
Hardware: All All
: medium minor
Assignee: Not Assigned
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Calc-Styles
  Show dependency treegraph
Reported: 2019-04-20 05:59 UTC by Rainer Bielefeld Retired
Modified: 2023-05-30 05:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:

Test document (133.46 KB, application/vnd.oasis.opendocument.text)
2019-04-20 13:59 UTC, Rainer Bielefeld Retired

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2019-04-20 05:59:26 UTC
Steps how to reproduce  with Version: 
Build ID: 2e3b0c5d42d60d46cd9f8b8eda9424b095c63418; Windows 6.1:
0. Open attached Sample Document
1. Double click Source spreadsheet above
2. Select A71:G84
3. <cntrl+c> for copy
4. Click at the bottom of the test document so that caret flashes there
5. Menu Edit 'Paste Special → GDI Metafile'
   » Inserted object looks similar to spreadseeht source, but size of heading
    is much too big, so that heading becomes truncated at left and right    😥

a) Works fine with Version: (x64)
Build-ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
CPU-Threads: 4; BS: Windows 6.1; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group

b) I am using a copy of an existing user profile, new user profile not yet 
c) Enabled: OpenGL, Hardware Acceleration, Anti Aliasing, 
d) Same bad result when I 'copy → paste special' to Draw document
e) Same result when I 'copy → paste special' from Sample document in LibO 6.3
   to Text document in LibO
f) because of (d), (e) I am pretty sure that the problem is in 'copy', not in
g) result of 'Paste Special → bitmap' looks ok.
Comment 1 Rainer Bielefeld Retired 2019-04-20 13:59:58 UTC
Created attachment 150895 [details]
Test document

Document contains spreadsheet source for tests and comparison copy/paste results LibO 6.0 / LibO 6.3
Comment 2 Buovjaga 2019-08-17 13:48:38 UTC
Bibisected with win32-5.3 to https://gerrit.libreoffice.org/plugins/gitiles/core/+/06f319937187f76ee402d53b3baa78c391c2af19%5E%21/
tdf#90937 Add a set of cell styles to calc

When testing the bug, a quick way to select the range is to click in the name box and paste A71:G84

I am not sure if the bibisect result is correct, so adding bibisect request

Confirmed with
Arch Linux 64-bit
Build ID: b9a776837462eeb6d50d0decc42604c0c3008eb1
CPU threads: 8; OS: Linux 5.2; UI render: default; VCL: kf5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 11 August 2019
Comment 3 Aron Budea 2021-05-29 09:37:24 UTC
I got the same results with bibisect-linux-64-5.3.
Comment 4 QA Administrators 2023-05-30 03:15:54 UTC Comment hidden (obsolete)
Comment 5 Rainer Bielefeld Retired 2023-05-30 05:57:48 UTC
Still the same like 2019-04-20 13:59:58 UTC 
with Server Installation of Version: (X86_64) 
Build ID: 3bc7cc14706f47d740dfc5715970054922ca470c
CPU threads: 12; OS: Windows 10.0 Build 19045; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE; Theme: Automatic (Colibre)
Calc: CL threaded – Special new User Profile for testing