Bug 124862 - Writer context menu: many options missing
Summary: Writer context menu: many options missing
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Customize-Dialog
  Show dependency treegraph
 
Reported: 2019-04-20 13:53 UTC by bugzilla2
Modified: 2019-04-21 14:38 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla2 2019-04-20 13:53:55 UTC
Description:
In Writer 6.2 there are some context menu options missing compared to earlier versions. I just had a document that was messed up by the new LibO version (bug is reported) and had to reformat a table. It was surprised (to say the least) by not finding any way to format the vertical alignment of table cells. I clicked all menus that seemed to be related to that somehow without any luck. About 10 minutes later I found the options in one of the toolbars (which I almost never use, because I'm used to work with the context menu). The two things that made me almost scream was the missing vertical-alignment and the number-formatting in context-menu. Im sure LibO 6.2 will make more users than me pull their hair, so maybe we can bring this options back by default? I already configured the context-menu as wanted (thanks to the great customization UI :)), but not everybody will find/do that.

Steps to Reproduce:
1. Open Writer and create a table
2. fill some numbers in a cell
3. Right click the celll

Actual Results:
No Options for vertical-alignment, number-formatting and number-recognition are displayed in context-menu.

Expected Results:
Options for vertical-alignment, number-formatting and number-recognition should be in context-menu, as it was in earlier versions.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
I guess the removal of those options is based on feedback from the telemetry. But I simply had to report this "issue" anyway. Also keep in mind, that more advanced users does tend more often to disable telemetry services!

Version: 6.2.3.2
Build-ID: aecc05fe267cc68dde00352a451aa867b3b546ac
CPU-Threads: 12; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-AT (de_AT); UI-Sprache: de-DE
Calc: CL
Comment 1 V Stuart Foote 2019-04-20 18:14:03 UTC
By design. Context menus were made user customizable at the 5.2 release for bug 93837

Use Tools -> Customize from the module in use, e.g. Writer, and select the Context menu to adjust from the Target droplist.

Prior to the 5.2 releases, the context menu was hard coded--after that the context menus were "weeded" to remove less common entries.

Users are expected to RTM.
Comment 2 bugzilla2 2019-04-21 09:20:50 UTC
Sadly thats the answer I expected :(

But what does RTM in that context mean?
Comment 3 V Stuart Foote 2019-04-21 14:38:07 UTC
(In reply to bugzilla2 from comment #2)
> Sadly thats the answer I expected :(
> 
> But what does RTM in that context mean?

The Help, either built-in (with F1), or online ( at https://help.libreoffice.org/6.2/en-US/text/shared/01/06140300.html?&DbPAR=SHARED )

And there is the Getting Started with LibreOffice guide... Chapter 14. - Customizing LibreOffice

https://wiki.documentfoundation.org/Documentation/Publications#Getting_Started_with_LibreOffice

The project release notes provides some coverage of the Tools -> Customize dialog (the menu section of the 5.2, 5.3, 6.0, 6.1 -- https://wiki.documentfoundation.org/ReleaseNotes )

Then there is project Ask (ask.libreoffice.org) to formulate a specific question, or check for similar that have already been answered. ( https://wiki.documentfoundation.org/Ask/Getting_Started )

And there is an old style User Mail List that many still prefer ( users@global.libreoffice.org) With a Nabbel hosted searchable archive ( http://document-foundation-mail-archive.969070.n3.nabble.com/Users-f1639498.html )

Or if one wants to follow the development--project uses meta bugs to help track specific issues. Here  https://bugs.documentfoundation.org/showdependencytree.cgi?id=103238&hide_resolved=0

Unfortunately, at the moment the F1 help (when the "off-line" Help package is installed) is a bit lacking, tooltips and labeling it should provide (on mouseover) are out of service--that happened as we transitioned the help system (NewHelp) for better browser integration (see bug 118148)