Download it now!
Bug 118148 - [NEWHELP] Handle <ahelp> tags in the UI
Summary: [NEWHELP] Handle <ahelp> tags in the UI
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0
Keywords: accessibility
: 124130 131748 (view as bug list)
Depends on: 120538
Blocks: New-Help 112237 129720
  Show dependency treegraph
 
Reported: 2018-06-13 16:52 UTC by Olivier Hallot
Modified: 2020-09-17 14:13 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2018-06-13 16:52:14 UTC
In old help system, the <ahelp> tag is extracted at build time to be used by the user interface as tool tip for each widget.

The new help does not handle that, yet.

The content of <ahelp> should be available as tool tips in the UI dialogs. UI dialogs have provision to hold tooltips for each widget.

the <ahelp> tag is documented here:

https://wiki.documentfoundation.org/Documentation/Understanding,_Authoring_and_Editing_Openoffice.org_Help/3#ahelp

So the task/enhancement is to have a script that extracts <ahelp> of a given dialog and add it to the corresponding .ui file. 

This will have some impacts
- The UI will increase in volume of translation job, but
- ideally the translated <ahelp> should go too, to prevent re-translation.
Comment 1 Buovjaga 2018-06-22 16:59:15 UTC
Setting to NEW
Comment 2 V Stuart Foote 2018-10-16 12:32:49 UTC
The a11y impact is a more immediate issue.
Comment 3 Olivier Hallot 2019-03-18 11:19:00 UTC
*** Bug 124130 has been marked as a duplicate of this bug. ***
Comment 4 V Stuart Foote 2020-03-31 21:35:07 UTC
*** Bug 131748 has been marked as a duplicate of this bug. ***
Comment 5 Olivier Hallot 2020-06-21 15:58:00 UTC
Currently (master 7.0), filling the tool tip field in the widget will display it in the dialog

But the Tools > LibreOffice > General > Extended tooltip checkbox does not control it.
Comment 6 Olivier Hallot 2020-06-21 16:41:55 UTC
Important discussion on the topic

https://lists.freedesktop.org/archives/libreoffice/2015-August/069910.html
Comment 7 Olivier Hallot 2020-06-29 20:18:52 UTC
 (In reply to V Stuart Foote from comment #2)
> The a11y impact is a more immediate issue.

Looks like that if we copy the <ahelp> contents on the widget "Accessible Description" field, e.g,

<child internal-child="accessible">
    <object class="AtkObject" id="versionlb-atkobject">
        <property name="AtkObject::accessible-description" translatable="yes">bla bla bla bla bla</property>
     </object>
</child>

It works (enable extended tips in the Options).

Any other settings? What about field "AtkObject::accessible-name" and other in the accessibility tab of Glade?
Comment 8 Commit Notification 2020-07-11 00:06:21 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/539e4124739feffdceecb5207fdc2428396a9dd4

tdf118148 Extended tips for optsavepage.ui

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2020-07-12 11:13:54 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f821efb6e674e5ebddb8eecb1139b7e57cc48bfc

tdf#118148 Extended tips in editmodulesdialog.ui

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-07-12 16:26:55 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/66977fbfa23a6d48c64d72d44264de90abddad53

tdf#118148 Extended tips in lingu compnents

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-07-12 22:09:16 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/dbece49a77e4cf3f6a0f95acb2936891d66d960b

tdf#118148 Add extended tips to selectpathdialog.ui

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 V Stuart Foote 2020-07-13 14:17:57 UTC
Testing the extended tips being added to the UI

Version: 7.1.0.0.alpha0+ (x64)
Build ID: ffe503b62f9a508285ed06ef977f91604130579a
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

On Windows 10 with NVDA 2019.3 screen reader

With Tools -> Options -> General -> Help 'Extended tips' checked enabled

The Load/Save -> General fully sounds the extended tips which appear in UI pop-up box.

<Tab> between controls is smooth, UI draws the new pop-up cleanly (with some fade in/out) visually appealing.

From a11y perspective this is going to be fine.

Of course no response to an <F1> Help query.

But OMG Oliver, doing all the UI this by hand is going to be work! Has to be a better way. Also impact on other documentation/Help (to adjudicate any string differences)  and also for l10n translators where these new translate strings will get flushed.
Comment 13 Olivier Hallot 2020-07-13 21:28:05 UTC
Glad to know it is working fine. Credits to Caolán who implemented the GTK ui. Once the strings are in place, they are picked into the translation process.

The extended tips process is semi-automatic. I found no (easy) way avoid a manual intervention to fix the <ahelp hid="."> anomaly and I hit a bug in the xml of the ui file.

I also have all the translated strings at hand, in PO format, for all languages. What is left open is to find a way to add there translated strings into the translation/weblate process.
Comment 14 Commit Notification 2020-07-15 11:19:24 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/590ec971a833e353e745049503958c99d58bbb15

tdf#118148 Extended tips to colorpickerdialog.ui

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2020-07-26 11:00:44 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5935dd32a445acd1b2625acda2f02b7d0debed97

tdf#118148 Add extended tips to optuserpage.ui

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Adolfo Jayme 2020-07-27 02:54:33 UTC
> What is left open is to find a way to add there translated strings into the
> translation/weblate process.

As long as this doesn’t exist, please do the migration to core slowly. It’s very painful to have a bunch of untranslated strings thrown at the translator teams at once, and it’s annoying to translate them since they are almost the same as the previous helpcontent2 ones but Weblate doesn’t prefill them. I beg you to talk to Cloph and find a solution!
Comment 17 Commit Notification 2020-08-21 16:02:08 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/bcf5469ee5aa74434aa5763059a78807e5e4c54f

tdf#118148 Extended tips for optgeneralpage.ui

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2020-08-21 16:02:19 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2a828d845a2232bff43ebe7c17f26af3fea14002

tdf#118148 Extended tips for optfontpage.ui

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2020-08-21 16:02:30 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fa096736c01e2556d7454b2b55ca19689da1e8d4

tdf#118148 Extended tips from smath/01 Help pages

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2020-08-21 16:03:41 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f5c2c94fa7c896dc9a76c30d824cd1c3be725c65

tdf#118148 Extended tips from schart/01/ Help pages 2

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2020-08-21 16:03:52 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c1eb680261107877bf2cea9339e89e23a0a29371

tdf#118148 All extended tips for shared/optionen

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2020-08-24 18:49:08 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/de01c0c1d0f80ffec3882625d77c02ab806f6c7a

tdf#118148 Extended tips from HC2/shared/

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2020-09-01 15:31:11 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/93626beb6407509220c92ef47425deba1d71858a

tdf#118148 Extended tips for HC2/scalc/

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2020-09-04 14:38:58 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c4ea034beb2fa0f1e874a39391a9498bdd7c7aad

tdf#118148 Extended tips for HC2/swriter

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2020-09-04 20:24:20 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0e8696bc2784364cfbefd7fa55da733e350c56cd

tdf#118148 Extended tips for simpress/ and sdraw/

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Commit Notification 2020-09-07 14:49:02 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9c55e725a45b027fade9084c0d9b82178fa1a04f

tdf#118148 Extended tips for HC2/sbasic

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 27 Olivier Hallot 2020-09-17 14:13:27 UTC
Migration from <ahelp> to extended tips in batch is done. 

Remaining extended tips should be added directly in the dialog files.