Bug 129720 - Populate the Description box of the Customize dialog with multiline tooltip from bug 108458
Summary: Populate the Description box of the Customize dialog with multiline tooltip f...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+ Master
Hardware: All All
: medium enhancement
Assignee: Onur Yılmaz
URL:
Whiteboard: target:7.0.0
Keywords: difficultyBeginner, easyHack, skillCpp, skillUI
: 130846 (view as bug list)
Depends on: 118148
Blocks: Customise-Dialog
  Show dependency treegraph
 
Reported: 2020-01-01 16:41 UTC by V Stuart Foote
Modified: 2020-03-31 21:35 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2020-01-01 16:41:56 UTC
Would the multiline tooltip implemented for bug 108458 be suitable to insert into the 'Description' box of the customize dialog, and so resolve bug 61210. 

Also, the description box will otherwise remain blank until for bug 118148 the <ahelp> tags can again be parsed from the New Help system and provided in the translated help packs for use when offline 'Local Help' is installed.

Even then, some folks might prefer the multiline tip entry to the extended tip entry from the <ahelp>. So could the Tools -> Options -> General 'Extended tips' also toggle use here? 

Likewise, content of the multiline tooltip would be sufficient for needs of bug 112237 if the Description box can be made to show tip for controls that have already been added to the UI, i.e. entries on the right column of the dialog.

All of it centered on populating the 'Description' box.
Comment 1 Jim Raykowski 2020-01-02 04:30:15 UTC
Possibly the Description box is no longer needed?
Comment 2 Heiko Tietze 2020-01-06 12:30:34 UTC
While I agree that description is not needed anymore, the control nicely aligns the two trees. So how about showing the new multiline info from the tooltip in this box?
Comment 3 Muhammet Kara 2020-01-06 16:20:50 UTC
(In reply to Heiko Tietze from comment #2)
> While I agree that description is not needed anymore, the control nicely
> aligns the two trees. So how about showing the new multiline info from the
> tooltip in this box?

Sounds okay to me. In fact, this can also be an easyHack.

Around line m_xDescriptionField in cfg.cxx, you will see a block for this check: "if ( !SfxHelp::IsHelpInstalled() )".

Just make necessary changes in that block to make the description field to show the tooltip for the command instead of the "local help is not installed" message, which is coming from the ui file, and set & used as sDescTooltip.

As we will no longer show an empty description on absense of local help, the tooltip for the m_xDescriptionField which comes from the "desc" item in the "menuassignpage.ui" is also no longer needed, so better to also remove that, along with the sDescTooltip const.

In fact, I would just remove the whole if-else ladder starting with "if ( !SfxHelp::IsHelpInstalled() )", and check for empty string returning from the m_xFunctions->GetHelpText(false) call, and set the multiline tooltip as the new text if it is empty.

The tooltip commit: https://gerrit.libreoffice.org/plugins/gitiles/core/+diff/444f0d256957544d26b9af9a0898364e829df1b5%5E%21
Comment 4 Commit Notification 2020-02-04 18:54:00 UTC
Onur Yilmaz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7d5a463684b44b625bf555c1d8ed4df5a1660339

tdf#129720: Populate the Description box of the Customize dialog...

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Muhammet Kara 2020-02-04 19:44:01 UTC
Seems fixed now.
Comment 6 Heiko Tietze 2020-02-05 10:57:51 UTC
Now I wonder if the UNO command is needed there. The average user might get confused with this information. Really cool would be to show the location of the command in the main menu and the shortcut, if available.
Comment 7 V Stuart Foote 2020-03-17 11:59:14 UTC
*** Bug 130846 has been marked as a duplicate of this bug. ***