Bug 141244 - Controls in Modify DDE Link dialog missing
Summary: Controls in Modify DDE Link dialog missing
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: All All
: medium normal
Assignee: Aron Budea
URL:
Whiteboard: target:7.2.0 target:7.1.3
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Files-Linked
  Show dependency treegraph
 
Reported: 2021-03-25 08:15 UTC by Jaise James
Modified: 2021-04-20 19:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
no editing in version 7.1 (9.05 KB, image/png)
2021-03-25 08:22 UTC, Jaise James
Details
edit option in 7.0 version (32.14 KB, image/png)
2021-03-25 08:22 UTC, Jaise James
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaise James 2021-03-25 08:15:47 UTC
Description:
If we link spreadsheet cells to writer using dde link by paste, there is no option edit cell range. It was available for old versions


Steps to Reproduce:
1.images attached for verification
2.
3.

Actual Results:
no editing in external file links

Expected Results:
editing of cells range should be there


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 Jaise James 2021-03-25 08:22:19 UTC
Created attachment 170731 [details]
no editing in version 7.1
Comment 2 Jaise James 2021-03-25 08:22:51 UTC
Created attachment 170732 [details]
edit option in 7.0 version
Comment 3 Julien Nabet 2021-03-25 19:43:51 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 4 Julien Nabet 2021-03-25 20:13:24 UTC
I can reproduce this with gtk3 and gen rendering.
I didn't see anything wrong in console logs.

Code pointer:
sfx2/uiconfig/ui/linkeditdialog.ui
sfx2/source/appl/impldde.cxx

To reproduce this:
- type this in a cell
=DDE("soffice";"c:\office\document\data1.ods";"sheet1.A1")
- select cell then Edit/Link to External Files...
- click "Modify..." button

I don't know what's the pb here, can't help=>uncc myself.
Comment 5 Aron Budea 2021-04-18 04:35:06 UTC
Bibisected to the following commit using repo bibisect-linux-64-7.1.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=de01c0c1d0f80ffec3882625d77c02ab806f6c7a
author		Olivier Hallot <olivier.hallot@libreoffice.org>	2020-08-22 12:36:14 -0300
committer	Caolán McNamara <caolanm@redhat.com>	2020-08-24 20:48:21 +0200

"tdf#118148 Extended tips from HC2/shared/"

Looks like a straightforward fix, patch is here: https://gerrit.libreoffice.org/c/core/+/114237
Comment 6 Commit Notification 2021-04-19 16:39:23 UTC
Aron Budea committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/da3d3fad1515348b6c4f2303db83ec03594f0597

tdf#141244 Modify DDE Link dialog was empty

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Aron Budea 2021-04-20 01:20:04 UTC
Marking as fixed, backport to 7.1 is on gerrit.
Comment 8 Commit Notification 2021-04-20 07:45:30 UTC
Aron Budea committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/8e324e8c9e8cfafef2f5fcebc64e7c5efb035ca2

tdf#141244 Modify DDE Link dialog was empty

It will be available in 7.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2021-04-20 08:42:09 UTC
Aron Budea committed a patch related to this issue.
It has been pushed to "libreoffice-7-1-3":

https://git.libreoffice.org/core/commit/678bcbe5bc3855fbda7477483c77c2cf4882d9da

tdf#141244 Modify DDE Link dialog was empty

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2021-04-20 08:57:29 UTC
Verified in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 93bb5fcba9e58eeeaaed9521c3bb4eecf9b91ac1
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Aron, thanks for fixing this issue!!

The same commmit broke the Cancel/OK buttons in the same dialog. I'll report it in a follow-up ticket!!
Comment 11 Commit Notification 2021-04-20 19:08:13 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/90cbc6c892a6b26a0fe950800d4fba0b7a0de68f

tdf#141244, tdf#141770: sc: Add UItest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.