Bug 117463 - Create a Dialog that shows up on first boot of Writer/Calc/Impress for the user to pick its default UI
Summary: Create a Dialog that shows up on first boot of Writer/Calc/Impress for the us...
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.1.0
Keywords: needsUXEval
: 133151 138620 (view as bug list)
Depends on: 137427 137423 137424 137429 137500 138051 138631
Blocks: HelpGaps-NewFeatures Notebookbar 135501
  Show dependency treegraph
 
Reported: 2018-05-06 19:07 UTC by Pedro
Modified: 2021-02-04 16:41 UTC (History)
14 users (show)

See Also:
Crash report or crash signature:


Attachments
Proposal 1: Mock-up of a LO UI picker dialog (172.01 KB, image/png)
2018-05-06 19:07 UTC, Pedro
Details
Softmaker Office UI Picker dialog box (79.88 KB, image/jpeg)
2018-05-06 19:08 UTC, Pedro
Details
WPS UI picker dialog (55.72 KB, image/png)
2018-05-06 19:08 UTC, Pedro
Details
WPS UI picker dialog (51.09 KB, image/png)
2018-05-06 19:09 UTC, Pedro
Details
Interface layout Ubuntu MATE (94.77 KB, image/png)
2020-06-08 10:49 UTC, John Mills
Details
Softmaker Office User Interface dialogue (113.63 KB, image/png)
2020-06-08 10:50 UTC, John Mills
Details
layout issues for UI picker dialog run from the Tip-of-the-Day (35.49 KB, image/png)
2020-10-09 13:37 UTC, V Stuart Foote
Details
New ToTD telling user ability to switch UI (64.77 KB, image/png)
2020-10-19 06:37 UTC, Rizal Muttaqin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2018-05-06 19:07:37 UTC
Created attachment 141939 [details]
Proposal 1: Mock-up of a LO UI picker dialog

Considering that currently on the 6.1dev build, the Notebookbar is no longer experimental and there are several UI options to choose from it would be good to draw attention of the users to the different UI options they can choose from in LibreOffice.

There are other Office suites that allow users to pick between mulitple UIs and they make a better job of drawing user's attention to those UIs: they offer dialog boxes where the user can preview the different UI options.

Softmaker Office prompts a dialog box the first time a user starts-up the software to make the user pick the UI of its preference. 

WPS Office, on the other hand, has a button close to the minimize, maximize and close buttons that allows the user to change the UI.

I propose that LO should prompt a dialog box at the first start-up after installation of each module with multiple UIs (Writer, Calc and Impress currently), to allow the user to easily change the UI without having to dig down into menus just like Softmaker and WPS Office do. Of course, that by doing this only polished UIs should be available in this dialog box at the beginning.
Comment 1 Pedro 2018-05-06 19:08:11 UTC
Created attachment 141940 [details]
Softmaker Office UI Picker dialog box
Comment 2 Pedro 2018-05-06 19:08:34 UTC
Created attachment 141941 [details]
WPS UI picker dialog
Comment 3 Pedro 2018-05-06 19:09:57 UTC
Created attachment 141942 [details]
WPS UI picker dialog
Comment 4 V Stuart Foote 2018-05-06 21:31:13 UTC
(In reply to Pedro from comment #0)
> 
> Considering that currently on the 6.1dev build, the Notebookbar is no longer
> experimental and there are several UI options to choose from it would be
> good to draw attention of the users to the different UI options they can
> choose from in LibreOffice.
> 

No, it is not out of Experimental mode...

> ...
> I propose that LO should prompt a dialog box at the first start-up after
> installation of each module with multiple UIs (Writer, Calc and Impress
> currently), to allow the user to easily change the UI without having to dig
> down into menus just like Softmaker and WPS Office do. Of course, that by
> doing this only polished UIs should be available in this dialog box at the
> beginning.

Not a fan. With work for bug 115131 we now have one combined menu action to directly select-- View -> User Interface--seems adequate. Much as with see also bug 102070 -- this type of in your face "guidance" for users is not effective marketing or UX.

IHMO, see no reason for overhead of maintaining a Dialog to pick UI's on initial profile setup and lots of opportunity for muddled profiles.

IMHO => WONTFIX
Comment 5 Samuel Mehrbrodt (allotropia) 2018-05-07 11:01:03 UTC
Before we can prominently promote the Notebookbar, we need to implement the missing features which are currently only in the classic toolbar.

Would also say wontfix, or at least blocked on those.
Comment 6 Pedro 2018-05-07 13:54:07 UTC
This doesn't have to be something to be developed for 6.1.
In fact, considering that the feature freeze is coming on May 21st I don't think that's possible. I just want this to be open for discussion and potential development for 6.2.
Comment 7 Xavier Van Wijmeersch 2018-05-07 17:03:33 UTC
Not a fan at all. Agree with WONTFIX
Comment 8 Heiko Tietze 2018-05-07 17:23:29 UTC
I'm also in favor of more subtle solutions. The Notebookbar is not a aesthetically thing, at least not primarily, where you decide once how the app looks like but a way to accommodate to the use scenario. Writing a love letter requires other functions then a thesis, for example.  And we make it easy to switch with the prominent menu entry.

Nevertheless, interesting enhancement idea if we think about the larger picture.
Comment 9 Heiko Tietze 2020-05-19 04:04:28 UTC
*** Bug 133151 has been marked as a duplicate of this bug. ***
Comment 10 V Stuart Foote 2020-05-19 15:18:55 UTC Comment hidden (obsolete)
Comment 11 Pedro 2020-05-19 15:22:03 UTC
Not sure if the discussion should be in this bug or in 133151. You guys decide which one to close.
https://bugs.documentfoundation.org/show_bug.cgi?id=133151

I seriously disagree that this is closed.
The last time this was discussed was two years ago which is plenty of time.
Furthermore, most of the issues raised on that bug are already surpassed. 
Those issues were:
1 - The alternative UIs were still experimental so that discussion was premature by Stuart V Foote.
2 - Need to implement the missing features which are currently only in the classic toolbar by Samuel Mehrbrodt.

Those two issues don't apply anymore so this discussion should be had now.
I agree with kdek and Timur that a dialog should be done to point the user to select the preferred UI. 
IMO, that would be much more useful than having a "tip of the day" dialog. Or simply hardcode the first "tip of the day" dialog after an installation to make the user select a UI, or at least point the user to where to select the UI.
Comment 12 V Stuart Foote 2020-05-19 15:52:50 UTC
*** Bug 133151 has been marked as a duplicate of this bug. ***
Comment 13 V Stuart Foote 2020-05-19 15:59:53 UTC
MUFFIN enhancements provide wonderful alternative UI configurations, but its usage can not be made self documenting--better left to external help & documentation delivered in more reasonable context.  In your face dialog pop-ups and warning bar entries would be insufficient and annoying.

And frankly we do not need guided usage within the GUI, what's nex--think of "Clippy" for MSO, or "Microsoft Bob"--no thanks!  Stick to functional documentation, external to the UI.

IMHO => remains a WF, with tasks against documentation.
Comment 14 V Stuart Foote 2020-05-19 16:29:51 UTC
(In reply to Pedro from comment #11)
> Not sure if the discussion should be in this bug or in 133151. You guys
> decide which one to close.
> https://bugs.documentfoundation.org/show_bug.cgi?id=133151
>

Closed that one again Duplicate.
 
> I seriously disagree that this is closed.
> The last time this was discussed was two years ago which is plenty of time.
> Furthermore, most of the issues raised on that bug are already surpassed. 
> ...

But you've ignored the primary reason this was moved to => WF 

From comment 4 here:

<snip>

Not a fan. With work for bug 115131 we now have one combined menu action to directly select-- View -> User Interface--seems adequate. Much as with see also bug 102070 -- this type of in your face "guidance" for users is not effective marketing or UX.

IHMO, see no reason for overhead of maintaining a Dialog to pick UI's on initial profile setup and lots of opportunity for muddled profiles.
</snip>

In other words we gain nothing/offer nothing to the user, and cause a whole lot of dev/maintenance work for a questionable dialog.
Comment 15 Rizal Muttaqin 2020-05-20 10:34:10 UTC
(In reply to V Stuart Foote from comment #14)
> -- View -> User Interface--seems adequate. Much as with see
> also bug 102070 -- this type of in your face "guidance" for users is not
> effective marketing or UX.
>
From what I see in many comments/discussions in many places in the Internet, many people does not aware this options while they complains no Ribbon UI in LibO.

> IHMO, see no reason for overhead of maintaining a Dialog to pick UI's on
> initial profile setup and lots of opportunity for muddled profiles.
> </snip>
> 

Honestly I dont get it what is the point of maintanaibility, we can say harshly many LibO elements are not maintained. We can count broken function here and there and no dev has interest to fix them (see G Drive for example which many user expected to use or HTML export from Impress/Draw that nobody use).

> In other words we gain nothing/offer nothing to the user, and cause a whole
> lot of dev/maintenance work for a questionable dialog.

This dialog would be a more added value to tell user about what we have in the UI/UX far away then let me say (with all due respect to the creator) Tips of the Day dialog.

So my take is 1000+ to this feature request.
Comment 16 V Stuart Foote 2020-05-20 13:17:55 UTC
(In reply to Rizal Muttaqin from comment #15)

> From what I see in many comments/discussions in many places in the Internet,
> many people does not aware this options while they complains no Ribbon UI in
> LibO.
> 

Please, we do not have a Ribbon UI and we never will, we have MUFFIN and one of its features is the 'Notebook Bar' in one of its UI implementations. And we expect/hope to additional MUFFIN function -- notably tabbed documents (bug 33173) and a multi-document interface (MDI) (bug 37134), with our existing "New Window" multi-window document view getting some love, and a mode for better side-by-side.

> 
> Honestly I dont get it what is the point of maintanaibility, we can say
> harshly many LibO elements are not maintained. We can count broken function
> here and there and no dev has interest to fix them (see G Drive for example
> which many user expected to use or HTML export from Impress/Draw that nobody
> use).
> 

That is part of my concern, features get taken to a certain point and development stalls, or the feature just rots away--e.g. review the history for the 'Navigation Toolbar' (bug 115817 - GSoC 2009). Or the 'Visual Editor' mode of the sm Math module (bug 88744 - GSoC 2010).  How would you write internal UI to guide a user to configure those features?

> This dialog would be a more added value to tell user about what we have in
> the UI/UX far away then let me say (with all due respect to the creator)
> Tips of the Day dialog.

Not really, a pop-up dialog or entries on the Warning bar can never be an adequate substitute for documenting the rich set of UI features in an active (on-line or local) contextual help system. Supplemented by TDF's well authored Guide books and topic specific guides, e.g. Bruce Byfields 'Designing with LibreOffice'. 

Restoring the <ahelp> tag function to the "New Help" (bug 118148) would allow targeted/contextual tip based help. We do not "need" a bloated dialog/wizard for  guided configuration of the UI.

> 
> So my take is 1000+ to this feature request.

No sorry, it just does not fit/belong in the UI.
Comment 17 V Stuart Foote 2020-05-20 14:27:12 UTC
Sorry, looks like the UX-advise ML was not added back when reopened.
Comment 18 Heiko Tietze 2020-06-04 12:53:26 UTC
* 2x con, 1x pro so far

* if we introduce another NB, ideally per extension, it won't show up on this welcome dialog
* the UI choice is the least important for new users
* if we need to advertise per image we should consider a tab in tools > options > view (and remove the menu option) plus have thumbnails with the envisioned extensions

Resolving as WF.
Comment 19 Pedro 2020-06-08 10:12:17 UTC
As I mentioned. I am also in favor of this besides Rizal.
So it is 2 against 2. Furthermore, it's bad to decide about closing bugs in meetings that not everyone can attend.
Comment 20 John Mills 2020-06-08 10:47:42 UTC
Hello all,

I would respectively disagree with Heiko Tietze on this point, I think the most important thing that developers can do is make their users feel comfortable with the software as presented.

LibreOffice ships with an interface currently that is very functional but not intuitive to Microsoft Office users that have been to school or university in the last 13 years. Also for business users which by all accounts has greater than 90% of the office suite market worldwide.

Please understand that this is not an attack on the current interface in anyway but simply provides a method to highlight the wonderful features found in LibreOffice. You are empowering your users by providing information to them to make an informed decision and this is a positive thing.


An example where this has been done well and is in the end users benefit is with Ubuntu MATE. The first run wizard highlights features and allows the end user to make an informed choice on their interface paradigm. I am attaching a screenshot on how this could possible work.

https://ubuntu-mate.org/blog/ubuntu-mate-focal-fossa-release-notes/

Softmaker office provides a good dialogue for choice. It would be helpful to to the same.

https://www.softmaker.com/en/blog/softmaker-office/softmaker-office-2018-whats-new-part-1 (Also screenshot attached)

Something similar also exists in Kingsoft office.

By allowing this initial selection on first run you would also gain telemetry information on user choice allowing you to concentrate your development efforts on the most popular interface. 

Thank you and very best regards,

John Mills
Comment 21 John Mills 2020-06-08 10:49:40 UTC
Created attachment 161758 [details]
Interface layout Ubuntu MATE

Interface Layout Ubuntu MATE
Comment 22 John Mills 2020-06-08 10:50:58 UTC
Created attachment 161759 [details]
Softmaker Office User Interface dialogue

Softmaker Office User Interface dialogue choice
Comment 23 Heiko Tietze 2020-06-08 10:55:05 UTC
Feel free to reopen and discuss - absolutely welcome- but please don't add UX keyword again after a decision has been done. It's rather contra-productive to have the keyword since it means this request needs to be discussed. And in my opinion we should keep the number of open discussions as low as possible.
Comment 24 John Mills 2020-06-08 11:32:57 UTC
@Heiko, thank you. As a very committed user and advocate of LibreOffice I sincerely believe that this option will aid in the adoption of LibreOffice. In my anecdotal experiences the number one complaint I hear about the office suite is the dated nature of the interface. 

Providing an initial dialogue for the already available interfaces will help those inexperienced users considerably. That is positive and a user focused feature to be commended. 

This dialogue really would be useful and help highlight the amazing features of LibreOffice that are likely never explored. You are also empowering your users. This is considerably more useful than a daily tip. And remember it is a once only dialogue (on initial start) and would also explain that the user could change to another interface if they weren't satisfied. I would envision this working like in the screenshot of Ubuntu MATE attached to this bug.
Comment 25 andreas_k 2020-07-14 14:20:42 UTC
I don't want to open the discussion again. 

Notebookbar implementations are part of the LibreOffice Community and design work, so I'm pro show it to the users. In addition after years of hide the notebookbar layouts behind an easy to use dropdown menu, no developer was found it's ok to push it more in front of the user and maybe we found an developer.

+1 to have an initial dialog for choose.
Comment 26 BogdanB 2020-08-06 10:39:25 UTC
+1 to have a dialog when first install of a new version of LibreOffice, like in Ubuntu Mate (see comment 21). It's much easy for a beginner to choose from there. Also there should be a message if you close this window you could change this user interface from: Options - so on...
Comment 27 V Stuart Foote 2020-08-07 13:35:41 UTC
Grudgingly I recast position to +1, as alternative to changing default UI from 'Toolbar, Menu & Dialog' to one of the GLADE based MUFFIN Notebook Bar assemblages.

As noted, the picker dialog per module would likely be light on detail--i.e. TotD. Interested to see what Hieko mocks up. But the heavy lifting on MUFFIN Notebook Bar documentation remains to be done.
Comment 28 jan d 2020-08-07 15:22:55 UTC
For me it hinges a bit on who is the target group for LO. If it is people who are about open source software: Options and showing community efforts are great. 

But if we assume we compete more with software for office workers who otherwise use MSO or SoftMaker or WPS… Then I would go with the UX principle of choosing a decent default options – since most people leave it as it is. 

If we decide that we need a selection, it should make clear what you get with each option. SoftMakers select dialog is rather helpful here, as it shows two screenshots for the menu and the ribbon-style UI, making the actions and its results follow a principle of least surprise.
Comment 29 John Mills 2020-08-07 20:45:51 UTC
Hi jan d,

Just on your statement:

>For me it hinges a bit on who is the target group for LO. If it is people who are about open source software: Options and showing community efforts are great.

> But if we assume we compete more with software for office workers who otherwise use MSO or SoftMaker or WPS… Then I would go with the UX principle of choosing a decent default options – since most people leave it as it is. 


The LibreOffice Next Decade manifesto:

https://www.documentfoundation.org/assets/Documents/tdf-manifesto.pdf

The very first point:

WE COMMIT OURSELVES:

'To eliminate the digital divide in society by giving everyone access to office productivity tools free of charge to enable them to participate as full citizens in the 21st century'

I don't see any other way that other than LibreOffice is targeted at typical users of office software. No where in that manifesto can I see it saying that this is targeted at open source 'activists' first. 

The wonderful thing about LibreOffice and FLOSS software in particular is that is a great equalizer. From the poorest to richest the our rights are the same. The document foundation provide a fantastic Office suite that respects user freedoms and empowers them. 

That is critical, anything that enables this and encourages more users to break away from proprietary software should be encouraged. I think a providing a user interface similar to what > 90% of users interact with can only be a positive step, it's a great starting point.

Note also the first value rejected.

'The ownership of office productivity tools by monopoly suppliers which imposes a de-facto tax on global electronic free speech and penalises the economically disadvantaged.'

LibreOffice competes for the poorest users against 'pirated' versions of Microsoft Office. When a user has no inclination that something free (libre/gratis)exists that respects them they become a prisoner. It is insidious. 

Anyway I apologise if off topic, but I just wanted to make clear who could benefit by this decision.
Comment 30 Heiko Tietze 2020-08-16 13:09:28 UTC
Patch at https://gerrit.libreoffice.org/c/core/+/99957 introduces a new tip of the day and the ability to start a UNO command. This command shows a dialog where the UI variants can be picked- much like the menu but without the need to go through the structure and with a preview including a short description. I suggest to remove the User Interface > * menu and show this User Interface... instead.
Comment 31 V Stuart Foote 2020-08-16 14:17:06 UTC
(In reply to Heiko Tietze from comment #30)
> ... I suggest to remove the User Interface > * menu and show this
> User Interface... instead.

That would allow us to call the dialog at any time. But, kind of an in your face exposure considering that now the View -> User Interface allows you an immediate selection (including keyboard accelerators) per module.

So when placing on the View menu, just add it to the current User Interface sub as a dialog with a suitable name, e.g. "UI picker..."  That seems least disruptive and most friendly MUFFIN approach, and keeps the UI changes in keyboard reach.
Comment 32 Pedro 2020-08-16 17:42:54 UTC
I still think that the UI picker dialog should be presented at first start.
Showing it in the Tip of the day dialog is a poor replacement because when a user starts a new module he will have to change the UI of that module again. 
And there's the issue that most people will just close the tip of the day dialog without even reading it. It would be better to present a solution that would make the user have to choose an UI. 

So I would prefer to have further discussion instead of pushing through a change that many don't seem to entirely agree with.
Comment 33 John Mills 2020-08-16 18:02:54 UTC
Just a question to the 'tip of the day' notification. Will the tip of the day message for changing the default UI be the first such tip that a user sees after installation? This is critical.

If it is not then a number of people who do not like such tips and select to not display them in the future will simply dismiss the first message, and then the user will not know about the extended range of available UIs. This then defeats the purpose of this dialogue.

If I select to use the tabbed interface from the tip of the day dialogue, or any other notebook bar UI, will my selection carry over to the other applications in the office suite? My point being I select Tabbed in Writer will this then become the default in Calc, Impress,Draw etc? 

I agree with Pedro on this point.
Comment 34 V Stuart Foote 2020-08-16 18:38:43 UTC
(In reply to Pedro from comment #32)
> ...
> dialog without even reading it. It would be better to present a solution
> that would make the user have to choose an UI. 
> 

And that is exactly the 'in your face' dialog many would prefer to avoid.

> So I would prefer to have further discussion instead of pushing through a
> change that many don't seem to entirely agree with.

(In reply to John Mills from comment #33)
> ...

> If I select to use the tabbed interface from the tip of the day dialogue, or
> any other notebook bar UI, will my selection carry over to the other
> applications in the office suite? My point being I select Tabbed in Writer
> will this then become the default in Calc, Impress,Draw etc? 
> 

No, the UI selection is made per-module and recorded to user profile. Eactly as done now from the actions on the View -> User Interface menu.  The Tip-of-the-Day framework dialog, or a full UI dialog frame would behave the same.
Comment 35 Rizal Muttaqin 2020-08-17 08:56:32 UTC
(In reply to V Stuart Foote from comment #34)
> (In reply to Pedro from comment #32)
> > ...
> > dialog without even reading it. It would be better to present a solution
> > that would make the user have to choose an UI. 
> > 
> 
> And that is exactly the 'in your face' dialog many would prefer to avoid.

The point is, how we set the behaviour for ToTD? If we set it as a one time only dialog at startup/first start (and of course per module as you state in #c33), this will not be a 'in your face' disturbance. The problem with ToTD is when one leave it (enable as the default), there's is possibility for user at some point to disable it completely. So, we lose the chance for displaying it in another untouched module. 

For example a new user ignore first ToTD message about chosing an UI and then just open Writer in some days, and keep the ToTD shows up everytime he use Writer but also the ToTD message will change to another topic. When he choose to disable it in the third day, then we would make him/her unaware about UI choice when opening a Calc sheet (and he/she was unaware for Writer also).

With that reason, first dialog UI has a benefit over ToTD.

My suggestion is to make the UI chooser dialog available at startup, other 

- Make the dialog re-accessible every time (to replace View > User Interface menu).
- Improve the ToTD content about UI choice with may be an animated image. This would benefit ToTD for other topic too
Comment 36 Pedro 2020-08-17 09:09:58 UTC
(In reply to V Stuart Foote from comment #34)
> (In reply to Pedro from comment #32)
> > ...
> > dialog without even reading it. It would be better to present a solution
> > that would make the user have to choose an UI. 
> > 
> 
> And that is exactly the 'in your face' dialog many would prefer to avoid.

Many as in you? I would be open to a suggestion from you that actually addresses the point instead of assuming a negative and contrarian point of view when you have a multitude of people pushing this.
 
> No, the UI selection is made per-module and recorded to user profile. Eactly
> as done now from the actions on the View -> User Interface menu.  The
> Tip-of-the-Day framework dialog, or a full UI dialog frame would behave the
> same.


And that's why we are discussing here to change this. That is not user friendly. If an user selects the Tabbed UI once, he will assume that the choice will be for all modules. So I would say that the behaviour you describe should change to avoid the frustration of an user having to repeat the same action to select his preferred UI every time he opens a new module.
Comment 37 John Mills 2020-08-17 09:32:59 UTC
I am not entirely sure about what the negatives of an 'in your face dialogue' are? Is it that we are making the end user 'uncomfortable' by providing them the choice of how they interact with LibreOffice?

As part of the initial tip of the day dialogue would it be possible to have an additional selection question along the lines of:

'Apply the UI choice to all supported LibreOffice Modules?'

Have a radio button for Yes and No, default it to no if needs be, however I think it makes more sense that the selection the user makes is applied to all of the supported modules for consistency and this updates the user profile accordingly.

Kind regards



>  
> > No, the UI selection is made per-module and recorded to user profile. Eactly
> > as done now from the actions on the View -> User Interface menu.  The
> > Tip-of-the-Day framework dialog, or a full UI dialog frame would behave the
> > same.
> 
> 
> And that's why we are discussing here to change this. That is not user
> friendly. If an user selects the Tabbed UI once, he will assume that the
> choice will be for all modules. So I would say that the behaviour you
> describe should change to avoid the frustration of an user having to repeat
> the same action to select his preferred UI every time he opens a new module.
Comment 38 Pedro 2020-08-17 10:14:31 UTC
I am interested why it's such a problem now to have an "in-your-face" dialog but this wasn't an issue for the tip of the day dialog. And this is arguably much more useful and impactful for users and it highlights the work done by the LibO design team. Why is that a problem again?
Comment 39 V Stuart Foote 2020-08-17 14:03:13 UTC
(In reply to Pedro from comment #36)
> (In reply to V Stuart Foote from comment #34)
> > (In reply to Pedro from comment #32)
> > > ...
> > > dialog without even reading it. It would be better to present a solution
> > > that would make the user have to choose an UI. 
> > > 
> > 
> > And that is exactly the 'in your face' dialog many would prefer to avoid.
> 
> Many as in you? I would be open to a suggestion from you that actually
> addresses the point instead of assuming a negative and contrarian point of
> view when you have a multitude of people pushing this.

I am only being pragmatic here. A pop-up dialog as an alternative to changing the default UI to the broken Tabbed Notebook Bar for bug 135501. So sure. However, there is no point to be made--other than it is a non-performant "solution" to impose on the broader user community. Virtually all serious users will make their UI choice--for each module--and be done with it. This UI picker and the ill-conceived attempt to move onto a Notebook bar framework default UI will not improve function of LibreOffice nor its UX. They are gimmicks aimed at new "Benjamin" users, not functional UI. Don't misunderstand, the MUFFIN Notebook Bar is excellent exercise in seeing where GLADE UI builder could take our UNO based controls as a flexible/configurable UI. But the framework is limited compared to fully instrumented Menu, Toolbar & Dialog UI as supplemented by the Sidebar. 

Making the Notebook Bar into a comparably "functional" UI would require uncountable investment in native code to reimplement/wrap UNO controls in native APIs (both MS & Apples).

That is what these ill-convinced actions would be committing the project to.

So excuse me if I seem a little less enthusiastic about these initiative--I just see them as all around bad for the project.

>  
> > No, the UI selection is made per-module and recorded to user profile. Eactly
> > as done now from the actions on the View -> User Interface menu.  The
> > Tip-of-the-Day framework dialog, or a full UI dialog frame would behave the
> > same.
> 
> 
> And that's why we are discussing here to change this. That is not user
> friendly. If an user selects the Tabbed UI once, he will assume that the
> choice will be for all modules. So I would say that the behaviour you
> describe should change to avoid the frustration of an user having to repeat
> the same action to select his preferred UI every time he opens a new module.

What, no! Core tenant of MUFFIN is that it is entirely flexible. We've worked hard to make user customization of each LO module independent and stateful. A UI choice made in Writer should not impact a choice made in Calc. That would be a horrible outcome!

Otherwise my suggestion to retain the View --> User Interface menu items would be the cleanest (and least disruptive) way to integrate any new "UI Picker..." dialog into common use.
Comment 40 John Mills 2020-08-17 15:58:17 UTC
> What, no! Core tenant of MUFFIN is that it is entirely flexible. We've
> worked hard to make user customization of each LO module independent and
> stateful. A UI choice made in Writer should not impact a choice made in
> Calc. That would be a horrible outcome!

That's an interesting point and I really do see your logic there with the flexibility and that is commendable, however do we have any data that people use the interfaces differently across modules? 

I personally think that people like to have consistency across all of the applications where at all possible. Hence why I suggested previously to have a dialogue within the tip of the day that asks question about applying the same interface across all modules. And if required set to no by default for the reason you stated, however I think most users would want the same interface everywhere and that is in their best interest to reduce confusion as the user may well never see this UI tip of the day again and end up with the standard UI in Calc but a Notebookbar UI in Writer. 


> Otherwise my suggestion to retain the View --> User Interface menu items
> would be the cleanest (and least disruptive) way to integrate any new "UI
> Picker..." dialog into common use.

To me that is the status quo and the whole reason why this request was made in the first place, so that people would see the available UI choices and flexibility in LibreOffice front and center. 

I feel that this is better accomplished with a specific first run 'wizard' like choice, however if the same goal is reached with a 'tip of the day' dialogue then that will have to suffice. 

Kind regards
Comment 41 Commit Notification 2020-10-07 16:02:39 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ed8df0ec6ed1af600a4d31223d5bfc3f65c5d7ba

Resolves tdf#117463 - Dialog to show UI options

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 42 John Mills 2020-10-07 17:32:45 UTC
Hi all,

I think that this is fantastic news, is there a screenshot or mock up about how this will work? 

I just have a few questions, will there be a choice for every current UI or are some prioritised over others? If you present a user a choice of 7 UIs to choose from doesn't that just cause confusion?

Will the selection be on a per application basis? I ask as if it is not couldn't we find ourselves in a situation where you might use the Tabbed interlace in one application such as Writer and potentially the standard UI in another, such as Calc, then not see the initial start dialogue again? I think changing all supported applications to the same UI makes sense and reduces confusion. Perhaps an additional dialogue could be made that gives the user the option to change for all or only the current application?

Thank you all for this effort,

John
Comment 43 Heiko Tietze 2020-10-08 13:36:16 UTC
(In reply to John Mills from comment #42)
> I just have a few questions, will there be a choice for every current UI or
> are some prioritised over others? If you present a user a choice of 7 UIs to
> choose from doesn't that just cause confusion?

You get the same list as with View > User Interface but in a dialog. The experimental UIs are shown only when this option is enabled.

> Will the selection be on a per application basis? 

You can Apply <to current module> or Apply to All <all modules> (limited to Writer, Calc, Impress, Draw since we do not have Notebookbars for all other).


I suggest to try the dialog. There is another patch that replaces the View > UI submenu by the new dialog (easy to revert), limited to the classic main menu (Notebookbars still have the submenu; all is customizable).

The patch adds also a new "Tip Of The Day" so new users will be presented with this tip the first time they start LibreOffice. To try this you don't need to press Next 100 times. Go to Tools > Options > Advanced > Expert Options, search for LastTipOfTheDayID, double-click and set it to 222 (the last item, counted up to 0 when the dialog is reshown).

Images both in this dialog and the thumbnail are a matter of improvement. It can be done temporarily on the nightly build. The TipOfTheDay is at share/tipoftheday/toolbarmode.png, the previews at share/toolbarmode/*.
Comment 44 V Stuart Foote 2020-10-08 15:03:24 UTC
(In reply to Commit Notification from comment #41)

> The patch should be included in the daily builds available at
> https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> https://wiki.documentfoundation.org/Testing_Daily_Builds
> 
> Affected users are encouraged to test the fix and report feedback.

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 64ab07edee8eba531fd05cbc5d92315cc2855e92
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

@Heiko, not sure pop-up dialog is plumbed correctly. Dialog is not presenting in this build that has ed8df0e is applied--and still getting to old sub-menu, expected as 7109b69 has not yet rolled.
Comment 45 Heiko Tietze 2020-10-09 07:35:01 UTC
(In reply to V Stuart Foote from comment #44)
> @Heiko, not sure pop-up dialog is plumbed correctly.

Be patient :-) (maybe tomorrow)
Comment 46 V Stuart Foote 2020-10-09 13:26:31 UTC
(In reply to Heiko Tietze from comment #45)
> (In reply to V Stuart Foote from comment #44)
> > @Heiko, not sure pop-up dialog is plumbed correctly.
> 
> Be patient :-) (maybe tomorrow)

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 75030b3a2d4336c494fbe799fb809a37ed7e582f
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

both commits present. 

Several issues:

1) the Tip-of-Day 1/233 holding the pick an interface does not actually show on launch new profile. Rather ToD start at 2/233 and you won't see tip again til cycle through all the other tips. Or possible reset profile. Maybe the ToD mechanism should not be the only mechanism--perhaps make use of the Infobar?

2) In the dialog layout, the descriptive text below the preview is being shifted too low and overlays the 'Close' button position. Packing issue?

3) where is 'Contextual Single' mode? Missing what is actually the most functional for use beside 'Standard Toolbar'
Comment 47 V Stuart Foote 2020-10-09 13:37:46 UTC
Created attachment 166239 [details]
layout issues for UI picker dialog run from the Tip-of-the-Day

(In reply to V Stuart Foote from comment #46)

> 2) In the dialog layout, the descriptive text below the preview is being
> shifted too low and overlays the 'Close' button position. Packing issue?
> 

Sorry, not clear there. This mislayout occurs only when using the 'Run this action now...' button from within the 'Tip or the Day' pop-up.

When run from the View menu or 'hamburger' the pop-up gets reasonable text layout.
Comment 48 Heiko Tietze 2020-10-12 10:12:53 UTC
(In reply to V Stuart Foote from comment #46)
> Several issues:

Please file tickets. Think I can fix all myself.
Comment 49 V Stuart Foote 2020-10-12 14:05:08 UTC
(In reply to Heiko Tietze from comment #48)
> (In reply to V Stuart Foote from comment #46)
> > Several issues:
> 
> Please file tickets. Think I can fix all myself.

done...

bug 137423 -- Launch of the UI picker from Tip of the Day -- radio button UI mode descriptions over top of dialog buttons
bug 137424 -- UI Picker dialog missing 'Contextual single' UI mode
bug 137427 -- UI Picker is not showing by default on first launch of each module
bug 137429 -- Logic for showing the UI Picker dialog via Tip-of-the-Day mechanism seem off
Comment 50 John Mills 2020-10-13 07:04:17 UTC
Hello all,

So I installed the the latest 7.1 alpha last night to provide feedback on this ticket for my experiences as I saw there were a few 'snagging points' highlighted.

My experience is the same as Stuart's of this dialogue not appearing and the tip of the day starting from number 2.

I came back to this ticket to look if others have had the same issue and I can see that Stuart had raised an issue for this point Bug#137427.   

I am copying the dialogue from that ticket to here as it is relevant:

Information from Bug Bug 137427 - UI Picker is not showing by default on first launch of each module 

> V Stuart Foote 2020-10-12 13:58:33 UTC
>
>Not clear if this was not yet implemented, but as spec'd in bug 117463 on first >launch of a module with a clean new profile, the UI picker was going to be >presented.
>
>[tag] [reply] [−] Comment 1 Heiko Tietze 2020-10-12 14:13:18 UTC
>
>I will not force showing the UI picker initially. The TotD is a compromise and >if users don't take the advice it's pretty easy to do later (View > UI...). >Point is that any initial "configure me", "start here", "do that" is odd. My >(personal) take => WF.
>
>[tag] [reply] [−] Comment 2 V Stuart Foote 2020-10-12 14:38:37 UTC
>
>I am of course fine with not forcing it either. Just filed the BZ as it was an >agreed facet of the resolved fixed bug 117463  -- Stuart

So if I understand this correctly @Heiko you have now decided that you will not show an initial dialogue.

"I will not force showing the UI picker initially. The TotD is a compromise and >if users don't take the advice it's pretty easy to do later (View > UI...). >Point is that any initial "configure me", "start here", "do that" is odd. My >(personal) take => WF."

This is completely disingenuous, you have marked this bug report as resolved,it clearly is not. If it is possible now please change this to Wont fix. As clearly you believe that providing this initial dialogue is 'odd' and your (personal) take is => WF.

This goes against everything that has been said in this report for the last months. Finally I thought that there was some understanding of the importance of highlighting the fantastic work done in this field and providing LibreOffice users with a real choice. 

Even Stuart realised that this functionality is a blocker for closing this bug report:

'I am of course fine with not forcing it either. Just filed the BZ as it was an agreed facet of the resolved fixed bug 117463  -- Stuart' 

Clearly as was an agreed facet to resolve this bug and you have now decided that it will not happen the bug by definition is not resolved. Again I suggest if you can then please do the correct thing and change to 'Wont Fix' so that those people who understand the importance of this bug report can move on as I genuinely believed that you had the interests of your user in mind.

Kind regards,

John
Comment 51 Heiko Tietze 2020-10-13 07:12:42 UTC
(In reply to John Mills from comment #50)
> ... please do the correct thing and change to 'Wont Fix'

You have the same rights as me, feel free to change the resolution. And complaints about not showing on start-up are better done in bug 137427.
Comment 52 John Mills 2020-10-13 08:25:02 UTC
Hello Heiko,

Thank you, I have had no part in the resolution of this bug report, so it is inappropriate for me to change description. Clearly a decision was made that the status is 'Resolved' when in reality the bug request will not be resolved as the dialogue currently will not be displayed upon start.

I will make the request in bug 137427 that it is displayed on first launch, but I do not feel that will serve much of a practical purpose if you have already made the decision that it wont be fixed there. This obfuscates the need to track there as that ticket is a child of this one.

This is not a personal criticism only an observation made on both of these tickets and the status of this being set to resolved when currently it will not be implemented as originally stated it would be.

With best regards,

John
Comment 53 Heiko Tietze 2020-10-13 08:29:54 UTC
(In reply to John Mills from comment #52)
> ...will serve much of a practical purpose if you have already made the decision...

There is no dictator in open source projects, and if I'm not willing and arguing against a solution it's not that you or anyone else is blocked doing the work. Actually it is pretty simple now with the patch I submitted.
Comment 54 Mike Kaganski 2020-10-15 11:33:43 UTC Comment hidden (off-topic)
Comment 55 Heiko Tietze 2020-10-16 10:51:41 UTC Comment hidden (off-topic)
Comment 56 John Mills 2020-10-16 11:08:06 UTC
Hi all,

I would just like to apologise if my comments were taken inappropriately, certainly these are in no way meant as any personal attack against any of the developers, Heiko in particular who I know works very hard for the goals of the Document Foundation and LibreOffice in particular.

My concerns were not really about the issue with the first slide not being displayed, I realised this was most likely some sort of bug. More the fact that the description for this bug report is:

'Create a Dialog that shows up on first boot of Writer/Calc/Impress for the user to pick its default UI'  

And that the resolution as provided does not reach that goal, I do like the first tip of the day by the way. But I understand the choice from both points of view. We all walk a very thin line and care about the greater goals of LibreOffice adoption and putting free software in the hands of people who can really benefit from this fantastic product and community.

So once again for any offense I apologise.

Kind regards,

John
Comment 57 Rizal Muttaqin 2020-10-19 06:37:56 UTC
Created attachment 166487 [details]
New ToTD telling user ability to switch UI

I am so thanks for this change, and it quitely nice, but hopefully the action link text can be changed to be something to less technical. Some of idea:

"Change user interface"
"Change LibreOffice interface"

The tooltip also need to be changed. User does not need to know what kind of command they will execute. This "Execute the command .uno:ToolbarModeUI" seems likely will scary user. Some of my suggestion

"Change user interface from a range of choice"
"Run user interface changer dialog"
Comment 58 Mike Kaganski 2020-10-19 06:47:59 UTC
(In reply to Rizal Muttaqin from comment #57)
> but hopefully the
> action link text can be changed to be something to less technical. Some of
> idea:
> ...
> The tooltip also need to be changed. User does not need to know what kind of
> command they will execute. This "Execute the command .uno:ToolbarModeUI"
> seems likely will scary user. Some of my suggestion
> ...

A very reasonable suggestion. But it should be a new issue.
Also, given that the function added there is a very generic one (allowing to run arbitrary UNO command), there may be several ways to solve it:

* using a new translatable hint string in the TofD (a bas one IMO);
* extracting the existing hint from the UNO command itself, something like in https://gerrit.libreoffice.org/c/core/+/85776.
Comment 59 Mike Kaganski 2020-12-02 13:47:18 UTC
*** Bug 138620 has been marked as a duplicate of this bug. ***
Comment 60 Jesse 2021-02-04 16:15:33 UTC
Is there any way to open this dialog manually? It didn't pop up after I updated the flatpak package.
Comment 61 Heiko Tietze 2021-02-04 16:41:31 UTC
(In reply to Jesse from comment #60)
> Is there any way to open this dialog manually? It didn't pop up after I
> updated the flatpak package.

We had a controversial discussion how to implement this. The solution is to advertise this dialog via tip-of-the-day rather than showing it automatically. You can always show the UI picker per View > User Interface... (previously and still available for customization all UI options were listed below User Interface).