Download it now!
Bug 137500 - UI Picker should handle situation when run from Start Center
Summary: UI Picker should handle situation when run from Start Center
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.1.0
Keywords:
Depends on:
Blocks: Tip-Of-The-Day 117463
  Show dependency treegraph
 
Reported: 2020-10-15 11:25 UTC by Mike Kaganski
Modified: 2020-10-22 09:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of problematic case (5.02 KB, image/png)
2020-10-15 11:40 UTC, Mike Kaganski
Details
Screenshot of normal case (32.59 KB, image/png)
2020-10-15 13:45 UTC, Mike Kaganski
Details
UI Picker opened while on Start Center (87.06 KB, image/png)
2020-10-15 15:10 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2020-10-15 11:25:55 UTC
The new UI picker dialog may be not only run from Writer or other component, but also straight from Start Center.

Steps:
1. Open Start Center
2. Help->Show Tip of the Day
3. Show tip 1 ...
4. Run this action now...

In this case, the dialog lacks preview, and also "Apply to" has no component, and should be hidden.
Comment 1 Mike Kaganski 2020-10-15 11:40:05 UTC
Created attachment 166381 [details]
Screenshot of problematic case
Comment 2 V Stuart Foote 2020-10-15 13:18:13 UTC
Could it? The Start Center main menu has no View value currently.

Guess the View menu would need to be added, don't imagine it would require any other effect on the SCs static UI.  So a preview clip of the SC, and maybe text note describing the SC "customization" is minimal but responds to os/DE theme.
Comment 3 Mike Kaganski 2020-10-15 13:23:57 UTC
(In reply to V Stuart Foote from comment #2)

I'm sorry, Stuart, was it posted to the correct report? (Or I might completely not understand it :-))
Comment 4 Mike Kaganski 2020-10-15 13:45:08 UTC
Created attachment 166387 [details]
Screenshot of normal case

Possibly a clarification to description of the bug is required.

The UI Picker dialog is *broken* when called from Start Center. It's OK that it does not change Start Center's appearance (the issue is not about using different UI modes in Start Center), but about the dialog itself: it must still show preview bitmaps; it must show the Information text; and it must hide "Apply to" button (because its action is not applicable to current component), and only show "Apply to All" button.
Comment 5 V Stuart Foote 2020-10-15 15:10:35 UTC
Created attachment 166390 [details]
UI Picker opened while on Start Center

(In reply to Mike Kaganski from comment #3)
> (In reply to V Stuart Foote from comment #2)
> Could it? The Start Center main menu has no View value currently.
> 
> Guess the View menu would need to be added, don't imagine it would require
> any other effect on the SCs static UI.  So a preview clip of the SC, and
> maybe text note describing the SC "customization" is minimal but responds to
> os/DE theme.

>> 
>> I'm sorry, Stuart, was it posted to the correct report? (Or I might
>> completely not understand it :-))

No, it was me and I did not fully engage brain to realize that I'd have to cycle through or reset the TotD counter that Heiko and you have been poking at.

I was thinking just about StartCenter's lack of a View button to launch the dialog, and forgot about the 'Run this action now...' launcher from the TotD.

So, yes the UI Picker could be exposed from the SC (just a little harder at the moment), but as you note a case that needs to handled.
Comment 6 Heiko Tietze 2020-10-16 10:40:07 UTC
Would just not show the menu item in the start center.
Comment 7 Mike Kaganski 2020-10-16 11:18:03 UTC
(In reply to Heiko Tietze from comment #6)
> Would just not show the menu item in the start center.

+1 :-)
Comment 8 Commit Notification 2020-10-22 09:51:40 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/31763e5af060f598c1699662adefe43f13d4db0e

Resolves tdf#137607 and tdf#137500 - Improvements to TotD

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.