Bug 88744 - Experimental Visual formula editor does not link to system clipboard, also is missing Copy and Cut buttons in its selection context menu (see comment 16)
Summary: Experimental Visual formula editor does not link to system clipboard, also is...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Formula-Editor Clipboard
  Show dependency treegraph
 
Reported: 2015-01-23 11:13 UTC by OfficeUser
Modified: 2019-05-15 08:40 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice 4.4.0.3 Math.png (9.94 KB, image/png)
2015-01-30 18:39 UTC, OfficeUser
Details
clip0006.avi (2.96 MB, video/x-msvideo)
2015-02-01 11:16 UTC, OfficeUser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description OfficeUser 2015-01-23 11:13:22 UTC
- Open the formula editor

- Enter any formula

- Select the whole formula or a part of it

- Open the Edit menu

Note: The Copy item is greyed out.

- Right-click on the selected part of the formula to open the context menu

Note: There is no Copy item available in the context menu while we have a Paste item there.


Version: 4.4.0.1
Build-ID: 1ba9640ddd424f1f535c75bf2b86703770b8cf6f
Gebietsschema: de_DE
Comment 1 OfficeUser 2015-01-23 11:13:46 UTC
Please note that CTRL+c works.
Comment 2 Buovjaga 2015-01-29 19:04:22 UTC
It is not greyed out for me.

What operating system do you use?

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-25_23:07:36

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-01-25_23:58:40
Comment 3 OfficeUser 2015-01-30 18:38:39 UTC
(In reply to Beluga from comment #2)
> It is not greyed out for me.

I just have tried master~2015-01-29_23.44.46_LibreOfficeDev_4.5.0.0.alpha0_Win_x86_en-US_de_ar_ja_ru_qtz.msi


This build is NOT able to select the rendered formula or parts of it. Instead this build has old StarOffice behavior where is is only possible to click elements of the formula to navigate to the corresponding part of the formula description language.

So I think you were talking about the menus when selecting parts of the formula description language.

Pleas look at my screen shot of 4.4.0.3. There it is possible to select parts of the rendered formula and there is no Copy item in the context menu.


So we have two problems here:

1.
LibreOffice 4 branch has a new feature where it is possible to select parts of the rendered formula. This feature is missing copy items.

2.
This functions has never founds it's way into 4.5 MASTER. Do we need an additional bug report for it?
Comment 4 OfficeUser 2015-01-30 18:39:24 UTC
Created attachment 112970 [details]
LibreOffice 4.4.0.3 Math.png
Comment 5 OfficeUser 2015-01-30 18:42:38 UTC
Importance set to HIGH because actually we loose functionality with LibO 4.5.
Comment 6 Buovjaga 2015-01-31 07:43:35 UTC
Ok, confirmed with your clarified instructions.
Yeah, I guess you should create a separate report for problem no. 2 and reference it here.
Comment 7 OfficeUser 2015-01-31 12:49:14 UTC
OK.

THIS issue shall now address problem 1.

Problem 2 is now Bug 88975.
Comment 8 V Stuart Foote 2015-01-31 21:45:17 UTC
With core LibreOffice install there is no GUI selection capability within the rendered Formula--some missing extension perhaps?

Seeting NEEDINFO, see bug 88975#c2
Comment 9 OfficeUser 2015-02-01 11:14:59 UTC
(In reply to V Stuart Foote from comment #8)
> With core LibreOffice install there is no GUI selection capability within
> the rendered Formula--some missing extension perhaps?
> 
> Seeting NEEDINFO, see bug 88975#c2

Guys, I am a advanced user and experienced bug reporter since a very long time of the StarOffice derivatives.

I find the advanced formula editor functions (select / CTRL+v / CTRL+v) for the first time in the following final installer:

LibreOffice_4.4.0_Win_x86.msi
+ LibreOffice_4.4.0_Win_x86_helppack_de.msi

I will attach a short video where you can see the feature in action as well as the about dialog and the extension manager.
Comment 10 OfficeUser 2015-02-01 11:16:25 UTC
Created attachment 113018 [details]
clip0006.avi
Comment 11 OfficeUser 2015-02-01 11:18:34 UTC
Typo, correct is:
(select / CTRL+c / CTRL+v)
Comment 12 OfficeUser 2015-02-01 11:19:54 UTC
Additional info:

The functions is also included in the release candidates of 4.4.
Comment 13 Buovjaga 2015-02-01 11:39:23 UTC
I see, the key information is: select by clicking next to the elements and dragging, do not click *on* the elements. I confirm that this works in 4.4, but not in 4.5.
Comment 14 Buovjaga 2015-02-01 11:41:17 UTC
Sorry for the noise: I also confirm that Edit - Copy is greyed out in 4.4.

Win 7 Pro 64-bit, LibO Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Comment 15 OfficeUser 2015-02-01 12:12:38 UTC
Actual situation:
Context menu is missing: Copy, Paste and Cut items.
Edit menu has greyed out Copy, Paste and Cut items.

Solution:
- Add Copy, Paste and Cut items to context menu.
- Enable currently greyed out Copy, Paste and Cut items inn the Edit menu.
Comment 16 V Stuart Foote 2015-02-01 15:28:17 UTC
The "Visual formula editor" remains an "Experimental" feature. It must be toggled on by enabling experimental features.

Tools -> Options -> Advanced: Optional (unstable) options
  "Enable experimental features" ceckbox

Once activated, formula manipulation in the visual window works.

Confirming the lack of Cut and Copy action buttons from the context menu presented when formula elements are selected with mouse. There is a Paste button that accesses the LibreOffice/system clipboard.

The normal clipboard accelerators are provided within Visual formula editor:

<Ctrl>+x  -- cut
<Ctrl>+c  -- copy
<Ctrl>+v  -- paste

However, there does not seem to be linkage between the system clipboard and the Visual formula editor's clipboard. The Paste button will not paste a Visual formula editor clip/copy!

When not in the experimental Visual formula editor mode, individual elements selected with the formula cursor in the formula window, or multiple elements in the formula command windows can be cut, copied and pasted with system clipboard.

@Tomaž (or Jonas) assume that is the state of things, is there anything further to be added to what is needed?
Comment 17 V Stuart Foote 2015-02-01 16:12:21 UTC
Seems we've had the Visual formula editor--with its isolated clipboard--stuck as an experimental feature since the initial 3.3.0 release

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

Resetting version.
Comment 18 OfficeUser 2015-02-01 19:43:36 UTC
After having this issue fixed... what prevents us from removing the Visual formula editor's "experimental" state?

According to some quick and dirty tests, it seems to work! In case if it still has some issues, they will will be revealed after this feature is not "hidden" anymore and used by more people.
Comment 19 V Stuart Foote 2015-02-01 20:25:36 UTC
(In reply to OfficeUser from comment #18)
> After having this issue fixed... what prevents us from removing the Visual
> formula editor's "experimental" state?
> 
> According to some quick and dirty tests, it seems to work! In case if it
> still has some issues, they will will be revealed after this feature is not
> "hidden" anymore and used by more people.

Probably nothing... but that is an issue for the ESC.

Unfortunately it looks like there remains a lot of work still to be done other than making this connection to the general system clipboard.  Here is Jonas' list as of mid-2013.

http://opengrok.libreoffice.org/xref/core/starmath/visual-editor-todo

Some folks have poked at its pieces, but no dev since Jonas' initial GSoC work in 2010 has really dug in to move the Visual formula editor along.
Comment 20 Roman Kuznetsov 2018-07-13 20:42:34 UTC
still repro in

Версия: 6.1.0.1 (x64)
ID сборки: 378e26bd4f22a135cef5fa17afd5d4171d8da21a
Потоков ЦП: 4; ОС:Windows 10.0; Отрисовка ИП: по умолчанию; 
Локаль: ru-RU (ru_RU); Calc: CL