Bug 124908 - Widows and Orphans Control Does Not Work as Expected for Paragraphs in Tables (Formatting)
Summary: Widows and Orphans Control Does Not Work as Expected for Paragraphs in Tables...
Status: RESOLVED DUPLICATE of bug 124366
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-23 12:46 UTC by Adalbert Hanßen
Modified: 2019-05-07 11:47 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample made to easily reproduce and study the buggy behaviour. (253.77 KB, application/vnd.oasis.opendocument.text)
2019-04-23 12:46 UTC, Adalbert Hanßen
Details
Augmented Samplemade to easily reproduce and study the buggy behaviour, with screenshots taken with development version of 2019-05-04 (413.75 KB, application/vnd.oasis.opendocument.text)
2019-05-05 16:24 UTC, Adalbert Hanßen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adalbert Hanßen 2019-04-23 12:46:52 UTC
Created attachment 150947 [details]
Sample made to easily reproduce and study the buggy behaviour.

This error message pertains to 
LibreOffice Writer Version: 6.3.0.0.alpha0+, 
Build ID: 08557a159bde7dab626f36488c88af94d7da0deb, 
CPU threads: 4; 
OS: Linux 4.4; 
UI render: default; 
VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, 
Time: 2019-04-08_16:43:39,
Locale: de-DE (de_DE.UTF-8); 
UI-Language: en-US, 
Calc: threaded 
running under Xubuntu  16.04.6 LTS currently running with Linux kernel 4.4.0-145-generic x86_64

In order to reproduce this bug:

1. Open the attached sample file.

2. Go to the space above the headline “The specimen” and add more forced line breaks before the table until it goes beyond the next page break.

3. carefully observe, that widows or orphans are created despite the widows and orphans rules set for the paragraphs in the table: If they would be honoured, these widows and orphans would not come up. 

One more bug can be observed with the right lower corner cell: The paragraph in it has the feature *Do not split paragraph*. But it is split by the first forced linefeed which one adds above the specimen.
Comment 1 Adalbert Hanßen 2019-05-05 16:24:37 UTC
Created attachment 151186 [details]
Augmented Samplemade to easily reproduce and study the buggy behaviour,  with screenshots taken with development version of 2019-05-04

I have checked if the bug is still in the current development version: Unfortunately it is.
Comment 2 Xisco Faulí 2019-05-07 11:47:17 UTC
Thanks for reporting this issue.
It seems like a dupe of bug 124366 and will be fixed in LibreOffice 6.2.4.

*** This bug has been marked as a duplicate of bug 124366 ***