Bug 124366 - FILEOPEN DOCX (REGRESSION): Orphan and Widow control for paragraph isn't applied in documents made with Microsoft Word
Summary: FILEOPEN DOCX (REGRESSION): Orphan and Widow control for paragraph isn't appl...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:6.3.0 target:6.2.4
Keywords: bibisected, bisected, regression
: 124908 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-03-27 14:52 UTC by NISZ LibreOffice Team
Modified: 2019-05-15 02:54 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (20.88 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-03-27 14:53 UTC, NISZ LibreOffice Team
Details
Screenshot (885.50 KB, image/png)
2019-03-27 14:54 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-03-27 14:52:43 UTC
Description:
LibreOffice Writer ignores the Orphan and Widow control settings applied to a paragraph in Microsoft Word.

Steps to Reproduce:
    1. Create a new document in Microsoft Word.
    2. Fill at least one and half pages with text – make sure that the last paragraph of the first page flows into the second page.
    3. Go to the end of the paragraph that flows from the first to the second page, and select the section from the end of the first line of the second page to the end of the paragraph – and delete it. This should trigger the orphan control, and move the last line from the first page to the second page to make sure that at least two lines are on the second page.
    4. Save the document as DOCX and close Microsoft Word.
    5. Open the document in LibreOffice Writer.

Alternatively, you can use the attached DOCX file (Orphan_widow_control.docx).

Actual Results:
Orphan and Widow control settings aren't applied to the paragraph.

Expected Results:
Orphan and Widow control settings should be applied to the paragraph.


Reproducible: Always


User Profile Reset: No



Additional Info:
LibreOffice details:
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 5a907fe76bc628629fddb5501727642468d38dae
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-03-22_00:18:04
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded

Bibisect log:
# bad: [f7c1838d18d55ceb798a86680ce8a2e9b083f3ef] source sha:ade1df0948563b532a5d293c31d46a4f042559ee
# good: [ea94942caaf195b8d8b2d5c2abb523359ab390e7] source sha:a20a2d7e0d28658f2d9089da076961a599833a28
git bisect start 'origin/master' 'oldest'
# good: [bdc1d1813ab88aba96b72536898293ae576016e6] source sha:1bf68dbf53f4b5308e295058226abd6d6fb49c3d
git bisect good bdc1d1813ab88aba96b72536898293ae576016e6
# good: [ddd5d7fc335077df25fb027ab9211c3917933b68] source sha:358b8a451f502d53e01e6b1dc6afa24ee9c5e8bc
git bisect good ddd5d7fc335077df25fb027ab9211c3917933b68
# bad: [dcf9e91fc6ab11a4a89e77fd30721b5c624cdc12] source sha:cddf072a62208d2514f97ba5c0d3577d7d88b8de
git bisect bad dcf9e91fc6ab11a4a89e77fd30721b5c624cdc12
# good: [6046fe46ff0d68e273695c942bf49984c9552f51] source sha:aa1b922c0f667d833e53b282ad9bbb78dec38502
git bisect good 6046fe46ff0d68e273695c942bf49984c9552f51
# bad: [633670da4d96e61906a9227dd7928e77b7f8b40e] source sha:7a13fd8d6cea0e3096eef956bc33e1336d4b2d8c
git bisect bad 633670da4d96e61906a9227dd7928e77b7f8b40e
# good: [06df394fd9c09a1f928300f74cd1dcc757f4f6a5] source sha:9584b37b10fb84934023cb7f4df3d05223647a38
git bisect good 06df394fd9c09a1f928300f74cd1dcc757f4f6a5
# good: [df0a648cace16cc00ecca47103cc3c72b916ea75] source sha:21233e29602e3a003b18bb0710e9be458bc27235
git bisect good df0a648cace16cc00ecca47103cc3c72b916ea75
# good: [bd3069349af11db03321e331548666908362e50d] source sha:33048db2b4f7fd6bc7055effe11ee37cf7045c46
git bisect good bd3069349af11db03321e331548666908362e50d
# good: [9a16dab1616168ebaa675eee440d9424cfd83276] source sha:c9bb48386bad7d2a40e6958883328145ae439cad
git bisect good 9a16dab1616168ebaa675eee440d9424cfd83276
# good: [ce9c271c1d1ea0ae25f22f458d8e725fcf0467ab] source sha:0aa8fbe22986aba5bf7c24e91cc3f7aff5efc296
git bisect good ce9c271c1d1ea0ae25f22f458d8e725fcf0467ab
# bad: [3d63f56d8f2440e98d1e4f6aa05e30a335a99878] source sha:b7d4418c309c8bc4fd25485dd3a0ea6ad9edf34e
git bisect bad 3d63f56d8f2440e98d1e4f6aa05e30a335a99878
# good: [11d66878eaa0fd51a8ad50c6864d0179e3a70282] source sha:3abe1e83c18c5778d60252092e9cc70c4c63268b
git bisect good 11d66878eaa0fd51a8ad50c6864d0179e3a70282
# first bad commit: [3d63f56d8f2440e98d1e4f6aa05e30a335a99878] source sha:b7d4418c309c8bc4fd25485dd3a0ea6ad9edf34e
Comment 1 NISZ LibreOffice Team 2019-03-27 14:53:49 UTC
Created attachment 150319 [details]
Example file
Comment 2 NISZ LibreOffice Team 2019-03-27 14:54:24 UTC
Created attachment 150320 [details]
Screenshot
Comment 3 NISZ LibreOffice Team 2019-03-27 15:29:35 UTC
Adding Cc: to Michael Stahl
Comment 4 Xisco Faulí 2019-03-27 16:20:28 UTC
Reproduced in

Version: 6.3.0.0.alpha0+
Build ID: 705558aa455403cd006993f95b5b13981fdb3483
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Xisco Faulí 2019-04-09 23:12:11 UTC
attachment 83524 [details] from bug 67663 is also affected by this problem
Comment 6 Xisco Faulí 2019-04-09 23:14:22 UTC
and attachment 106595 [details] from bug 84128
Comment 7 Commit Notification 2019-05-06 15:50:04 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/1caea03fcc6c24e38b2d1d9f6097ad84183ffefd%5E%21

tdf#122892 tdf#124366 sw: fix loop in SwTextFrame::CalcFollow()

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Michael Stahl (CIB) 2019-05-06 16:35:34 UTC
hope it's fixed on master...
Comment 9 Commit Notification 2019-05-06 18:35:02 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/1c4b53909b2a1c99dfcb5bbbb1685e5100c503c6%5E%21

tdf#122892 tdf#124366 sw: fix loop in SwTextFrame::CalcFollow()

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2019-05-06 21:39:03 UTC
Verified in

Version: 6.2.5.0.0+
Build ID: 6c3ceaf3e4d59c658d0f9e4e1b22204be25f74e2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Michael Stahl, thanks for fixing this issue!!
Comment 11 Xisco Faulí 2019-05-07 11:47:17 UTC
*** Bug 124908 has been marked as a duplicate of this bug. ***
Comment 12 Commit Notification 2019-05-09 11:21:02 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-4":

https://git.libreoffice.org/core/+/880fa5382c0249f09584a9a7af498cecaa75a08c%5E%21

tdf#122892 tdf#124366 sw: fix loop in SwTextFrame::CalcFollow()

It will be available in 6.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.