Bug Hunting Session
Bug 124927 - Crash when adding more than one object to the animated images dialog
Summary: Crash when adding more than one object to the animated images dialog
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.0.0.beta2+
Hardware: All All
: medium critical
Assignee: Caolán McNamara
URL: https://help.libreoffice.org/6.2/en-U...
Whiteboard: target:6.3.0 target:6.2.5 target:6.2.4
Keywords: bibisected, bisected, needUITest, regression, wantBacktrace
Depends on:
Blocks: AW080-Regressions
  Show dependency treegraph
 
Reported: 2019-04-24 09:59 UTC by Heiko Tietze
Modified: 2019-05-10 15:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["sd::DrawView::DrawView(sd::DrawDocShell *,OutputDevice *,sd::DrawViewShell *)"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2019-04-24 09:59:56 UTC
* create some shapes, e.g. a rectangle and edit > duplicate > some rotation
* select all
* open Insert > Media > Animated images
* click the 'Apply Objects' button under Image => crash

It works with single objects, however I cannot figure out how to produce the animated gif finally. And since the preview (?) area is always empty I vote for making this dialog experimental.
Comment 1 Xisco Faulí 2019-04-24 10:40:03 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=dfefe448c41921f2f1e54d3f69b8b9e89031d055

author	Armin Le Grand <Armin.Le.Grand@cib.de (CIB)>	2018-03-01 15:54:32 +0100
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-04-07 00:28:30 +0200
commit	dfefe448c41921f2f1e54d3f69b8b9e89031d055 (patch)
tree	1aace31054b5740e2faffcbc5de66a791be27f7d
parent	eba4d5b2b76cefde90cb3d6638c736f435023a45 (diff)
SOSAW080: Added first bunch of basic changes to helpers

Bisected with: bibisect-linux64-6.1

Adding Cc: to Armin Le Grand
Comment 2 Caolán McNamara 2019-05-09 14:25:10 UTC
https://gerrit.libreoffice.org/#/c/72054/ makes it not crash for me
Comment 3 Commit Notification 2019-05-09 20:31:00 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/23338100720a76420e302f02b876b3708a95cdda%5E%21

Resolves: tdf#124927 crash on multiple drawing shapes in animation dialog

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Caolán McNamara 2019-05-09 20:32:26 UTC
6-2 backport in gerrit
Comment 5 Commit Notification 2019-05-09 20:43:02 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/6670ae80580a5f80d6042b7f9d49308862472c90%5E%21

Resolves: tdf#124927 crash on multiple drawing shapes in animation dialog

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2019-05-10 08:19:19 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: e16641769df8cb2631808acf43e0ee8bd31cb0f7
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Caolán, thanks for fixing this issue!