Download it now!
Bug 134674 - Crash: Impress - Insert Animated Image - Doubleclick on 'Create' - 3 type of crashs [Regression]
Summary: Crash: Impress - Insert Animated Image - Doubleclick on 'Create' - 3 type of ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1 all versions
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.0.0.2 target:7.1.0 target:6.4.6
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks: Regressions-AW080
  Show dependency treegraph
 
Reported: 2020-07-09 05:27 UTC by Mike
Modified: 2020-07-10 08:27 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Crash type a screencast (647.01 KB, video/x-matroska)
2020-07-09 05:35 UTC, Mike
Details
Crash type b screencast (1.20 MB, video/x-matroska)
2020-07-09 05:43 UTC, Mike
Details
Crash type c screencast (879.79 KB, video/x-matroska)
2020-07-09 05:44 UTC, Mike
Details
bt with debug symbols (13.89 KB, text/plain)
2020-07-09 07:53 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike 2020-07-09 05:27:00 UTC
Description:
In Impress I get a crash when I choose an object, open the window "Animation" (via "Insert Animated Image"),  click on the icon "Apply Object", click twice on "Create" and close the window.

It crashes always, but I can't see a pattern, which kind of crash happens. It's either:
a) Impress crashes without Document Recovery window. You don't get a "Send Crash Report" window at a restart of LO.
b) Impress crashes and freezes the Document Recovery window. After that the process soffice.bin has to be killed with the Task Manager. (If you restart LO after that, you get a "Send Crash Report" window!)
c) Impress "thinks" it crashed - that means, it does not crash instantly after closing "Animation" window. But if you close Impress with(out) saving, Impress opens the "Document Recovery" window - which is empty of couse if you have not saved - and restarts LO. (No "Send Crash Report" window)


A crash report from a c) crash:

crashreport.libreoffice.org/stats/crash_details/e950ca0b-9831-457c-b831-d2f83d203087

I attach short screencasts of the issues.


Steps to Reproduce:
1. Start Impress 
2. Choose object (like "Click to add Title" textbox) or create one first (like a rectangle)
3. Open "Animation" window (Insert Animated Image)
4. Click on "Apply Object" icon (on the left below "Image:")
5. Click twice on "Create"
6.  Close "Animation" window
Either you get the crash, that I described as a) and b)
or go on and
7. Close Impress with(out) saving
and get crash c)





Actual Results:
Impress crashes either at closing "Animation" window or at closing Impress with(out) saving

Expected Results:
Impress crashs not.



Reproducible: Always


User Profile Reset: No



Additional Info:
It seems to be a regression. I can provoke the issues with 6.1, but can't provoke them with 6.0.

Crash with LO 6.1
Version: 6.1.0.3
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: de-DE (de_DE); Calc: CL

Version: 7.0.0.0.beta2
Build ID: 00(Build:0)
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: kf5
Locale: en-US (en_DE.UTF-8); UI: en-US
Calc: threaded

Version: 7.0.0.1.0+ (x64)
Build ID: 74d3471e74478a18c5a54ed4e9be83a5c0aadd8b
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-US
Calc: threaded

Does NOT crash with LO 6.0
Version: 6.0.5.2
Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: de-DE (de_DE); Calc: CL
Comment 1 Mike 2020-07-09 05:29:43 UTC
Correction: The link of the crash report is from a b) type crash, not a c) type!
Comment 2 Mike 2020-07-09 05:35:38 UTC
Created attachment 162826 [details]
Crash type a screencast
Comment 3 Mike 2020-07-09 05:42:22 UTC
Comment on attachment 162826 [details]
Crash type a screencast

It`s type a, not c. Sorry for messing up, the keyboard on my phone is just too small ... ;)
Comment 4 Mike 2020-07-09 05:43:12 UTC
Created attachment 162827 [details]
Crash type b screencast
Comment 5 Mike 2020-07-09 05:44:09 UTC
Created attachment 162828 [details]
Crash type c screencast
Comment 6 Julien Nabet 2020-07-09 07:53:39 UTC
Created attachment 162834 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 7 Xisco Faulí 2020-07-09 09:34:00 UTC
LibreOffice started to crash clicking on 'Apply Object' button after https://cgit.freedesktop.org/libreoffice/core/commit/?id=dfefe448c41921f2f1e54d3f69b8b9e89031d055. Later on, this crash was fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=91b0d2122bdee361bf5412a42d48ff051159cbf2 and since then, the animation dialog crashes when it's closed.

@Caolán, since you fixed bug 124927, I thought you might be interested in this issue as well...
Comment 8 Telesto 2020-07-09 09:40:19 UTC
@Mike
The crashing behavior is bit of a thing. Bug 133770 is about case b
Comment 9 Commit Notification 2020-07-09 14:18:12 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/6c09d2e5d7880b6facf905cce97d23e78a90ac53

Resolves: tdf#134674 object inserting using dialogs SdrModel

It will be available in 7.0.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-07-09 18:47:41 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/06f0c944e66005266ed85051d301332b4e5c0653

Resolves: tdf#134674 object inserting using dialogs SdrModel

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Caolán McNamara 2020-07-09 18:50:21 UTC
fixed in master and 7-0, backport to 6-4 in gerrit.
Comment 12 Commit Notification 2020-07-10 08:27:25 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/c1e7da2ce1b7705514ca09ace5a53e86474e5fd2

Resolves: tdf#134674 object inserting using dialogs SdrModel

It will be available in 6.4.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.