Bug 125156 - Option “Automatically detect high contrast mode of operating system“ does not work
Summary: Option “Automatically detect high contrast mode of operating system“ does not...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: High-Contrast
  Show dependency treegraph
 
Reported: 2019-05-07 13:06 UTC by Harald Koester
Modified: 2019-05-07 15:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2019-05-07 13:06:49 UTC
In order to reproduce the bug:

[1] Open a new text document.
[2] Verify if option „Automatically detect high contrast mode of operating system“ is not checked (Menu: Tools > Options… > LibreOffice > Accessibility). If checked uncheck option.
[3] Enable the high contrast mode of your OS. With Win 10: Open „Settings“ > Ease of Access > High Contrast > Activate High Contrast. Due to the unchecked option I expect that there are no changes of the LibreOffice user interface. But nearly all elements of the user interface are changed: Menu bar (items not visible), menus, symbol bars, rulers, scroll bars, status bar, all elements of dialogues and all elements of the sidebar (Symbols in sidebar are partly not or badly visible).
Comment 1 V Stuart Foote 2019-05-07 14:59:03 UTC
Can not confirm. This works as well as it has from > 4.2.  On Windows 10 Home 64-bit en-US (1809) with current master/6.3.0

This is kind of a mess, see bug 35365 and fix in bug 71511 [1]

Issue remains that os/DE "Dark Desktop" themes (see bug 118320) are distinct from HighContrast accessibility themes which are flagged from the os/DE as such.

Presently we split the difference--we detect HC always, but still set theme based on colors passed from DE--only FONTCOLOR and DOCCOLOR respond to the a11y HC checkbox.  

When System HC is active--the colors for DOCCOLOR and FONTCOLOR are read as set by the HC theme.

But if the Tools -> Options -> Accessibility "Automatically Detect HighContrast Mode of Operating System" is left unchecked, System HC is *still* detected and LibreOffice responds: Icons will shift to Sifr, menu text and back ground will change.

Without the checkbox only DOCCOLOR and FONTCOLOR do not pickup colors from the HC theme--and those will remain as set in user profile or default (Black font on White document).

The system HC flag is distinct from new Windows dark desktop modes--which do not trigger the HC handling.

=-ref-=
[1] https://cgit.freedesktop.org/libreoffice/core/commit/?id=7b0e8b9c8541250be65ce228b67ff5adb105b732
Comment 2 V Stuart Foote 2019-05-07 15:12:41 UTC
IIUC autodetection of the os set HC happens here:

https://opengrok.libreoffice.org/xref/core/vcl/source/window/settings.cxx#149

and then colors are set/ignored here:
https://opengrok.libreoffice.org/xref/core/svtools/source/config/colorcfg.cxx#208