Bug Hunting Session
Bug 125227 - duplicate assignment of accelerators on a single menu disrupts keyboard use, eliminate duplicate accelerators
Summary: duplicate assignment of accelerators on a single menu disrupts keyboard use, ...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2019-05-12 01:04 UTC by TorrAB
Modified: 2019-05-16 08:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description TorrAB 2019-05-12 01:04:05 UTC
Description:
I any Writer document, Format: hit ~o x or ~o s or ~o n or ~o b or ~o i: get immediately the submenu; good.
	Now, hit ~o h or ~o a: you must hit Enter to get the submenu; inconsistent and annoying.

Steps to Reproduce:
1.hit ~o a
2.
3.

Actual Results:
highlight Paragraph

Expected Results:
open format para submenu


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 V Stuart Foote 2019-05-12 14:40:32 UTC
Confirming observation on Windows 10 Home 64-bit en-US with
Version: 6.3.0.0.alpha0+ (x64)
Build ID: 425a570a114d9a087e5320f071604f64d43fcec1
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-05-10_01:47:15
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

Accelerators assigned are localized.

So, in en-US locale

The Format <alt>+o -> h (C_haracter) -> h (Anc_hor); or
Format <alt>+o -> a (P_aragraph) -> a (Rot_ate or Flip)

However, duplicate accelerators on a menu are not prohibited. And, so long as the accelerators function (e.g. do not trap and block action of another accelerator) they are allowed.

=> NAB
Comment 2 TorrAB 2019-05-14 12:24:50 UTC
I agree it's not a bug.
But it would make a useful enhancement.
Comment 3 V Stuart Foote 2019-05-14 13:37:21 UTC
Personally, not a fan. Behavior when accelerators are duplicated now is pretty consistent--just have to be aware of it. IMHO => WF
Comment 4 TorrAB 2019-05-15 14:05:00 UTC
	Ah! Now I understand the indirect (via Enter) shortcut: duplication!
Well, duplicate assignments should be avoided (if not prohibited). Easily: make shortcuts case-sensitive, as in Format: <alt>+o ->
* h (C_haracter); H (Anc_Hor); or
* a (P_aragraph); A (Rot_Ate or Flip)
	Most shortcuts would not change; capitals would be assigned to less-used menu items. In the above example, user must (currently) hit 'a' twice, then Enter, to open the RotateOrFlip menu; with a case-sensitive assignment, A (shift-a) would do it.
Comment 5 V Stuart Foote 2019-05-15 14:16:26 UTC
(In reply to TorrAB from comment #4)
> 	Ah! Now I understand the indirect (via Enter) shortcut: duplication!
> Well, duplicate assignments should be avoided (if not prohibited). Easily:
> make shortcuts case-sensitive, as in Format: <alt>+o ->
> * h (C_haracter); H (Anc_Hor); or
> * a (P_aragraph); A (Rot_Ate or Flip)
> 	Most shortcuts would not change; capitals would be assigned to less-used
> menu items. In the above example, user must (currently) hit 'a' twice, then
> Enter, to open the RotateOrFlip menu; with a case-sensitive assignment, A
> (shift-a) would do it.

Unfortunately that would not work--keyboard gymnastics to enter sequence of <alt> to toggle accelerators active, then to remember if the mnemonic is <shift> upper or just the lower. *Not* the best UX.
Comment 6 TorrAB 2019-05-16 07:10:31 UTC
No 'need to remember if the mnemonic is <shift> upper or just…', one can SEE if the underlined character is 'a' or 'A'. And hitting shift-a is less gymnastic than a twice and Enter.
Besides, the second choice marked 'A' could respond to a 2nd 'a' hit if the user did not Shift — for whatever reason, including not being used to the new procedure.
Comment 7 Heiko Tietze 2019-05-16 08:26:38 UTC
We do care about duplicate shortcuts and try to avoid. You cannot use shift for the accelerator (would be a shortcut then). So based on c4 and c3 I close the issue as WF. 

But please don't hesitate to report issues - and potential solutions. Your contribution is very welcome.