Bug 125312 - FILEOPEN DOCX Table with two rows disappears after line break
Summary: FILEOPEN DOCX Table with two rows disappears after line break
Status: RESOLVED DUPLICATE of bug 116194
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Tables Writer-Page-Break DOCX-Page
  Show dependency treegraph
 
Reported: 2019-05-15 14:24 UTC by NISZ LibreOffice Team
Modified: 2019-12-20 09:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Word (43.66 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-05-15 14:24 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Word and Writer (90.95 KB, image/png)
2019-05-15 14:25 UTC, NISZ LibreOffice Team
Details
Screenshot of the document in bibisect-win64-6.5 (62.44 KB, image/png)
2019-12-20 09:31 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-05-15 14:24:02 UTC
Description:
Attached file is a minimized user doc. It contains a page break followed by a two rows table.
Opening the file in Writer makes the page break and the table disappear.

Actual Results:
- 

Expected Results:
- 


Reproducible: Always


User Profile Reset: No



Additional Info:
Bibisect log:

# bad: [88fbca43bcebd0a49ebd2c881905761f9a8fee5d] source sha:2d13cf60ecdab83997c9cd7275c799ddd96617cd
# good: [c67d0ea7e4829f52c6d5a787b70a63a0f9275868] source sha:fc8f44e82de4ebdd50ac5fbb9207cd1a59a927e3
git bisect start 'latest' 'oldest'
# good: [fd3248eb87da183560b48abdaa5ca425196379b9] source sha:0ea119318a9102e145ad007811759281afbe7305
git bisect good fd3248eb87da183560b48abdaa5ca425196379b9
# good: [9c7bccc4e51af29518f948592d76bb6deb13dd55] source sha:6835d9f3074c1030be6632bdaff6c8398c696429
git bisect good 9c7bccc4e51af29518f948592d76bb6deb13dd55
# bad: [47bbca901323efe21566af499f9cd3609515d0e2] source sha:1d188294fd96a82e7200550f8950aa456a481410
git bisect bad 47bbca901323efe21566af499f9cd3609515d0e2
# bad: [6e2b1a9271327a73c792af5c286b9ee76e9cacf5] source sha:b98ce8b9c5201a61a60a9f7010e5ddfafd6fcecd
git bisect bad 6e2b1a9271327a73c792af5c286b9ee76e9cacf5
# good: [df078bedbff9fe5c60ddebda0d1dd6033bb48a24] source sha:c12bc7f8949b6eda629ad48218c7cc19f8f767ee
git bisect good df078bedbff9fe5c60ddebda0d1dd6033bb48a24
# good: [db0b8669a1cdfe62cea15aac04f004d49d31f040] source sha:cce9c76409affdec3960aa5d047de6fd68363e81
git bisect good db0b8669a1cdfe62cea15aac04f004d49d31f040
# good: [db0b8669a1cdfe62cea15aac04f004d49d31f040] source sha:cce9c76409affdec3960aa5d047de6fd68363e81
git bisect good db0b8669a1cdfe62cea15aac04f004d49d31f040
# bad: [17ec4bde94dcc7fe1e3999e0fb3b53469b849d8a] source sha:25d88d2b8eebb4782a016e03aa8562ad9fa15b7b
git bisect bad 17ec4bde94dcc7fe1e3999e0fb3b53469b849d8a
# good: [6eaa636d37dd445da2313ec4c9868a36b297d180] source sha:4d225d3e7f3dbbb463fd0229f3e6403407e34f62
git bisect good 6eaa636d37dd445da2313ec4c9868a36b297d180
# bad: [c9b346010aa1b0393c146e52a090e036b76f4ae9] source sha:dd6641962d56c91dd6a1073a3c80ea85926211a5
git bisect bad c9b346010aa1b0393c146e52a090e036b76f4ae9
# bad: [ed471f0744e2a17d427d569f728826f57cdb6226] source sha:532acfde021fb78de64faefeb561632b333931a2
git bisect bad ed471f0744e2a17d427d569f728826f57cdb6226
# bad: [c6b994025c514db834ee2ee59f09f18812886564] source sha:a80f7551c917adec593a59900e20be7327c7cbac
git bisect bad c6b994025c514db834ee2ee59f09f18812886564
# bad: [158edc03f95b0236f4a89de5ed2675c8b9c1716c] source sha:2e8aad6d45c53d554ccaf26de998ede708cfc289
git bisect bad 158edc03f95b0236f4a89de5ed2675c8b9c1716c
# good: [2254397000a5118b4a2cb08087cd17ba0fb1c558] source sha:cf058da1e5664bc8c30a5777e2c1dbf059a6304f
git bisect good 2254397000a5118b4a2cb08087cd17ba0fb1c558
# first bad commit: [158edc03f95b0236f4a89de5ed2675c8b9c1716c] source sha:2e8aad6d45c53d554ccaf26de998ede708cfc289
Comment 1 NISZ LibreOffice Team 2019-05-15 14:24:39 UTC
Created attachment 151441 [details]
Example file from Word
Comment 2 NISZ LibreOffice Team 2019-05-15 14:25:13 UTC
Created attachment 151442 [details]
Screenshot of the original document side by side in Word and Writer
Comment 3 Dieter 2019-05-15 17:12:31 UTC
I confirm it with

Version: 6.2.3.2 (x64)
Build-ID: aecc05fe267cc68dde00352a451aa867b3b546ac
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded

Additional information: It doesn't depend on change of page format. If I change second page to portrait the bug occurs also.
Comment 4 Gabor Kelemen (allotropia) 2019-05-17 06:38:00 UTC
Steps to reproduce from a new document:

    1. Create a new document in the Microsoft Word.
    2. Insert a new section.
    3. Insert a two rows table on the top of the new section directly.
    4. Drag the left border of the table’s first row
    5. Move the border to RIGHT direction. (Remain the second row on the original place!)
    6. Save the document in DOCX format.
    7. Open the document with LibreOffice Writer.
Comment 5 Xisco Faulí 2019-05-22 16:23:30 UTC
Dear NISZ LibreOffice Team,
Please, do not forget to add the regression, bibisected and bisected tags if you bisect and issue...
Comment 6 Gabor Kelemen (allotropia) 2019-06-06 13:17:31 UTC
Clickable reference:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2e8aad6d45c53d554ccaf26de998ede708cfc289

author	Vinaya Mandke <vinaya.mandke@synerzip.com>	2014-04-18 15:50:51 +0530
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2014-04-24 12:57:51 +0200

fdo#39056 fdo#75431 Section Properties if section starts with table
Section properties are not imported if the section starts with a table for DOCX,
and also for a few RTF files with combination of tables and section breaks.
SwXBodyText::createTextCursorByRange is not able to find the start of section and hence
section properties are not applied.
Comment 7 NISZ LibreOffice Team 2019-12-20 09:31:33 UTC
Created attachment 156688 [details]
Screenshot of the document in bibisect-win64-6.5
Comment 8 NISZ LibreOffice Team 2019-12-20 09:36:03 UTC
Bibsected with bibisect-win64-6.5 to: 

author
László Németh <nemeth@numbertext.org> Mon Dec 02 19:02:43 2019 +0100 

committer
László Németh <nemeth@numbertext.org> Sun Dec 08 15:53:39 2019 +0100 

tdf#116194 DOCX import: fix missing tables with w:gridBefore

*** This bug has been marked as a duplicate of bug 116194 ***