Download it now!
Bug 125346 - PPTX export: Shape has wrong fill color comming from theme
Summary: PPTX export: Shape has wrong fill color comming from theme
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: medium normal
Assignee: Tamás Zolnai
URL:
Whiteboard: target:6.3.0 target:6.2.5
Keywords: bibisected, regression
Depends on:
Blocks: PPTX OOXML-Doc-Themes Master-Slide
  Show dependency treegraph
 
Reported: 2019-05-17 18:19 UTC by Tamás Zolnai
Modified: 2019-05-21 11:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test document with the buggy shape (21.56 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2019-05-17 18:19 UTC, Tamás Zolnai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Zolnai 2019-05-17 18:19:03 UTC
Description:
The attached document contains one shape on the first slide. After a round trip in LO, the shape's fill color changes from green to blue. The document contains two master slides using two different color themes. The root of the issue is that the export code finds the incorrect theme for the specific slide.

Steps to Reproduce:
1. Open the attached PPTX -> the shape has green fil color
2. Save it back to a different PPTX file
3. Open the saved file again -> the shape has blue fill color

Actual Results:
After an RT shape has blue fill color.

Expected Results:
After an RT shape should have green fill color.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Tamás Zolnai 2019-05-17 18:19:43 UTC
Created attachment 151490 [details]
Test document with the buggy shape
Comment 2 Commit Notification 2019-05-18 10:42:12 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/a8bba60e8b655167ad91edcd0c2d1723d525b546%5E%21

tdf#125346: PPTX export: Shape has wrong fill color comming from theme

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2019-05-19 19:20:50 UTC
Tamás Zolnai committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/2506c835834acfdc344227a82f407e3b818db321%5E%21

tdf#125346: PPTX export: Shape has wrong fill color comming from theme

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2019-05-21 11:16:51 UTC
Verified in

Version: 6.3.0.0.alpha1+
Build ID: 38ac0586448d4f07811b139f62f62686b029feba
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Tamás Zolnai, Thanks for fixing this issue!