Bug 84205 - FILESAVE: Theme Colors inverted in drawings after PPTX roundtrip (black part turned to white)
Summary: FILESAVE: Theme Colors inverted in drawings after PPTX roundtrip (black part ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0 target:6.0.4 target:5.4....
Keywords: bibisected, bisected, filter:pptx, regression
Depends on:
Blocks: PPTX OOXML-Doc-Themes
  Show dependency treegraph
 
Reported: 2014-09-23 01:16 UTC by Luke
Modified: 2018-05-31 08:45 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Roundtrip before and after comparison (369.14 KB, image/png)
2014-09-23 01:16 UTC, Luke
Details
stripped-down .PPTX with only 1 picture before RT (578.81 KB, application/vnd.ms-powerpoint.12)
2014-09-23 15:56 UTC, Luke
Details
document as originally rendered in Office2007 (371.30 KB, image/png)
2014-10-18 18:56 UTC, V Stuart Foote
Details
document as rendered in Office365 - PowerPoint 2013 (131.45 KB, image/png)
2014-10-18 19:13 UTC, V Stuart Foote
Details
document round trip LO433 pptx--odp--pptx on Windows w - LO 4331 (378.89 KB, image/png)
2014-10-18 19:15 UTC, V Stuart Foote
Details
Simple Example of Inverted colors (882.20 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2015-05-29 04:27 UTC, Luke
Details
Another Simple example of theme color lost (44.53 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-02-09 20:57 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2014-09-23 01:16:44 UTC
Created attachment 106698 [details]
Roundtrip before and after comparison

This bug was observed on LibreOffice v4.4 under Linux. When you save as .pptx, the black and white in the pictures will be inverted the next time you open the file. 

Steps to reproduce the bug:
1. Open attachment 83059 [details] in Impress
2. Save as .pptx
3. Open in PowerPoint,OneDrive, or Impress 
4. Compare the documents. 

Note In the 5 pictures in the middle, the black part has been turned to white.
Comment 1 Luke 2014-09-23 15:56:28 UTC
Created attachment 106747 [details]
stripped-down .PPTX with only 1 picture before RT
Comment 2 Yousuf Philips (jay) (retired) 2014-09-24 07:07:28 UTC
Can confirm that its in 4.4 master, 4.2.6, 3.6.7, and 3.3.0 on Linux.

So the problem colors occur like this.

1) Master Slide - Parallelogram is RGB [85,85,85] on opening and [242,241,232] on reopening.

2) Slide 1 - Speaker and monitor icons are in Gray 9 on opening and [238,236,225] on reopening.

3) Slide 1 - There is a rectangle gradient going from #dddcd0 to #262626 on opening and #1f497d to #ffffff on reopening.

4) Slide 1 - There are 3 orange lines with style=continuous on opening and are blue on reopening with style=none, so they are invisible. (this is a regression as this is fine in 4.2.6)

Version: 4.4.0.0.alpha0+
Build ID: 935e8fc98c033680029e4531747a2f680f50d5ca
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-09-21_23:17:52
Comment 3 V Stuart Foote 2014-10-18 18:56:07 UTC
Created attachment 108034 [details]
document as originally rendered in Office2007
Comment 4 V Stuart Foote 2014-10-18 19:13:40 UTC
Created attachment 108035 [details]
document as rendered in Office365 - PowerPoint 2013
Comment 5 V Stuart Foote 2014-10-18 19:15:20 UTC
Created attachment 108038 [details]
document round trip LO433 pptx--odp--pptx on Windows w - LO 4331

So, more than just color flip on round trip--which on windows actually retains some of the black, but corrupts the object shape. The block gradients and word art is not being handled well during import into LibreOffice or on export back to OOXML.
Comment 6 Luke 2015-05-29 02:49:55 UTC
Please ignore the rendering issue, as that has been fixed in 5.0. This bug is specifically about the regression between 4.3 and 4.4 where the black drawing( speaker and monitor) are turned white. Compare 4.3 roundtrip: attachment 108038 [details] with 4.4: attachment 106698 [details]
Comment 7 Luke 2015-05-29 04:27:38 UTC Comment hidden (obsolete)
Comment 8 Andras Timar 2015-06-11 11:00:32 UTC
I identified Jacobo's commits as the cause of this regression.

d185dae ooxml: unit test for shape theme attributes preservation
bc0a907 ooxml: Preserve shape theme attribute for solid fill
15e01d9 ooxml: Preserve shape style attribute fillRef
Comment 9 Jacobo Aragunde Pérez 2015-06-11 11:47:53 UTC
I have yet to check it, but the root cause could be the same as in #91332: theme xml files not being roundtripped.
Comment 10 Robinson Tryon (qubit) 2015-12-07 16:37:18 UTC Comment hidden (obsolete)
Comment 11 Robinson Tryon (qubit) 2015-12-13 11:11:00 UTC Comment hidden (obsolete)
Comment 12 Kevin Suo 2017-11-07 03:41:09 UTC
Still reproducible
Version: 6.0.0.0.alpha1+
Build ID: 2416d69ad4fa26b65d5b05a8575ac96af6b2c9a9
CPU threads: 2; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: zh-CN (zh_CN.UTF-8); Calc: group
Comment 13 Luke 2018-02-09 20:54:38 UTC
Szymon Kłos,

Your fix for Bug 103478 didn't address this case. Any idea what's going on?
Comment 14 Luke 2018-02-09 20:57:57 UTC
Created attachment 139746 [details]
Another Simple example of theme color lost

In this example, the theme color used on the SmartArt on 2nd page is lost on export. If the first page is removed, the SmartArt's color is remembered on roundtrip.
Comment 15 Luke 2018-02-09 21:01:41 UTC
After https://cgit.freedesktop.org/libreoffice/core/commit/?id=c344d74a6961ec39685d718fbb7c29dd186ca0a4

The orange circle in attachment 116117 [details] is no longer turning blue. However the other theme colors are still lost.
Comment 16 Luke 2018-03-02 17:07:47 UTC Comment hidden (obsolete)
Comment 17 Commit Notification 2018-03-17 07:18:56 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e673a47767cbd272d206ac50f2ac879d5ba71176

tdf#84205 If theme not found, use first

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Luke 2018-03-25 19:23:27 UTC
Szymon Kłos,

We're getting there. The shape theme colors in attachment 139746 [details] are now preserved on roundtrip. Thanks!


However, the original test doc and the stripped-down version, attachment 106747 [details] , are both still losing their color info after being roundtripped.
Comment 19 Commit Notification 2018-04-05 14:12:19 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b8bb9a94266035b0d4579a7dbb3252a85fc896bc&h=libreoffice-6-0

tdf#84205 If theme not found, use first

It will be available in 6.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2018-04-19 12:15:54 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ee47da7ae49be26dcb69ba1b720be93720b79959&h=libreoffice-5-4

tdf#84205 If theme not found, use first

It will be available in 5.4.8.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2018-04-30 10:37:38 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-5-4-7":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=40306c728ac4ba305106193637c547a699b67fdf&h=libreoffice-5-4-7

tdf#84205 If theme not found, use first

It will be available in 5.4.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Xisco Faulí 2018-05-31 08:45:36 UTC
A polite ping to Szymon Kłos:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks