Bug Hunting Session
Bug 125453 - Bad layout in "Save As" dialog
Summary: Bad layout in "Save As" dialog
Status: RESOLVED DUPLICATE of bug 74443
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-23 07:45 UTC by Antoine Lorence
Modified: 2019-05-25 05:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Same with GTK3 (22.22 KB, image/png)
2019-05-23 08:10 UTC, Xisco Faulí
Details
Zoom on labels layout, subect of this report (13.65 KB, image/png)
2019-05-23 08:24 UTC, Antoine Lorence
Details
Dialg in Glade (54.57 KB, image/png)
2019-05-23 08:46 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Antoine Lorence 2019-05-23 07:45:13 UTC
Description:
In any component (Writer, Calc, Draw, Impress, etc.) when the document is saved for the first time using "Save As" action, the dialog layout has margin issues. Checkboxes are here to allow user to "Save with automatic file extension", "save with a password", "Encrypt with a GPG key" and "Edit filter parameters", but for each checkbox, the description text is displayed on 2 or 3 lines when it could probably be displayed on a single line.

Please see a screenshot :
https://i.imgur.com/yq7eTqI.png

Steps to Reproduce:
1. Create a new document
2. Use menu File > Save As

Actual Results:
In the bottom of the dialog, checkboxes labels are displayed on 2 or 3 lines

Expected Results:
Checkboxes labels are displayed each on a single line


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
The french language is enabled, I don't know if this issue appear with other languages.

Screenshot of the dialog:
https://i.imgur.com/yq7eTqI.png

Version: 6.2.3.2 (x64)
Build ID: aecc05fe267cc68dde00352a451aa867b3b546ac
Threads CPU : 8; OS : Windows 10.0; UI Render : par défaut; VCL: win; 
Locale : fr-FR (fr_FR); Langue IHM : fr-FR
Calc: threaded
Comment 1 Xisco Faulí 2019-05-23 08:10:53 UTC Comment hidden (off-topic)
Comment 2 Xisco Faulí 2019-05-23 08:11:58 UTC
Could you please explain why it's a bad layout ? it's consistent among all Operative Systems...
Comment 3 Antoine Lorence 2019-05-23 08:24:39 UTC
Created attachment 151618 [details]
Zoom on labels layout, subect of this report

In the screenshot you attached, the layout is correct:

[ ] Encrypt with GPG key
[ ] Edit filter settings
[ ] Save with password

On MS Windows (see my screenshot), the labels are displayed on multiple lines

[ ] Extension
    automatique du nom
    de fichier
[ ] Enregistrer avec mot
    de passe
[ ] Chiffrer avec une clé
    GPG
[ ] Editer les paramètres
    du filtre

I have the feeling the layout could be improved (displaying each layout on a single line) :

[ ] Extension automatique du nom de fichier
[ ] Enregistrer avec mot de passe
[ ] Chiffrer avec une clé GPG
[ ] Editer les paramètres du filtre
Comment 4 Xisco Faulí 2019-05-23 08:27:06 UTC
oh I see. Adding UX Team then...
Comment 5 Heiko Tietze 2019-05-23 08:46:02 UTC Comment hidden (obsolete)
Comment 6 Adolfo Jayme 2019-05-25 05:17:54 UTC
This bug is about the native Windows file picker, not the LO-internal picker. And this picker is not done with Glade; it’s the Windows-provided dialog, to which we add checkboxes. It is implemented in fpicker/source/win32/filepicker/VistaFilePicker*

This problem was reported already; marking as a dupe…

*** This bug has been marked as a duplicate of bug 74443 ***