Bug 74443 - Windows File Picker: Automatic File Name Extension needlessly on two lines
Summary: Windows File Picker: Automatic File Name Extension needlessly on two lines
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Windows (All)
: lowest trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
: 125453 (view as bug list)
Depends on:
Blocks: File-Dialog
  Show dependency treegraph
 
Reported: 2014-02-03 15:16 UTC by Stefan Knorr (astron)
Modified: 2021-06-21 09:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Save dialog (29.88 KB, image/png)
2014-02-03 15:16 UTC, Stefan Knorr (astron)
Details
Save dialog italian locale LO 3.3.3 (84.59 KB, image/png)
2014-02-16 07:46 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Knorr (astron) 2014-02-03 15:16:36 UTC
Created attachment 93289 [details]
Save dialog

1. Make sure you are using the native Windows file picker:
   Tools > Options > LibreOffice/General > Open/Save Dialogs, 
   Make sure the option User Libreoffice Dialogs is not selected.

2. Go to File > Save As

3. See bottom portion of the appearing Save As dialog: there are three options, the first one (and in some locales, the second one, too) is a multiline option, even though there is a lot of available horizontal space.
Comment 1 tommy27 2014-02-16 07:05:36 UTC
confirmed under Win7x64

using Version: 4.3.0.0.alpha0+
Build ID: ecf22894f522374cbdb8196d3bdef88e2fba7af9
TinderBox: Win-x86@39, Branch:master, Time: 2014-02-15_01:01:17
Comment 2 tommy27 2014-02-16 07:46:18 UTC
Created attachment 94151 [details]
Save dialog italian locale LO 3.3.3

not a new issue, same problem even with older LibO releases (see screenshot from 3.3.3 italina locale) and OOo 3.3.0 and AOO 4.0.0
Comment 3 Joel Madero 2015-05-02 15:41:49 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-06-20 14:00:00 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)
Comment 5 QA Administrators 2016-09-20 10:11:02 UTC Comment hidden (obsolete)
Comment 6 Roman Kuznetsov 2018-12-12 18:27:23 UTC
still repro in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 7 Heiko Tietze 2018-12-12 18:43:28 UTC

*** This bug has been marked as a duplicate of bug 119747 ***
Comment 8 Roman Kuznetsov 2018-12-12 18:48:32 UTC
Heiko, you are wrong. It's different problem only for text labels in checkboxes

Status-> back to NEW
Comment 9 Adolfo Jayme 2019-05-25 05:17:54 UTC
*** Bug 125453 has been marked as a duplicate of this bug. ***
Comment 10 QA Administrators 2021-06-01 04:30:21 UTC Comment hidden (obsolete)
Comment 11 Buovjaga 2021-06-01 10:54:10 UTC
Still valid

Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 187136265d26c014e842550c2f1fc5997736e4fa
CPU threads: 2; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded Jumbo
Comment 12 Andreas Heinisch 2021-06-20 17:11:45 UTC
Unfortunately, the IFileDialogCustomize does not provide any option in order to change the layout of the checkboxes with their labels. So we rely on the file dialog of MS here, which we cannot change.
Comment 13 Buovjaga 2021-06-21 09:07:18 UTC
(In reply to Andreas Heinisch from comment #12)
> Unfortunately, the IFileDialogCustomize does not provide any option in order
> to change the layout of the checkboxes with their labels. So we rely on the
> file dialog of MS here, which we cannot change.

I checked in the dev chat as well and will close as notourbug