Bug 125463 - Error import vector sign from MS Office
Summary: Error import vector sign from MS Office
Status: RESOLVED DUPLICATE of bug 132305
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Formula
  Show dependency treegraph
 
Reported: 2019-05-23 15:16 UTC by Army_bloodcore
Modified: 2020-05-04 18:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test (10.65 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-06-01 15:35 UTC, Army_bloodcore
Details
Test compared MSO LO (35.43 KB, image/png)
2020-02-18 14:30 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Army_bloodcore 2019-05-23 15:16:26 UTC
Description:
Overlining symbol doesn't import correctly from MS Office.

Steps to Reproduce:
1. Create equation in MS Office
2. Place it vector sign overlining (line that marks symbol as vector). 
3. Save it in *.docx format.
4. Open again in LibreOffice.

Actual Results:
Overlining was displayed like this: "à"

Expected Results:
I wanted to get a vector symbol!


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: ru
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
Comment 1 raal 2019-05-23 18:56:32 UTC Comment hidden (obsolete)
Comment 2 Army_bloodcore 2019-06-01 15:35:01 UTC
Created attachment 151833 [details]
Test

Hello! Here is attachment as you requested earlier. I hope this bug will be fixed as soon as possible
Comment 3 raal 2019-06-02 05:49:42 UTC
I can confirm with Version: 6.3.0.0.alpha1+
Build ID: 53325b40b557cc84d8d21c1baa0ef8d3bfc00ab8
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
and Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 4 Army_bloodcore 2019-08-28 09:24:35 UTC Comment hidden (obsolete)
Comment 5 Army_bloodcore 2020-02-18 09:31:29 UTC Comment hidden (obsolete)
Comment 6 Timur 2020-02-18 14:30:46 UTC
Created attachment 157979 [details]
Test compared MSO LO

Repro LO 7.0+, as in screenshot.
Repro also 3.5 so looks like ImplementationError, not a regression.
Reporter, do not change bug status, just wait until a volunteer fixes it.
Comment 7 Julien Nabet 2020-05-04 18:36:54 UTC
Fixed with https://cgit.freedesktop.org/libreoffice/core/commit/?id=be23b4a91504b81a19510f8562e92203b4317edf

from next LO release 6.4.4

*** This bug has been marked as a duplicate of bug 132305 ***