Download it now!
Bug 132305 - FILEOPEN: DOCX: Incorrect MS_COMBOVERLINE symbol
Summary: FILEOPEN: DOCX: Incorrect MS_COMBOVERLINE symbol
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:7.0.0 target:6.4.4
Keywords:
: 125463 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-04-21 18:18 UTC by Rhys Young
Modified: 2020-05-04 18:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The word document - correct symbols (11.71 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-04-21 18:19 UTC, Rhys Young
Details
The pdf - incorrect symbols (21.81 KB, application/pdf)
2020-04-21 18:20 UTC, Rhys Young
Details
The correct symbols screenshot (3.12 KB, image/png)
2020-04-22 12:33 UTC, Rhys Young
Details
The incorrect symbols screenshot (6.36 KB, image/png)
2020-04-22 12:34 UTC, Rhys Young
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rhys Young 2020-04-21 18:18:53 UTC
Description:
When converting a word document to a PDF the PDF symbols do not match those of the word doc.

Steps to Reproduce:
1. Convert file to PDF using 'soffice --headless --nolockcheck --nodefault --nofirststartwizard --nologo --norestore --convert-to pdf --outdir /tmp /tmp/test.docx'
2. Open PDF using a viewer
3. Observe the symbols do not match

Actual Results:
The math symbols are incorrect.

Expected Results:
The math symbols are correct.


Reproducible: Always


User Profile Reset: No



Additional Info:
None
Comment 1 Rhys Young 2020-04-21 18:19:58 UTC
Created attachment 159799 [details]
The word document - correct symbols
Comment 2 Rhys Young 2020-04-21 18:20:35 UTC
Created attachment 159800 [details]
The pdf - incorrect symbols
Comment 3 Julien Nabet 2020-04-22 08:28:09 UTC
When opening the docx file and pdf files, I don't see the difference.
Could you attach a screenshot of what you expect?
Comment 4 Rhys Young 2020-04-22 12:33:52 UTC
Created attachment 159812 [details]
The correct symbols screenshot
Comment 5 Rhys Young 2020-04-22 12:34:55 UTC
Created attachment 159813 [details]
The incorrect symbols screenshot
Comment 6 Rhys Young 2020-04-22 12:35:39 UTC
Updated with screenshots
Comment 7 Julien Nabet 2020-04-22 12:52:43 UTC
Thank you for your feedback.
Last question but it's more to confirm, if you open docx, do you see right symbols?
Indeed, I don't see them and noticed these logs on console:
warn:xmloff:41059:41059:sax/source/fastparser/fastparser.cxx:1267: unknown element xsi:type http://www.w3.org/2001/XMLSchema-instance
warn:xmloff:41059:41059:sax/source/fastparser/fastparser.cxx:1267: unknown element xsi:type http://www.w3.org/2001/XMLSchema-instance
warn:xmloff:41059:41059:sax/source/fastparser/fastparser.cxx:1267: unknown element w15:val http://schemas.microsoft.com/office/word/2012/wordml
warn:xmloff:41059:41059:sax/source/fastparser/fastparser.cxx:1195: unknown attribute vid={4A3C46E8-61CC-4603-A589-7422A47A8E4A}
warn:starmath.ooxml:41059:41059:starmath/source/ooxmlimport.cxx:226: Unknown m:chr in m:acc '̅'
warn:starmath:41059:41059:starmath/source/document.cxx:240: !! SmDocShell::ArrangeFormula: reference device missing !!
warn:starmath:41059:41059:starmath/source/document.cxx:240: !! SmDocShell::ArrangeFormula: reference device missing !!
warn:starmath:41059:41059:starmath/source/document.cxx:240: !! SmDocShell::ArrangeFormula: reference device missing !!
warn:starmath:41059:41059:starmath/source/document.cxx:240: !! SmDocShell::ArrangeFormula: reference device missing !!
warn:starmath:41059:41059:starmath/source/document.cxx:240: !! SmDocShell::ArrangeFormula: reference device missing !!
warn:starmath.ooxml:41059:41059:starmath/source/ooxmlimport.cxx:226: Unknown m:chr in m:acc '̅'
warn:starmath:41059:41059:starmath/source/document.cxx:240: !! SmDocShell::ArrangeFormula: reference device missing !!
warn:starmath:41059:41059:starmath/source/document.cxx:240: !! SmDocShell::ArrangeFormula: reference device missing !!
warn:starmath:41059:41059:starmath/source/document.cxx:240: !! SmDocShell::ArrangeFormula: reference device missing !!
warn:starmath:41059:41059:starmath/source/document.cxx:240: !! SmDocShell::ArrangeFormula: reference device missing !!
warn:starmath:41059:41059:starmath/source/document.cxx:240: !! SmDocShell::ArrangeFormula: reference device missing !!
warn:starmath.ooxml:41059:41059:starmath/source/ooxmlimport.cxx:226: Unknown m:chr in m:acc '̅'
warn:starmath:41059:41059:starmath/source/document.cxx:240: !! SmDocShell::ArrangeFormula: reference device missing !!
warn:starmath:41059:41059:starmath/source/document.cxx:240: !! SmDocShell::ArrangeFormula: reference device missing !!
warn:starmath:41059:41059:starmath/source/document.cxx:240: !! SmDocShell::ArrangeFormula: reference device missing !!
warn:starmath:41059:41059:starmath/source/document.cxx:240: !! SmDocShell::ArrangeFormula: reference device missing !!
warn:starmath:41059:41059:starmath/source/document.cxx:240: !! SmDocShell::ArrangeFormula: reference device missing !!
warn:legacy.osl:41059:41059:oox/source/helper/storagebase.cxx:66: StorageBase::StorageBase - missing base input stream
Comment 8 Rhys Young 2020-04-22 13:37:43 UTC
Works if opened in word, does not work if opened in libre!
Comment 9 Julien Nabet 2020-04-22 13:48:22 UTC
I gave a try with:
https://gerrit.libreoffice.org/c/core/+/92698
Comment 10 Commit Notification 2020-04-24 08:02:17 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/be23b4a91504b81a19510f8562e92203b4317edf

tdf#132305: Teach Starmath MS_COMBOVERLINE = 0x0305

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Julien Nabet 2020-04-24 08:12:38 UTC
Patch waiting for review for 6.4 branch:
https://gerrit.libreoffice.org/c/core/+/92770
Comment 12 Xisco Faulí 2020-04-28 10:05:45 UTC
Verified in

Version: 7.0.0.0.alpha0+
Build ID: 4ba1909f12b49f020195b5e767045340717ce6df
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

@Julien, thanks for fixing this issue!!

This is actually a FILEOPEN issue, and it can also be reproduced in LibreOffice 4.4
Comment 13 Commit Notification 2020-04-28 10:08:04 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/47c2a85b41d669281b0e9f0063f024360485f0d5

tdf#132305: Teach Starmath MS_COMBOVERLINE = 0x0305

It will be available in 6.4.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2020-04-28 17:04:34 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/781a1a82231ee4b95733dfb76249224948d6d894

tdf#132305: sw: Add unittest

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Julien Nabet 2020-05-04 18:36:54 UTC
*** Bug 125463 has been marked as a duplicate of this bug. ***