Download it now!
Bug 125524 - Editing Formula causes fatal Application Crash
Summary: Editing Formula causes fatal Application Crash
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-05-27 13:27 UTC by aSystemOverload
Modified: 2019-05-27 22:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description aSystemOverload 2019-05-27 13:27:46 UTC
Description:
Whilst editing Cell D25, mis-typing the following formula [=SUMIFS($'weekly data'.i5$'weekly data'.i$'weekly data'.m5$'Weekly Data'.M5:M5000,$'Weekly Data'.E7:E5000,A25,$'Weekly Data'.F7:F44,B25,$'Weekly Data'.G7:G43,C25)], hitting [ENTER], it produced an (expected) error.
I then removed the initial [$'weekly data'.i5$'weekly data'.i$'weekly data'.m5], hit [ENTER] (also tried the formula TICK) and Libre Calc crashed (disappears, no error messages).

Steps to Reproduce:
1. Enter bad formula [=SUMIFS($'weekly data'.i5$'weekly data'.i$'weekly data'.m5$'Weekly Data'.M5:M5000,$'Weekly Data'.E7:E5000,A25,$'Weekly Data'.F7:F44,B25,$'Weekly Data'.G7:G43,C25)]
2. Hit [ENTER]
3. Attempt to remove first part of formula [$'weekly data'.i5$'weekly data'.i$'weekly data'.m5].
4. <CRASH>

Actual Results:
LibreCalc produces no error messages, disappears from the screen, requiring user to re-launch LibreCalc.
Repeating this exact formula in a different cell, results in the same issue.

Expected Results:
Adjusted formula, without crashing.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.2.4.2.0+
Build ID: 6.2.4-1
CPU threads: 4; OS: Linux 5.1; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded

OpenGL renderer string: Mesa DRI Intel(R) Haswell Desktop 
OpenGL core profile version string: 4.5 (Core Profile) Mesa 19.0.5
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 19.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 19.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:
Comment 1 Julien Nabet 2019-05-27 15:18:09 UTC
On Win10 with master sources updated today, I don't reproduce this.

Do you reproduce this on a brand new file or an specific file only?
Comment 2 Xisco Faulí 2019-05-27 18:37:20 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 3 Roman Kuznetsov 2019-05-27 20:03:19 UTC
What linux distro do you use? 
Can you try install LibreOffice from libreoffice.org and retest your problem?
Can you disable OpenGL in LibreOffice (Tools->Options->LibreOffice->View) and retest it?
Comment 4 aSystemOverload 2019-05-27 22:27:28 UTC
I've done a brief test on a new file and cannot reproduce, will mark as RESOLVED until/unless it rears its head again.