Bug 125591 - FILEOPEN: DOC: performance regression opening a file with EMF images
Summary: FILEOPEN: DOC: performance regression opening a file with EMF images
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.4.0 target:6.3.0.1 target:6.2.5
Keywords: bibisected, bisected, filter:doc, perf, regression
Depends on:
Blocks:
 
Reported: 2019-05-30 11:37 UTC by Xisco Faulí
Modified: 2019-06-13 21:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2019-05-30 11:37:36 UTC
Steps to reproduce:
1. Open attachment 113370 [details] from bug 89331

In

Version: 6.3.0.0.alpha1+
Build ID: aa687b22991e6c674b1d8653d52fbe9a50080174
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

it takes

real	0m30,909s
user	0m10,208s
sys	0m0,443s

while in

Version: 6.2.5.0.0+
Build ID: 0d657498080aad86f4b97309fff9bf589c57dc2e
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

it takes

real	0m3,048s
user	0m2,757s
sys	0m0,187s
Comment 1 Xisco Faulí 2019-05-30 11:39:08 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=69b62cfcbd364d7f62142149c2f690104b217ca1

author	Miklos Vajna <vmiklos@collabora.com>	2019-05-27 21:24:42 +0200
committer	Miklos Vajna <vmiklos@collabora.com>	2019-05-28 09:10:15 +0200
commit	69b62cfcbd364d7f62142149c2f690104b217ca1 (patch)
tree	2584b8fc78810624981ad10e2c834793258bb23f
parent	d0d9acc7c6095e0bc640e073b9d8e2e19aaa8993 (diff)
tdf#125281 DOC import: fix size of lazy-loaded metafiles

Bisected with: bibisect-linux64-6.3

Adding Cc: to Miklos Vajna
Comment 2 Miklos Vajna 2019-06-04 08:43:15 UTC
I can't reproduce the extreme difference, but I do see that setting the preferred size triggers loading of the EMF. I'll look at avoiding that.

(Normally images of a multi-page document only load when you scroll there.)
Comment 3 Commit Notification 2019-06-11 09:32:32 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/acb803b730f2c6bd82e39beab58949ec14f85eb0%5E%21

tdf#125591 DOC import: lazy-load metafiles with explicit size

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Xisco Faulí 2019-06-12 10:06:33 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 31944b14c3e998a37a0bb3dff300f4460c322183
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

it takes

real	0m9,005s
user	0m8,251s
sys	0m0,568s

while in

Version: 6.2.5.0.0+
Build ID: 0d657498080aad86f4b97309fff9bf589c57dc2e
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

it takes

real	0m10,461s
user	0m8,482s
sys	0m0,598s

( same version as in comment 0... it seems today my computer is slower in general, or I did a wrong mesurement the other day... )

@Miklos, thanks for fixing this issue!!
Comment 5 Commit Notification 2019-06-12 10:19:27 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/78a21c7d94f8ff391f9c470bf10f4ae3c1d90307%5E%21

tdf#125591 DOC import: lazy-load metafiles with explicit size

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2019-06-13 21:36:35 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/a21e297b1229dd389c691893ddc48605e9471db0%5E%21

tdf#125591 DOC import: lazy-load metafiles with explicit size

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.