Bug 89331 - Slow perf scrolling prix-immobilier-friggit.doc with EMF graphs
Summary: Slow perf scrolling prix-immobilier-friggit.doc with EMF graphs
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc, perf
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2015-02-12 09:42 UTC by Antoine Pitrou
Modified: 2019-07-30 10:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
file (422.00 KB, application/msword)
2015-02-13 15:26 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Antoine Pitrou 2015-02-12 09:42:45 UTC
The following document is a compilation of real estate statistics by a French researcher. It should display many graphs. Those graphs display incorrectly with LibreOffice:
http://www.cgedd.fr/prix-immobilier-friggit.doc

This is with the Ubuntu 14.10 build of LibreOffice 4.3.3.2 ("Build ID: 430m0(Build:2)"). I'm sorry if this is already fixed in mainline.
Comment 1 raal 2015-02-13 15:25:16 UTC
I can confirm with Version: 4.5.0.0.alpha0+
Build ID: 62969accf9c01b71b738424d4d643db8bfaed182
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-02-08_23:22:32
Comment 2 raal 2015-02-13 15:26:38 UTC
Created attachment 113370 [details]
file
Comment 3 QA Administrators 2016-02-21 08:35:12 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2019-05-14 03:00:07 UTC Comment hidden (obsolete)
Comment 5 Antoine Pitrou 2019-05-14 08:23:43 UTC
This has gotten worse with:

Version: 6.0.7.3
Build ID: 1:6.0.7-0ubuntu0.18.04.5
Threads CPU : 16; OS : Linux 4.15; UI Render : par défaut; VCL: gtk3; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group

Now the document makes LibreOffice entirely unusable.  It takes a lot of time to import (more than one minute perhaps?) and then the UI becomes extremely sluggish or unresponsive.
Comment 6 Timur 2019-05-14 11:10:05 UTC
This DOC had multiple bugs: 
1. Opening in Writer splits the page into two, so 8 pages in document instead of 7 on open, reproducible from 4.3.1.1 both in Windows and Linux - but Bug 86468 was closed as WontFix. 
2. accidental crash on scrolling down (with mouse on vertical scroll) to the end and up - tested in Windows 7 x64 with LO 4.3.2 - no repro anymore
3. crash on PDF export, original report in bug 80508, confirmed in Linux Mint -  no repro anymore
4. PDF export incomplete, there are items missing in WMF or EMF (legend, caption) - not tested again
5. WMF images in DOC file not rendered correctly in Linux - Bug 80503 closed as a duplicate of fixed bug (not verified)
6. EMF images on original page 6 not rendered correctly both Win, Lin - new bug

This bug was not correctly/exactly reported ("Those graphs display incorrectly" is not specific thus incorrect) but it was likely a duplicate of some. 

Previous comment points to different issue "UI becomes extremely sluggish or unresponsive". I confirm it's sluggish, but not extremely, master both in Win and Lin. So I'll update the title.

Note: current link and 2015. attached file are different. I tested with link.
Comment 7 Xisco Faulí 2019-05-29 20:32:24 UTC
So the hang seems to be a recent regression.

in

Version: 5.4.0.0.alpha1+
Build ID: 9feb7f7039a3b59974cbf266922177e961a52dd1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

it takes

real	0m5,432s
user	0m2,902s
sys	0m0,380s

to open with OOO_EXIT_POST_STARTUP=1

and in

Version: 6.3.0.0.alpha1+
Build ID: aa687b22991e6c674b1d8653d52fbe9a50080174
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

it takes

real	0m29,191s
user	0m9,430s
sys	0m0,357s
Comment 8 Xisco Faulí 2019-05-30 11:32:30 UTC
So, there are two different performance problems, once recently introduced and another one while scrolling, let's use this one to track the slow performance while scrolling