Download it now!
Bug 125598 - FILESAVE calc scrollbars don't save correctly in ms formats
Summary: FILESAVE calc scrollbars don't save correctly in ms formats
Status: RESOLVED DUPLICATE of bug 104309
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.0.7.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: Form-Controls
  Show dependency treegraph
 
Reported: 2019-05-30 20:36 UTC by ffs
Modified: 2020-06-15 11:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
slider in ODS format - works (8.01 KB, application/vnd.oasis.opendocument.spreadsheet)
2019-05-31 06:43 UTC, ffs
Details
slider in XLS format - range incorrect (5.50 KB, application/vnd.ms-excel)
2019-05-31 06:44 UTC, ffs
Details
slider in XLSX format, slider missing (4.87 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-05-31 06:45 UTC, ffs
Details
screen shot .ods format (79.36 KB, image/png)
2019-05-31 06:48 UTC, ffs
Details
screenshot .xls format (78.61 KB, image/png)
2019-05-31 06:49 UTC, ffs
Details
screenshot .xlsx format (77.92 KB, image/png)
2019-05-31 06:50 UTC, ffs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ffs 2019-05-30 20:36:24 UTC
Description:
Obviously a pita but I need to create a form in calc that is shared with excel users and it needs to have a scroll bar.

If I save a scrollbar in LO and reload it:

- .xls format: the scrollbar is there but the min and max values are 0,0 so it doesn't scroll.  If I put them back to 0,100 and save/reload it is back to 0,0.

- .xlsx format: the scrollbar is simply missing.



Steps to Reproduce:
Create a spreadsheet with a scroll bar save as .xls or .xlsx, reload and the scrollbar is broken or absent

Actual Results:
.xls :scrollbar is present but has incorrect range
.xlsx: scrollbar is absernt


Expected Results:
scrollbar should be there and working


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-GB
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 ffs 2019-05-30 21:13:50 UTC
FWIW it seems to work ok in writer fr both doc and docx
Comment 2 raal 2019-05-31 03:34:51 UTC
Hello,

Thank you for filing the bug. Please send us a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO', so please do change it back to 'UNCONFIRMED' once you have attached a document.
(Please note that the attachment will be public, remove any sensitive information before attaching it.)
How can I eliminate confidential data from a sample document?
https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F
Thank you
Comment 3 ffs 2019-05-31 06:43:53 UTC
Created attachment 151795 [details]
slider in ODS format - works
Comment 4 ffs 2019-05-31 06:44:42 UTC
Created attachment 151796 [details]
slider in XLS format - range incorrect
Comment 5 ffs 2019-05-31 06:45:14 UTC
Created attachment 151797 [details]
slider in XLSX format, slider missing
Comment 6 ffs 2019-05-31 06:48:55 UTC
Created attachment 151799 [details]
screen shot .ods format
Comment 7 ffs 2019-05-31 06:49:28 UTC
Created attachment 151800 [details]
screenshot .xls format
Comment 8 ffs 2019-05-31 06:50:06 UTC
Created attachment 151801 [details]
screenshot .xlsx format
Comment 9 raal 2019-06-14 04:03:52 UTC
Confirm with Version: 6.3.0.0.beta1+
Build ID: 4904391e125eb66304a5c029def8d4c1a150952d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
in 4.1 is slider completely missing in LO. In 6.3 the slider is visible in LO, but in excel2010 error message "Excel completed file level validation and repair. Some parts of this workbook may have been repaired or discarded" and slider is removed upon open.
Steps:
open file
save as xlsx
Comment 10 ffs 2019-06-16 11:19:19 UTC
I can confirm that if a slider is placed in excel and saved then LO can load it correctly. So it appears to be a LO filesave issue.
Comment 11 NISZ LibreOffice Team 2020-06-15 11:52:44 UTC

*** This bug has been marked as a duplicate of bug 104309 ***