Bug Hunting Session
Bug 125625 - Cannot update appimage LibreOffice
Summary: Cannot update appimage LibreOffice
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL: https://github.com/antoniofaccioli/li...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-01 16:42 UTC by asfesq
Modified: 2019-06-04 20:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description asfesq 2019-06-01 16:42:10 UTC
Description:
I have "installed" LibreOffice 6.2.2 on my linux based system using the AppImage app. I have purposefully not fully integrated LibreOffice into my installed system.

When I attempt to update LibreOffice using AppImageUpdate, a message appears informing that the developer has not provided the ability to perform a "delta" update (e.g., just install the updated files). It also requests that I contact the developer to ask them to provide such ability.

    Does the appimage version of LibreOffice have that ability?
    If not, can you modify the app to permit the update?
    If the answer to the above is no, how can I retain any modifications I made to the installed version upon downloading the updated version (default styles, etc.)

Thank you.


Actual Results:
Does not download available update. Says that update ability is not included with app.

Expected Results:
Should enable a delta update


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Xisco Faulí 2019-06-04 13:47:55 UTC
Hello,
We don't provide delta updates for releases, just for daily builds. See bug 68274.
Closing as a duplicated

*** This bug has been marked as a duplicate of bug 68274 ***
Comment 2 V Stuart Foote 2019-06-04 14:50:03 UTC
libreoffice-AppImage is not maintained by TDF, it just uses TDF builds. 

Project is here:

https://github.com/antoniofaccioli/libreoffice-appimage

There is already an open bug for issue with appimageupdate, here: https://github.com/antoniofaccioli/libreoffice-appimage/issues/9
Comment 3 asfesq 2019-06-04 20:36:52 UTC
Thank you.