Bug 125679 - FILEOPEN DOCX LibreOffice Writer freezes when opening a particular DOCX file with tables
Summary: FILEOPEN DOCX LibreOffice Writer freezes when opening a particular DOCX file ...
Status: RESOLVED DUPLICATE of bug 120315
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, implementationError
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2019-06-04 11:15 UTC by NISZ LibreOffice Team
Modified: 2019-11-04 10:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The document that freezes LibreOffice Writer. (34.85 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-06-04 11:15 UTC, NISZ LibreOffice Team
Details
A screenshot showcasing the issue. (42.59 KB, image/png)
2019-06-04 11:16 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2019-06-04 11:15:34 UTC
Created attachment 151901 [details]
The document that freezes LibreOffice Writer.

LibreOffice Writer freezes when opening the attached DOCX file with LibreOffice Writer. Even a slight modification in Microsoft Word (like deleting some text from a cell or adding an empty paragraph before the first table) can “fix” the document, so this seems to be a corner-case rendering issue.

Steps to reproduce:
    1. Download the attached file.
    2. Open the file with LibreOffice Writer.

Actual results:
LibreOffice Writer freezes when opening this particular document.

Expected results:
LibreOffice Writer shouldn't freeze.

LibreOffice details:
Version: 6.4.0.0.alpha0+ (x64)
Build ID: 02bee5f5d846f40f244c5acab044177576a6d869
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-06-02_21:57:08
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded

Bibisected in bibisect-win32-6.3
https://cgit.freedesktop.org/libreoffice/core/commit/?id=e502463fa9a601963aa9f5a8783eb1318de36c13
author
Miklos Vajna <vmiklos@collabora.com>
2019-03-11 21:40:44 +0100
committer
Miklos Vajna <vmiklos@collabora.com>
2019-03-12 08:43:22 +0100
tdf#123104 DOCX import: fix lack of vertical merge due to rounding 

Technically this commit doesn't cause the freezing itself, just changes the height of the tables, which accidentally causes LibreOffice to freeze. Adding Cc: to Miklos Vajna, please take a look sometimes.
Comment 1 NISZ LibreOffice Team 2019-06-04 11:16:25 UTC
Created attachment 151902 [details]
A screenshot showcasing the issue.
Comment 2 Xisco Faulí 2019-06-04 11:46:49 UTC
Reproduced in

Version: 6.3.0.0.beta1+
Build ID: 4abdaf4afb2245d404f6709124b3c627b07b8a3c
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Adding Cc: to Miklos Vajna

Setting priority to high since the patch was backported to libreoffice-6-2 branch
Comment 3 Miklos Vajna 2019-06-04 12:01:41 UTC
We have a trade-off here: depending on if you round or not round the table column sizes, either you get bug 123104 or the bug described in commit 29cbbad64088354425c606f9eb6c267bdf7731dc. Given the original commit was only a "nice to have" change and the regression was reported by users, I just reverted my change, since I expected sorting this out would require considerable resources (I'm not short on problems right now).

I think it's reasonable to say that if we had a baseline, then a commit introduced a regression, and now the revert (fixing the regression) causes further problems, then yes, this is a bug, but it's not a regression, since it never really worked without serious side-effects.

Updating keywords accordingly.
Comment 4 Xisco Faulí 2019-06-13 13:55:42 UTC
I guess we can set the importance to normal since this is not a real regression... we can increase it later if we see many documents affected...
Comment 5 Xisco Faulí 2019-11-04 10:15:02 UTC
Issue fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=44e44239de35c1548809c96e13bfa9d64c7ca441
Closing as duplicate of bug

*** This bug has been marked as a duplicate of bug 120315 ***