Bug Hunting Session
Bug 125685 - crash in layout after paste on particular document
Summary: crash in layout after paste on particular document
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:6.4.0 target:6.3.0.1 target:6.2.5
Keywords: bisected, regression
Depends on:
Blocks: tdf#114306-regressions
  Show dependency treegraph
 
Reported: 2019-06-04 14:56 UTC by Michael Stahl (CIB)
Modified: 2019-06-10 12:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Stahl (CIB) 2019-06-04 14:56:36 UTC
Description:
this was found when testing bug 125475 and it's a different cause:



Steps to Reproduce:
1. Open attachment 147138 [details]
2. CTRL+A + CTRL+C
3. CTRL+N
4. CTRL+V
5. CTRL+V



Actual Results:
the table at the end is broken, because it fails to split properly runs into this problem

warn:legacy.osl:22975:22975:sw/source/core/layout/tabfrm.cxx:2639: debug assertion: <SwTabFrame::MakeAll()> - format of table lowers suppressed by fix i44910

... wait a little, it crashes.



Expected Results:
not crashing


Reproducible: Always


User Profile Reset: No



Additional Info:
regression from commit 18765b9fa739337d2d891513f6e2fb7c3ce23b50
Comment 1 Telesto 2019-06-04 15:01:38 UTC
Same as I report in bug 122736 comment 11. So confirming
Comment 2 Michael Stahl (CIB) 2019-06-04 15:01:59 UTC
it turns out that while it started to crash with 18765b9fa739337d2d891513f6e2fb7c3ce23b50 the problem is really that the table isn't properly formatted; if that is fixed the crash no longer happens.

it's hard to avoid the crash otherwise as updating view starts formatting at the cursor position, at the end of the document, and goes backwards, which is going to run into trouble sooner or later as the assumption is that the layout was fully calculated up to the visible page.
Comment 3 Commit Notification 2019-06-05 08:49:46 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e37ffdd118da2d21c5e78e8c7b67252d0d1adc8c%5E%21

tdf#125685 sw: disregard footnotes in follow table on table split

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Michael Stahl (CIB) 2019-06-05 09:24:10 UTC
forgot to mention: i tried to bibisect the table-formatting issue on this document... it's tricky... it can actually happen just by loading the document, and then going to the end and scrolling up page by page with PgUp... i was able to repro that in every build of the 5.4-dbgutil repo and then i tried the latest of the 5.3-product repo and couldn't repro ... probably need very specific timing to get it.... so quite hard to find out how old that problem is really.

but it should be fixed on master.
Comment 5 Commit Notification 2019-06-05 11:49:11 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/b9089b1be5ad1df8949527d28b9ce5840a892d0b%5E%21

tdf#125685 sw: disregard footnotes in follow table on table split

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2019-06-05 13:29:38 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/d93d82de8725031cbe9b47046081328674cbead4%5E%21

tdf#125685 sw: disregard footnotes in follow table on table split

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2019-06-10 12:25:21 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 43ddddb703bcdb9430752af63ae46527f737f874
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Michael Stahl, thanks for fixing this issue!