Bug 125692 - kde5: Impress crashes when closing after using presentation minimizer
Summary: kde5: Impress crashes when closing after using presentation minimizer
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
6.4.0.0.alpha0+ Master
Hardware: All Linux (All)
: medium normal
Assignee: Jan-Marek Glogowski
URL:
Whiteboard: target:6.4.0 target:6.3.0.1 target:6.2.5
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-06-04 20:20 UTC by Michael Weghorn
Modified: 2019-06-17 06:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample presentation (10.77 KB, application/vnd.oasis.opendocument.presentation)
2019-06-04 20:20 UTC, Michael Weghorn
Details
gdb backtrace and some output) (8.72 KB, text/plain)
2019-06-04 20:21 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Weghorn 2019-06-04 20:20:02 UTC
Created attachment 151915 [details]
Sample presentation

Version: 6.4.0.0.alpha0+
Build ID: 222f6a1c43b7ae7bf8e2f1fbc1dbe6457e611ab7
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded

Steps to reproduce:

1) open attached presentation "some_slides.odp" in Impress
2) "Tools" -> "Minimize Presentation"
3) click "Finish"
4) select name to save the minimized presentation, don't open it
5) close Impress

Result: crash

This is specific to the kde5 VCL plugin. It's reproducible on both X11 and Wayland (though bug 121293 on X11 may prevent even getting that far).
Comment 1 Michael Weghorn 2019-06-04 20:21:18 UTC
Created attachment 151916 [details]
gdb backtrace and some output)
Comment 2 Xisco Faulí 2019-06-11 19:55:58 UTC
Patch in gerrit: https://gerrit.libreoffice.org/#/c/73567/
Comment 3 Commit Notification 2019-06-12 21:24:45 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/2dc6bdd1d5789ace0500cad90f5d2eb930888bb9%5E%21

tdf#125692 SalObject always holds a SystemChildWindow

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2019-06-13 05:01:22 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/a7ab534afee3d92d92c51759dcb733da6545d7a2%5E%21

tdf#125692 SalObject always holds a SystemChildWindow

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2019-06-13 17:48:13 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/c9e626df57a3dd66613ec6b41a7d1ffb8da1843e%5E%21

tdf#125692 SalObject always holds a SystemChildWindow

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Vera Blagoveschenskaya 2019-06-17 06:49:48 UTC
Can't reproduce for

Version: 6.4.0.0.alpha0+
Build ID: f75c2b04785aa05cff3bcd52689feb7400a14e8e
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: kde5; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-06-15_11:49:26
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded