Download it now!
Bug 125717 - Scrolling up stuck with cursor position during two-fingers scrolling
Summary: Scrolling up stuck with cursor position during two-fingers scrolling
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE Scrolling-PageUpDown
  Show dependency treegraph
 
Reported: 2019-06-05 15:53 UTC by Daniel T.
Modified: 2019-12-10 20:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel T. 2019-06-05 15:53:36 UTC
Description:
The new fresh version seems to break the possibility to scroll up using two-fingers scrolling on the touchpad. 

I am using LibreOffice on Kubuntu 18.04 LTS.

Steps to Reproduce:
1. Open a relatively long files (5 pages long at least).
2. Place a cursor in the relative middle.
3. Scroll up using two-fingers scrolling on the touchpad.

Actual Results:
1. There is no way to scroll up the position get stuck to the position of the cursor, so there is no possibility to show pages above where the cursor currently is. At the same time, scrolling down works without a problem. See attached screencast.

Expected Results:
You are able to scroll up and down. 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.4.2
Build ID: 1:6.2.4-0ubuntu0.18.04.1~lo1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: kde5; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-US
Calc: threaded
Comment 1 Daniel T. 2019-06-05 16:19:02 UTC
Screencast: http://versiforma.net/screencast20190605174233.mp4
Comment 2 Dieter 2019-06-06 17:25:15 UTC
I can't confirm with

Version: 6.3.0.0.beta1 (x64)
Build ID: a187af327633f5f00363be5131bd21a13e0f1a7b
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-US (de_DE); UI-Language: en-GB
Calc: threaded
Comment 3 Jan-Marek Glogowski 2019-06-08 17:24:26 UTC
This may be a duplicate of bug 125201, which is now fixed for master and 6.3 and pending for 6.2.

Two finger scrolling doesn't work for me at all, but border scrolling does, so I can't verify and eventually close as duplicate.
Comment 4 Dieter 2019-06-09 07:03:53 UTC
Daniel, could you please try to reproduce it with a master build from http://dev-builds.libreoffice.org/daily/master/ ? You can install it alongside the standard version. I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the master build
Comment 5 QA Administrators 2019-12-09 03:40:21 UTC Comment hidden (obsolete)
Comment 6 Daniel T. 2019-12-10 20:09:05 UTC
Can no longer reproduce in Version: 6.3.3.2 (Build ID: 1:6.3.3-0ubuntu0.19.10.1).
Comment 7 Michael Weghorn 2019-12-10 20:22:37 UTC
(In reply to Daniel T. from comment #6)
> Can no longer reproduce in Version: 6.3.3.2 (Build ID:
> 1:6.3.3-0ubuntu0.19.10.1).

Thanks for retesting.

Closing this as WORKSFORME then.