Bug 125805 - "Insert Hyperlink" dialogue box does not scale correctly on high DPI.
Summary: "Insert Hyperlink" dialogue box does not scale correctly on high DPI.
Status: NEEDINFO
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HiDPI
  Show dependency treegraph
 
Reported: 2019-06-08 19:16 UTC by typingcat
Modified: 2019-08-19 10:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen capture (27.13 KB, image/png)
2019-06-08 19:17 UTC, typingcat
Details
6.3.0.4 screen (130.48 KB, image/png)
2019-08-19 10:28 UTC, typingcat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description typingcat 2019-06-08 19:16:38 UTC
Description:
4K monitor, 200% scaling, the "Insert Hyperlink" does not scale correctly.

Steps to Reproduce:
1. Click the "Insert Hyperlink" button on the toolbar.
2.
3.

Actual Results:
Incorrect scaling for image resources.

Expected Results:
Correct scaling.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 6.2.4.2 (x64)
Build ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-GB
Calc: threaded
Comment 1 typingcat 2019-06-08 19:17:15 UTC
Created attachment 152053 [details]
Screen capture

Screen capture of the dialogue box.
Comment 2 ace_dent 2019-06-14 22:41:23 UTC
Possible duplicate of Bug 123623 - LO Calc, Insert -> Hyperlink -> Icons and text looks bad ...
Comment 3 Xisco Faulí 2019-08-19 09:51:52 UTC
A new major release of LibreOffice is available since this bug was reported.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 4 typingcat 2019-08-19 10:28:53 UTC
Created attachment 153502 [details]
6.3.0.4 screen

Eh... It now looks better (see the attached screenshot), although I do not think they look ideal (icons are too small and not well-aligned with the text labels. But, that is just a minor cosmetic problem one can live with. I think it can be closed.
Comment 5 Xisco Faulí 2019-08-19 10:30:25 UTC
@Caolán, can you reproduce this on your end ?