Bug 125821 - Crash on insertion of video
Summary: Crash on insertion of video
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Jan-Marek Glogowski
URL:
Whiteboard: target:6.4.0 target:6.3.0.1 target:6.2.5
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-06-10 09:34 UTC by Oystein Sture
Modified: 2019-06-13 18:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace (without debug symbols) (68.34 KB, text/x-log)
2019-06-10 09:34 UTC, Oystein Sture
Details
Backtrace (with dbg) (37.06 KB, text/plain)
2019-06-10 13:46 UTC, Oystein Sture
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oystein Sture 2019-06-10 09:34:49 UTC
Created attachment 152074 [details]
Backtrace (without debug symbols)

Inserting video into presentation immediately makes it crash. Opening pptx or odp containing video also makes it crash. Most other bug reports seems related to crashes when the presentation is started (not simply opened or inserted).

Happens in both 6.2.4 and 6.3.0beta1

KDE Plasma on Archlinux x86_64
Comment 1 Oystein Sture 2019-06-10 09:37:07 UTC
Crash occurs with the video file from issue 120452, however that issue seems fixed for other users, so I thought a new issue should be created (also, backtrace seems different)
Comment 2 Xisco FaulĂ­ 2019-06-10 10:03:53 UTC
Could you please paste the info from Help - about LibreOffice ?

I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' once the information has been provided
Comment 3 Oystein Sture 2019-06-10 10:07:07 UTC
The crash was observed on both of the following builds

Version: 6.2.4.2.0+
Build ID: 6.2.4-1
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: nb-NO (nb_NO.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.3.0.0.beta1
Build ID: a187af327633f5f00363be5131bd21a13e0f1a7b
CPU threads: 8; OS: Linux 4.19; UI render: default; VCL: kde5; 
Locale: nb-NO (nb_NO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 4 Oystein Sture 2019-06-10 13:46:42 UTC
Created attachment 152078 [details]
Backtrace (with dbg)
Comment 5 Jan-Marek Glogowski 2019-06-11 14:31:35 UTC
Not that I confirm the bug, but the backtrace crashes in gst_element_link with dest=dest@entry=0x0, which is supposed to be the audio output object, which is empty for you. So I don't know why GStreamer fails to auto-detect ("autoaudiosink") sound output on your system, but this is quite probably not KDE related in any sense.

Any idea why no audio is found on your system?
Did this really just start with 6.2.4, because that crashing code is from 2016?
Does SAL_USE_VCLPLUGIN=gtk3 work for you?

Please reset to UNCONFIRMED after providing the info.
Comment 6 Jan-Marek Glogowski 2019-06-12 00:23:30 UTC
Probably working patch: https://gerrit.libreoffice.org/#/c/73848/
Comment 7 Oystein Sture 2019-06-12 08:07:19 UTC
The computer only has an integrated speaker on the motherboard. It does show up in PulseAudio.

Output of "pactl list short sinks"
alsa_output.pci-0000_00_1f.3.analog-stereo      module-alsa-card.c      s16le 2ch 44100Hz       RUNNING

I'm unfortunately not able to test the proposed patch for 2 weeks due to travel
Comment 8 Jan-Marek Glogowski 2019-06-12 09:23:21 UTC
For Debian I have to install extra packages for alsa or pulseaudio gstreamer support: gstreamer1.0-alsa and gstreamer1.0-pulseaudio.

What happens if you install these?
Comment 9 Oystein Sture 2019-06-12 10:27:41 UTC
Thanks, installing the package gst-plugins-good on arch linux resolved the issue (https://wiki.archlinux.org/index.php/GStreamer). At any rate, I think the patch you've proposed is the expected behavior for systems without an audio interface
Comment 10 Jan-Marek Glogowski 2019-06-12 16:12:20 UTC
(In reply to Oystein Sture from comment #9)
> At any rate, I think the patch you've proposed is the expected behavior for
> systems without an audio interface

Yes - this is definitely a bug in LO to ignore the result of the audio function calls, even if it is very uncommon today to run LO on a system without a "proper" (as expected by LO) GStreamer audio setup. Apparently nobody did since 2016 :-)

The patch is already there and fixes the crash for me, when I "chmod -r" the needed plugins.
Comment 11 Commit Notification 2019-06-12 23:48:35 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/5e6af47dc87a55fea595c952ea3e59c93d0620db%5E%21

tdf#125821 don't crash on missing gstreamer plugins

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2019-06-13 02:27:35 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/142696e71e15db3c112796c43630bdfa6c634fa0%5E%21

tdf#125821 don't crash on missing gstreamer plugins

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2019-06-13 16:42:47 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/10850d0d8406a7c0b1524788bf9f6530ea4012e8%5E%21

tdf#125821 don't crash on missing gstreamer plugins

It will be available in 6.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.