Download it now!
Bug 125944 - Regression due to KDE5 VCL: calc shows formula tooltips covering the formula bar, making it impossible to see what one is typing
Summary: Regression due to KDE5 VCL: calc shows formula tooltips covering the formula ...
Status: RESOLVED DUPLICATE of bug 123779
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.2.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2019-06-15 22:33 UTC by sergio.callegari
Modified: 2019-06-18 09:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2019-06-15 22:33:36 UTC
Description:
Summary says it all. While the gtk3 VCL puts the tooltip under the formula bar, the KDE5 VCL ends up positioning the tooltip right over the place where one might be trying to type, edit a formula, completely hiding the formula.

Steps to Reproduce:
See description

Actual Results:
See description

Expected Results:
See description


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 sergio.callegari 2019-06-16 09:36:42 UTC
Made some comparison with the gtk and KDE4 VCLs.

With the gtk3 VCL, the tooltip baloon is always shown completely above or below the item it refers to and it is shaped to precisely point at the item it describes (looks like a baloon with a little on the top or on the bottom).

With the KDE4 VCL, the tooltip baloon is always shown completely above or below the item it refers to, it is shaped as a mere rectangle, aesthetically less pleasing than the gtk3 version, but I guess this is a Qt limitation.

With the KDE5 VCL, the tooltip baloon looks like the one in KDE4, but control on the position and shape is gone. The tooltip often is displayed in a multiline fashion, taking a lot of vertical space and quite often goes over what it is referring to, hiding it and hindering the possibility of editing the item.
 
Because this issue makes it almost impossible to make any serious usage of the formula bar in calc, I think it should be considered for bug 124044.

As a quick workaround, I suggest users to disable tooltips when using calc with KDE5.
Comment 2 Michael Weghorn 2019-06-18 06:06:26 UTC
Is this the same as bug 123779?
I'm not 100 % sure what you mean by "formula bar", but I don't get any distracting tooltips when typing in the "Input line" just below the toolbar instead (with current master build of LibreOffice).

(In reply to sergio.callegari from comment #1)
> Because this issue makes it almost impossible to make any serious usage of
> the formula bar in calc, I think it should be considered for bug 124044.

The best way to keep track of bugs specific to the kde5 VCL plugin is via the meta bug 102495, so if you add "102495" in the "Blocks" field for any such bug, all people subscribed to that one will automatically receive an email and thus be aware of any new kde5-specific bugs so they can take a look (no need to explicitly mention in bug 124044 in addition).
Comment 3 sergio.callegari 2019-06-18 06:32:32 UTC
@Michael
Thanks for teaching me about meta bug 102495.

And, yes: the issue seems very similar to 123779, with the difference that I have noticed it while typing in the upper "formula bar" (which appears to be called "input line", actually), i.e. in the space for input right below the toolbars. The screenshots made by Roman Kuznetsov (who has been much more efficient than me in this) totally confirm the issue.

I think that the two bugs may be merged (possibly changing the title to something like "Regression due to KDE5 VCL: calc shows tooltips covering the text that is being typed", to indicate that it is not just an issue with cells, nor with the formula bar, but both).

I would like to add that the KDE5 VCL often causes the tooltip to be displayed breaking the text in multiple lines, which exacerbates the issue.

Finally, it would be great if the KDE5 VCL could provide "shaped" tooltips as in gtk3, where the little arrow points at the place the tooltip refers to. If this is impossible due to how qt5 handles tooltips, I wonder whether LibO could file an enhancement request to qt, probably having much better chances of being heard than any individual user.
Comment 4 Jan-Marek Glogowski 2019-06-18 09:54:23 UTC
There is already a bug about tooltip placement. I guess all have the same origin.

*** This bug has been marked as a duplicate of bug 123779 ***