Bug 126017 - Crash swlo!SwNode::EndOfSectionIndex
Summary: Crash swlo!SwNode::EndOfSectionIndex
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:6.4.0 target:6.3.0.1
Keywords: bibisected, bisected, haveBacktrace, needUITest, regression
Depends on:
Blocks:
 
Reported: 2019-06-19 22:42 UTC by Telesto
Modified: 2019-07-15 18:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (28.09 KB, application/vnd.oasis.opendocument.text)
2019-06-19 22:42 UTC, Telesto
Details
BT without symbols (6.21 KB, text/plain)
2019-06-19 22:42 UTC, Telesto
Details
gdb bt (37.65 KB, text/plain)
2019-06-20 19:11 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2019-06-19 22:42:02 UTC
Description:
Crash swlo!SwNode::EndOfSectionIndex

Steps to Reproduce:
1. Open the attached file
2. Make edits, delete the TOC, redo, undo, edit -> will crash.. at some point (haven't figured out the minimum steps, but I have a screencast)

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.4.0.0.alpha0+ (x86)
Build ID: 60271c4433372097ef5ecc74e522532ebf5af8e0
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-06-19_05:53:39
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: threaded
Comment 1 Telesto 2019-06-19 22:42:23 UTC
Created attachment 152299 [details]
Example file
Comment 2 Telesto 2019-06-19 22:42:38 UTC
Created attachment 152300 [details]
BT without symbols
Comment 3 Telesto 2019-06-20 07:17:13 UTC
1. Open the attached file
2. Right click on TOC -> Edit index 
3. Change the title
4. Press OK
5. CTRL+Z
6. Repeat 2-4
7. Press CTRL+Z twice
Comment 4 Oliver Brinzing 2019-06-20 08:20:34 UTC
(In reply to Telesto from comment #3)
> 1. Open the attached file
> 2. Right click on TOC -> Edit index 
> 3. Change the title
> 4. Press OK
> 5. CTRL+Z
> 6. Repeat 2-4
> 7. Press CTRL+Z twice

maybe same root cause:

https://bugs.documentfoundation.org/show_bug.cgi?id=126014
[Bug 126014] Crash on & opening recovered file after removing title from long(?) Table Of Contents [EDITING] [FILEOPEN]
Comment 5 Xisco Faulí 2019-06-20 10:45:09 UTC
(In reply to Telesto from comment #3)
> 1. Open the attached file
> 2. Right click on TOC -> Edit index 
> 3. Change the title
> 4. Press OK
> 5. CTRL+Z
> 6. Repeat 2-4
> 7. Press CTRL+Z twice

I can't reproduce it in

Version: 6.4.0.0.alpha0+
Build ID: af37bb23f63b209af1193e20177c3aacbd777543
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Could you please be more precise on how to reproduce it reliably ?
Comment 6 Telesto 2019-06-20 12:23:26 UTC
1. Open the attached file
2. Right click on TOC -> Edit index 
3. Change the title
4. Press OK
5. Delete the TOC -> Right click delete table of content
6. CTRL+Z 2x
7. Right click on TOC -> Edit index
8. Change the title
9. Press OK -> Crash

HMM -> This is a different crash.. However steps are more or less similar
Comment 7 Telesto 2019-06-20 12:28:02 UTC
1. Open the attached file
2. Right click on TOC -> Edit index 
3. Change the title
4. Press OK
5. Delete the TOC -> Right click delete table of content
6. CTRL+Z (only once)
7. Right click on TOC -> Edit index
8. Change the title
9. Press OK 
10. Delete the TOC -> Right click delete table of content
11. Hold CTRL+Z -> Crash ->  swlo!SwNode::EndOfSectionIndex
Comment 8 Xisco Faulí 2019-06-20 15:33:13 UTC
(In reply to Telesto from comment #7)
> 1. Open the attached file
> 2. Right click on TOC -> Edit index 
> 3. Change the title
> 4. Press OK
> 5. Delete the TOC -> Right click delete table of content
> 6. CTRL+Z (only once)
> 7. Right click on TOC -> Edit index
> 8. Change the title
> 9. Press OK 
> 10. Delete the TOC -> Right click delete table of content
> 11. Hold CTRL+Z -> Crash ->  swlo!SwNode::EndOfSectionIndex

Reproduced in

Version: 6.4.0.0.alpha0+
Build ID: af37bb23f63b209af1193e20177c3aacbd777543
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 9 Xisco Faulí 2019-06-20 15:36:58 UTC
No reproduced in

Version: 5.4.0.0.alpha1+
Build ID: 9feb7f7039a3b59974cbf266922177e961a52dd1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

likely related to bug 124677. I don't think it can be bisected as it freezes while changing the name ( bug 126014 ).

@Michael, I thought you might be interested in this issue...
Comment 10 Julien Nabet 2019-06-20 19:11:10 UTC
Created attachment 152319 [details]
gdb bt

On pc Debian x86-64 with master sources updated today, I could reproduce the crash.

I attached the whole console logs (including bt) because there are lots of warns which may be related.
Comment 11 Julien Nabet 2019-06-20 19:11:47 UTC
(my bt - see previous comment - is from an assert but may help anyway)
Comment 12 Xisco Faulí 2019-06-25 11:21:22 UTC
Actually this is a regression from 

https://cgit.freedesktop.org/libreoffice/core/commit/?id=4f0b568ef35353b276ae560fb43502b6f6b2bfdb

author	Michael Stahl <Michael.Stahl@cib.de>	2019-04-25 18:31:08 +0200
committer	Michael Stahl <Michael.Stahl@cib.de>	2019-04-26 15:55:29 +0200
commit	4f0b568ef35353b276ae560fb43502b6f6b2bfdb (patch)
tree	b336c36b1207fa59ee6402ec2673e3017be48760
parent	41df42a8dc758571dd7635c358a09bf412051649 (diff)
tdf#38703 i#42807 sw: stop clearing Undo stack on ToX Update

Bisected with: bibisect-linux64-6.3

Adding Cc: to Michael Stahl
Comment 13 Michael Stahl (CIB) 2019-06-25 16:30:48 UTC
this is obviously unrelated to layout changes

fixed on master
Comment 14 Commit Notification 2019-06-25 16:31:52 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/4999c99529f1b1543ef110da9e6c0dcbd9f73032%5E%21

tdf#126017 sw: do not restore SwFormatContent in SwUndoFormatAttr

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Xisco Faulí 2019-06-26 07:16:58 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: fe855eda54faf6196ad9dea12d8dc090b6d6c1da
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Michael Stahl, thanks for fixing this issue!!
Comment 16 Commit Notification 2019-06-26 07:18:31 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/a9fce4cd52c880a0024fb3c921110a1da5400972%5E%21

tdf#126017 sw: do not restore SwFormatContent in SwUndoFormatAttr

It will be available in 6.3.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2019-07-15 18:35:46 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/07ea5933b70d442f3c53b16df56772de3dca8392%5E%21

uitest for bug tdf#126017

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.