Bug Hunting Session
Bug 126172 - Tools-Options cannot be opened if GPG4win is installed and many PGP keys set (Windows 10?)
Summary: Tools-Options cannot be opened if GPG4win is installed and many PGP keys set ...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.4.2 release
Hardware: All Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 126160 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-06-30 12:05 UTC by Helmut Leininger
Modified: 2019-07-15 17:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Helmut Leininger 2019-06-30 12:05:27 UTC
Description:
Window to set Opteions cannot be opened. 
If you try by Extras/Options a prcess gpg.exe ist started und eats 30% of CPU. But it seems LO does not see an answer. LO gets unresponsive ("Keine Rückmeldung").
If gpg.exe is killed, the Options window opens immediately

Steps to Reproduce:
1. install LO 6.2 (or 6.1 or 6.3 beta2), same behavious
2. install GPG4win
3. start LO, try Extras/Options

Actual Results:
LO hangs

Expected Results:
should work


Reproducible: Always


User Profile Reset: Yes



Additional Info:
[Information automatically included from LibreOffice]
Locale: de
Module: StartModule
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes

Windows 10, last updates
GPG4win 3.1.9
LO 6.2.4.2, 6.1.6, 6.3.0 beta-2
Comment 1 Oliver Brinzing 2019-06-30 16:30:06 UTC
*** Bug 126160 has been marked as a duplicate of this bug. ***
Comment 2 Helmut Leininger 2019-07-01 05:46:46 UTC
I made another try.
This time, I decided to wait for maybe hours and did not kill gpg.exe.

After about half an hour, the Options window opened and the functionality seemd to be ok, also keys for encription could be selected.

Now, opening the Option window takes about 20 to 25 seconds, regardless if LO is restarted or not.
Comment 3 Helmut Leininger 2019-07-02 14:52:47 UTC
Maybe it is an issue of GNUPG gpg.exe. Also running gpg -K takes very long time.
Comment 4 Timur 2019-07-03 10:22:54 UTC
I'll confirm because you found a cause and we have a duplicate. 
But this well may be NotOutBug, we need to test. 
Did you use GPG4win before, does it depend on version? 
What's the relation GPG4win-LO, do you have GPG4win set somewhere in LO?
Tools-Options-User data-Signing key?
Comment 5 Timur 2019-07-03 10:35:33 UTC
I cannot reproduce in Windows 7. Not clear if some steps missing and whether related to Windows 10. Patrick didn't specify but Dieter didn't reproduce in W10.
Comment 6 Patrick Schönbach 2019-07-03 10:39:50 UTC
I am on W10.
Comment 7 Patrick Schönbach 2019-07-03 10:47:16 UTC
Yes, it used to work before, but I am not sure, when it stopped working. Currently, no keys are selected, and I also cannot select any. Probably, because I have to kill gpg2.exe in order to get the dialog?
Comment 8 Timur 2019-07-03 14:12:48 UTC
I still don't see a connection LO-GPG and steps to reproduce problem.
Comment 9 Helmut Leininger 2019-07-03 14:27:08 UTC
My guess:
as of LO 6.x, LO supports encripting/signing PDF by openpgp (bottom of Options / User data)

When opening the Options window, LO looks if GNUPG is installed. If yes, it asks gpg (in Windows most probably part of GPG4win) to check keys.
Comment 10 QA Administrators 2019-07-04 02:48:08 UTC Comment hidden (obsolete)
Comment 11 Helmut Leininger 2019-07-04 06:30:11 UTC
I deleted a lot of keys / certificates that I don't need any more. The problem seems to have gone.
Comment 12 Timur 2019-07-04 12:36:35 UTC
Partick, please check your keys. I just have one and I don't repro this.
Comment 13 Patrick Schönbach 2019-07-04 13:54:52 UTC
Reduced it to 34 keys (Is that many?). Did not help. At least, after several minutes, LO still hangs.
Comment 14 Timur 2019-07-05 07:32:01 UTC
I'll confirm now based on those 2 reports. Looks like "many keys" is the problem. 
Patrick says 34. It would be good for Helmut to note how many he had before.
Comment 15 Helmut Leininger 2019-07-05 08:00:57 UTC
I did not count the number of keys before. Butr I would estimate it had been 50 or more. I reduced to 15.

Note:
Also the deletion of the keys took quite a time. You need to be patient.
Comment 16 Patrick Schönbach 2019-07-05 16:46:54 UTC
I posted this: https://dev.gnupg.org/T4615
Comment 17 Patrick Schönbach 2019-07-15 17:50:42 UTC
Thia turns out to be a GnuPG problem.