Bug 126173 - FILEOPEN RTF: Autoshape textbox not imported
Summary: FILEOPEN RTF: Autoshape textbox not imported
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.3.0.4 release
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.4.0 target:6.3.0.2 target:6.2.6
Keywords: bibisected, bisected, regression
: 104110 (view as bug list)
Depends on:
Blocks: RTF-Shapes
  Show dependency treegraph
 
Reported: 2019-07-01 01:24 UTC by Aron Budea
Modified: 2019-07-11 09:12 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample RTF (44.00 KB, application/msword)
2019-07-01 01:24 UTC, Aron Budea
Details
Sample exported as PDF from Word (80.09 KB, application/pdf)
2019-07-01 01:25 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2019-07-01 01:24:44 UTC
Created attachment 152477 [details]
Sample RTF

The attached RTF was created in Word, and contains an autoshape text box.
Open it in Writer.

=> Text box not shown.

Observed using LO 6.4.0.0.alpha0+ (58ef8c188b6bb2ed307f5e825cc7e475c33d0c33), 4.4.0.3 / Windows 7.
In 4.0.0.3 the text box is imported, though doesn't look perfect, but can be considered a much better state.
=> regression
Comment 1 Aron Budea 2019-07-01 01:25:47 UTC
Created attachment 152478 [details]
Sample exported as PDF from Word
Comment 2 Aron Budea 2019-07-01 01:30:21 UTC
In 4.2.0.4 it looks good.
In 4.3.0.4 it fails opening with input/output error.
In 4.4.0.3 textbox isn't imported.
Comment 3 Aron Budea 2019-07-01 01:50:49 UTC
Bibisected to the following commit using repo bibisect-win32-4.3. Adding Cc: to Miklos Vajna (committer).

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c6b99eedda03461202f9bf012a422dfd81da72ec
author		sushil_shinde <sushil.shinde@synerzip.com>	2014-02-28 15:33:10 +0530
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2014-03-07 03:19:07 -0600

fdo#75158 : Handled unsupported fields for docx file.
Comment 4 Regina Henschel 2019-07-01 23:35:08 UTC
The frame is listed in Navigator, but hidden. The problem is connected to its anchor "In Line with Text".
Comment 5 Xisco Faulí 2019-07-03 16:24:26 UTC
Maybe the same root cause as bug 104110
Comment 6 Commit Notification 2019-07-09 07:09:25 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/9a15a75dfa7ab8c5d51c411e0e39d68d22b7587a%5E%21

tdf#126173 RTF import: fix lost SHAPE fields

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2019-07-09 09:16:26 UTC
*** Bug 104110 has been marked as a duplicate of this bug. ***
Comment 8 Xisco Faulí 2019-07-09 09:25:37 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 7a0164f0d82d91e2ac481d74cdacfe9a7ad6080f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!!
Comment 9 Commit Notification 2019-07-09 10:54:27 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/0e6fdee15df8928c33308b353a7b80de150aca6b%5E%21

tdf#126173 RTF import: fix lost SHAPE fields

It will be available in 6.3.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-07-11 09:12:01 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/45cf5d55221b92e395948cb2e36d6ae6f056b1a3%5E%21

tdf#126173 RTF import: fix lost SHAPE fields

It will be available in 6.2.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.